All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Lechner <david@lechnology.com>
To: William Breathitt Gray <vilhelm.gray@gmail.com>
Cc: jic23@kernel.org, linux-stm32@st-md-mailman.stormreply.com,
	kernel@pengutronix.de, a.fatoum@pengutronix.de,
	kamel.bouhara@bootlin.com, gwendal@chromium.org,
	alexandre.belloni@bootlin.com, linux-iio@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, syednwaris@gmail.com,
	patrick.havelange@essensium.com, fabrice.gasnier@st.com,
	mcoquelin.stm32@gmail.com, alexandre.torgue@st.com,
	o.rempel@pengutronix.de, jarkko.nikula@linux.intel.com,
	Pavel Machek <pavel@ucw.cz>
Subject: Re: [PATCH v12 12/17] tools/counter: Create Counter tools
Date: Sun, 11 Jul 2021 09:05:32 -0500	[thread overview]
Message-ID: <56fb48ac-335d-f112-6370-38ad35ad72f0@lechnology.com> (raw)
In-Reply-To: <YOrVy7Ba117s1maQ@shinobu>

On 7/11/21 6:28 AM, William Breathitt Gray wrote:
> On Sat, Jul 10, 2021 at 11:53:35AM -0500, David Lechner wrote:
>> On 7/5/21 3:19 AM, William Breathitt Gray wrote:

>>> +	{
>>> +		/* Component data: Count 0 count */
>>> +		.component.type = COUNTER_COMPONENT_COUNT,
>>> +		.component.scope = COUNTER_SCOPE_COUNT,
>>> +		.component.parent = 0,
>>> +		/* Event type: Index */
>>> +		.event = COUNTER_EVENT_INDEX,
>>> +		/* Device event channel 0 */
>>> +		.channel = 0,
>>> +	},
>>> +	{
>>> +		/* Component data: Count 1 count */
>>> +		.component.type = COUNTER_COMPONENT_COUNT,
>>> +		.component.scope = COUNTER_SCOPE_COUNT,
>>> +		.component.parent = 1,
>>> +		/* Event type: Index */
>>> +		.event = COUNTER_EVENT_INDEX,
>>> +		/* Device event channel 0 */
>>> +		.channel = 0,
>>> +	},
>>> +};
>>> +
>>> +int main(void)
>>> +{
>>> +	int fd;
>>> +	int ret;
>>> +	struct counter_event event_data[2];
>>> +
>>> +	fd = open("/dev/counter0", O_RDWR);
>>> +	if (fd == -1) {
>>> +		perror("Unable to open /dev/counter0");
>>> +		return -errno;
>>
>> errno is no longer valid after calling perror(). Since this
>> is example code, we can just return 1 instead (exit codes
>> positive number between 0 and 255 so -1 would be 255).
> 
> Ack.
> 
>>> +	}
>>> +
>>> +	ret = ioctl(fd, COUNTER_ADD_WATCH_IOCTL, watches);
>>> +	if (ret == -1) {
>>> +		perror("Error adding watches[0]");
>>> +		return -errno;
>>> +	}
>>> +	ret = ioctl(fd, COUNTER_ADD_WATCH_IOCTL, watches + 1);
>>> +	if (ret == -1) {
>>> +		perror("Error adding watches[1]");
>>> +		return -errno;
>>> +	}
>>> +	ret = ioctl(fd, COUNTER_ENABLE_EVENTS_IOCTL);
>>> +	if (ret == -1) {
>>> +		perror("Error enabling events");
>>> +		return -errno;
>>> +	}
>>> +
>>> +	for (;;) {
>>> +		ret = read(fd, event_data, sizeof(event_data));
>>> +		if (ret == -1) {
>>> +			perror("Failed to read event data");
>>> +			return -errno;
>>> +		}
>>> +
>>> +		if (ret != sizeof(event_data)) {
>>> +			fprintf(stderr, "Failed to read event data\n");
>>> +			return -EIO;
>>> +		}
>>> +
>>> +		printf("Timestamp 0: %llu\tCount 0: %llu\n"
>>> +		       "Error Message 0: %s\n"
>>> +		       "Timestamp 1: %llu\tCount 1: %llu\n"
>>> +		       "Error Message 1: %s\n",
>>> +		       (unsigned long long)event_data[0].timestamp,
>>> +		       (unsigned long long)event_data[0].value,
>>> +		       strerror(event_data[0].status),
>>> +		       (unsigned long long)event_data[1].timestamp,
>>> +		       (unsigned long long)event_data[1].value,
>>> +		       strerror(event_data[1].status));
>>> +	}
>>
>> Aren't the Count 0 and Count 1 events independent? Why should we expect to
>> always get both events at the same time in the same order?
> 
> Watch 0 and Watch 1 are both triggered by the same event: a
> COUNTER_EVENT_INDEX event on device event channel 0. If we had set
> channel to 1 for Watch 1, then we would have two independent events, but
> in this case both Watches have their respective channel set to 0.

The thing that jumped out to me is that they have different parents.
But I guess I forgot that the event itself always has a scope of
device and that the component just says what value to record and
is otherwise independent of the event.


WARNING: multiple messages have this Message-ID (diff)
From: David Lechner <david@lechnology.com>
To: William Breathitt Gray <vilhelm.gray@gmail.com>
Cc: jic23@kernel.org, linux-stm32@st-md-mailman.stormreply.com,
	kernel@pengutronix.de, a.fatoum@pengutronix.de,
	kamel.bouhara@bootlin.com, gwendal@chromium.org,
	alexandre.belloni@bootlin.com, linux-iio@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, syednwaris@gmail.com,
	patrick.havelange@essensium.com, fabrice.gasnier@st.com,
	mcoquelin.stm32@gmail.com, alexandre.torgue@st.com,
	o.rempel@pengutronix.de, jarkko.nikula@linux.intel.com,
	Pavel Machek <pavel@ucw.cz>
Subject: Re: [PATCH v12 12/17] tools/counter: Create Counter tools
Date: Sun, 11 Jul 2021 09:05:32 -0500	[thread overview]
Message-ID: <56fb48ac-335d-f112-6370-38ad35ad72f0@lechnology.com> (raw)
In-Reply-To: <YOrVy7Ba117s1maQ@shinobu>

On 7/11/21 6:28 AM, William Breathitt Gray wrote:
> On Sat, Jul 10, 2021 at 11:53:35AM -0500, David Lechner wrote:
>> On 7/5/21 3:19 AM, William Breathitt Gray wrote:

>>> +	{
>>> +		/* Component data: Count 0 count */
>>> +		.component.type = COUNTER_COMPONENT_COUNT,
>>> +		.component.scope = COUNTER_SCOPE_COUNT,
>>> +		.component.parent = 0,
>>> +		/* Event type: Index */
>>> +		.event = COUNTER_EVENT_INDEX,
>>> +		/* Device event channel 0 */
>>> +		.channel = 0,
>>> +	},
>>> +	{
>>> +		/* Component data: Count 1 count */
>>> +		.component.type = COUNTER_COMPONENT_COUNT,
>>> +		.component.scope = COUNTER_SCOPE_COUNT,
>>> +		.component.parent = 1,
>>> +		/* Event type: Index */
>>> +		.event = COUNTER_EVENT_INDEX,
>>> +		/* Device event channel 0 */
>>> +		.channel = 0,
>>> +	},
>>> +};
>>> +
>>> +int main(void)
>>> +{
>>> +	int fd;
>>> +	int ret;
>>> +	struct counter_event event_data[2];
>>> +
>>> +	fd = open("/dev/counter0", O_RDWR);
>>> +	if (fd == -1) {
>>> +		perror("Unable to open /dev/counter0");
>>> +		return -errno;
>>
>> errno is no longer valid after calling perror(). Since this
>> is example code, we can just return 1 instead (exit codes
>> positive number between 0 and 255 so -1 would be 255).
> 
> Ack.
> 
>>> +	}
>>> +
>>> +	ret = ioctl(fd, COUNTER_ADD_WATCH_IOCTL, watches);
>>> +	if (ret == -1) {
>>> +		perror("Error adding watches[0]");
>>> +		return -errno;
>>> +	}
>>> +	ret = ioctl(fd, COUNTER_ADD_WATCH_IOCTL, watches + 1);
>>> +	if (ret == -1) {
>>> +		perror("Error adding watches[1]");
>>> +		return -errno;
>>> +	}
>>> +	ret = ioctl(fd, COUNTER_ENABLE_EVENTS_IOCTL);
>>> +	if (ret == -1) {
>>> +		perror("Error enabling events");
>>> +		return -errno;
>>> +	}
>>> +
>>> +	for (;;) {
>>> +		ret = read(fd, event_data, sizeof(event_data));
>>> +		if (ret == -1) {
>>> +			perror("Failed to read event data");
>>> +			return -errno;
>>> +		}
>>> +
>>> +		if (ret != sizeof(event_data)) {
>>> +			fprintf(stderr, "Failed to read event data\n");
>>> +			return -EIO;
>>> +		}
>>> +
>>> +		printf("Timestamp 0: %llu\tCount 0: %llu\n"
>>> +		       "Error Message 0: %s\n"
>>> +		       "Timestamp 1: %llu\tCount 1: %llu\n"
>>> +		       "Error Message 1: %s\n",
>>> +		       (unsigned long long)event_data[0].timestamp,
>>> +		       (unsigned long long)event_data[0].value,
>>> +		       strerror(event_data[0].status),
>>> +		       (unsigned long long)event_data[1].timestamp,
>>> +		       (unsigned long long)event_data[1].value,
>>> +		       strerror(event_data[1].status));
>>> +	}
>>
>> Aren't the Count 0 and Count 1 events independent? Why should we expect to
>> always get both events at the same time in the same order?
> 
> Watch 0 and Watch 1 are both triggered by the same event: a
> COUNTER_EVENT_INDEX event on device event channel 0. If we had set
> channel to 1 for Watch 1, then we would have two independent events, but
> in this case both Watches have their respective channel set to 0.

The thing that jumped out to me is that they have different parents.
But I guess I forgot that the event itself always has a scope of
device and that the component just says what value to record and
is otherwise independent of the event.


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2021-07-11 14:05 UTC|newest]

Thread overview: 101+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-05  8:18 [PATCH v12 00/17] Introduce the Counter character device interface William Breathitt Gray
2021-07-05  8:18 ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 01/17] counter: 104-quad-8: Return error when invalid mode during ceiling_write William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 02/17] counter: Return error code on invalid modes William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-09 17:40   ` David Lechner
2021-07-09 17:40     ` David Lechner
2021-07-05  8:18 ` [PATCH v12 03/17] counter: Standardize to ERANGE for limit exceeded errors William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 04/17] counter: Rename counter_signal_value to counter_signal_level William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 05/17] counter: Rename counter_count_function to counter_function William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 06/17] counter: Internalize sysfs interface code William Breathitt Gray
2021-07-11  9:49   ` Syed Nayyar Waris
2021-07-11 11:42   ` Jonathan Cameron
2021-07-11 11:42     ` Jonathan Cameron
2021-07-05  8:18 ` [PATCH v12 07/17] counter: Update counter.h comments to reflect sysfs internalization William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-09 17:49   ` David Lechner
2021-07-09 17:49     ` David Lechner
2021-07-10  9:41     ` William Breathitt Gray
2021-07-10  9:41       ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 08/17] docs: counter: Update " William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-09 17:56   ` David Lechner
2021-07-09 17:56     ` David Lechner
2021-07-05  8:18 ` [PATCH v12 09/17] counter: Move counter enums to uapi header William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 10/17] counter: Add character device interface William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-10 19:37   ` David Lechner
2021-07-10 19:37     ` David Lechner
2021-07-11 12:20   ` Jonathan Cameron
2021-07-11 12:20     ` Jonathan Cameron
2021-07-12 10:28     ` William Breathitt Gray
2021-07-12 10:28       ` William Breathitt Gray
2021-07-05  8:18 ` [PATCH v12 11/17] docs: counter: Document " William Breathitt Gray
2021-07-05  8:18   ` William Breathitt Gray
2021-07-10 20:15   ` David Lechner
2021-07-10 20:15     ` David Lechner
2021-07-11 10:41     ` William Breathitt Gray
2021-07-11 10:41       ` William Breathitt Gray
2021-07-05  8:19 ` [PATCH v12 12/17] tools/counter: Create Counter tools William Breathitt Gray
2021-07-05  8:19   ` William Breathitt Gray
2021-07-10 16:53   ` David Lechner
2021-07-10 16:53     ` David Lechner
2021-07-11 11:28     ` William Breathitt Gray
2021-07-11 11:28       ` William Breathitt Gray
2021-07-11 14:05       ` David Lechner [this message]
2021-07-11 14:05         ` David Lechner
2021-07-11 13:22   ` Jonathan Cameron
2021-07-11 13:22     ` Jonathan Cameron
2021-07-05  8:19 ` [PATCH v12 13/17] counter: Implement signalZ_action_component_id sysfs attribute William Breathitt Gray
2021-07-05  8:19   ` William Breathitt Gray
2021-07-10 16:20   ` David Lechner
2021-07-10 16:20     ` David Lechner
2021-07-05  8:19 ` [PATCH v12 14/17] counter: Implement *_component_id sysfs attributes William Breathitt Gray
2021-07-05  8:19   ` William Breathitt Gray
2021-07-10 17:06   ` David Lechner
2021-07-10 17:06     ` David Lechner
2021-07-11 13:28     ` Jonathan Cameron
2021-07-11 13:28       ` Jonathan Cameron
2021-07-11 14:08       ` David Lechner
2021-07-11 14:08         ` David Lechner
2021-07-12 10:19         ` Jonathan Cameron
2021-07-12 10:19           ` Jonathan Cameron
2021-07-05  8:19 ` [PATCH v12 15/17] counter: Implement events_queue_size sysfs attribute William Breathitt Gray
2021-07-05  8:19   ` William Breathitt Gray
2021-07-06 11:40   ` Jarkko Nikula
2021-07-06 11:40     ` Jarkko Nikula
2021-07-10 10:25     ` William Breathitt Gray
2021-07-10 10:25       ` William Breathitt Gray
2021-07-10 15:43       ` David Lechner
2021-07-10 15:43         ` David Lechner
2021-07-10 16:08         ` David Lechner
2021-07-10 16:08           ` David Lechner
2021-07-10 17:53           ` David Lechner
2021-07-10 17:53             ` David Lechner
2021-07-11  9:12         ` William Breathitt Gray
2021-07-11  9:12           ` William Breathitt Gray
2021-07-05  8:19 ` [PATCH v12 16/17] counter: 104-quad-8: Replace mutex with spinlock William Breathitt Gray
2021-07-05  8:19   ` William Breathitt Gray
2021-07-05  8:19 ` [PATCH v12 17/17] counter: 104-quad-8: Add IRQ support for the ACCES 104-QUAD-8 William Breathitt Gray
2021-07-05  8:19   ` William Breathitt Gray
2021-07-11 13:44   ` Jonathan Cameron
2021-07-11 13:44     ` Jonathan Cameron
2021-07-12 10:59     ` William Breathitt Gray
2021-07-12 10:59       ` William Breathitt Gray
2021-07-06 11:40 ` [PATCH v12 00/17] Introduce the Counter character device interface Jarkko Nikula
2021-07-06 11:40   ` Jarkko Nikula
2021-07-07  0:28   ` William Breathitt Gray
2021-07-07  0:28     ` William Breathitt Gray
2021-07-11 13:48 ` Jonathan Cameron
2021-07-11 13:48   ` Jonathan Cameron
2021-07-12 10:48   ` William Breathitt Gray
2021-07-12 10:48     ` William Breathitt Gray
2021-07-05 16:36 [PATCH v12 15/17] counter: Implement events_queue_size sysfs attribute kernel test robot
2021-07-06  7:48 ` Dan Carpenter
2021-07-06  7:48 ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=56fb48ac-335d-f112-6370-38ad35ad72f0@lechnology.com \
    --to=david@lechnology.com \
    --cc=a.fatoum@pengutronix.de \
    --cc=alexandre.belloni@bootlin.com \
    --cc=alexandre.torgue@st.com \
    --cc=fabrice.gasnier@st.com \
    --cc=gwendal@chromium.org \
    --cc=jarkko.nikula@linux.intel.com \
    --cc=jic23@kernel.org \
    --cc=kamel.bouhara@bootlin.com \
    --cc=kernel@pengutronix.de \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=o.rempel@pengutronix.de \
    --cc=patrick.havelange@essensium.com \
    --cc=pavel@ucw.cz \
    --cc=syednwaris@gmail.com \
    --cc=vilhelm.gray@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.