All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andy Shevchenko <andy.shevchenko@gmail.com>
To: Hans de Goede <hdegoede@redhat.com>
Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	Daniel Vetter <daniel@ffwll.ch>, David Airlie <airlied@linux.ie>,
	Jani Nikula <jani.nikula@linux.intel.com>,
	Joonas Lahtinen <joonas.lahtinen@linux.intel.com>,
	Rodrigo Vivi <rodrigo.vivi@intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Guenter Roeck <linux@roeck-us.net>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>,
	intel-gfx <intel-gfx@lists.freedesktop.org>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"platform-driver-x86@vger.kernel.org" 
	<platform-driver-x86@vger.kernel.org>,
	"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>
Subject: Re: [PATCH 3/9] drm/connector: Add drm_connector_find_by_fwnode() function (v2)
Date: Tue, 4 May 2021 15:35:27 +0300	[thread overview]
Message-ID: <CAHp75VcsyiWQ_LN8qNQU72SgWyzy0TWcq=N0BLTHHWLSA9Rz1Q@mail.gmail.com> (raw)
In-Reply-To: <afbfa6fb-8b1d-3d3c-96b4-d3045584d2b8@redhat.com>

On Tue, May 4, 2021 at 2:53 PM Hans de Goede <hdegoede@redhat.com> wrote:
> On 5/4/21 10:00 AM, Andy Shevchenko wrote:
> > On Monday, May 3, 2021, Hans de Goede <hdegoede@redhat.com <mailto:hdegoede@redhat.com>> wrote:

...

> >     +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode)
> >     +{
> >     +       struct drm_connector *connector, *found = ERR_PTR(-ENODEV);
> >     +
> >     +       if (!fwnode)
> >     +               return ERR_PTR(-ENODEV);
> >     +
> >     +       mutex_lock(&connector_list_lock);
> >     +
> >     +       list_for_each_entry(connector, &connector_list, global_connector_list_entry) {
> >     +               if (connector->fwnode == fwnode ||
> >     +                   (connector->fwnode && connector->fwnode->secondary == fwnode)) {
> >     +                       drm_connector_get(connector);
> >     +                       found = connector;
> >     +                       break;
> >     +               }
> >     +       }
> >     +
> >     +       mutex_unlock(&connector_list_lock);
> >     +
> >     +       return found;
> >
> > If I am not mistaken you can replace this with
> >
> > return list_entry_is_head();
> >
> > call and remove additional Boolean variable.
>
> Found is not a boolean, it is a pointer to the found connector (or ERR_PTR(-ENODEV)).

Ah, perhaps giving a better name? `match` ?

And to the initial topic, it's either an additional variable or
additional branch in this case. I think additional branch (taking into
account the length of the line or amount of lines) doesn't buy us
anything.

> >     +}

-- 
With Best Regards,
Andy Shevchenko

WARNING: multiple messages have this Message-ID (diff)
From: Andy Shevchenko <andy.shevchenko@gmail.com>
To: Hans de Goede <hdegoede@redhat.com>
Cc: "dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	David Airlie <airlied@linux.ie>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	intel-gfx <intel-gfx@lists.freedesktop.org>,
	"platform-driver-x86@vger.kernel.org"
	<platform-driver-x86@vger.kernel.org>,
	"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>,
	Rodrigo Vivi <rodrigo.vivi@intel.com>,
	Guenter Roeck <linux@roeck-us.net>
Subject: Re: [PATCH 3/9] drm/connector: Add drm_connector_find_by_fwnode() function (v2)
Date: Tue, 4 May 2021 15:35:27 +0300	[thread overview]
Message-ID: <CAHp75VcsyiWQ_LN8qNQU72SgWyzy0TWcq=N0BLTHHWLSA9Rz1Q@mail.gmail.com> (raw)
In-Reply-To: <afbfa6fb-8b1d-3d3c-96b4-d3045584d2b8@redhat.com>

On Tue, May 4, 2021 at 2:53 PM Hans de Goede <hdegoede@redhat.com> wrote:
> On 5/4/21 10:00 AM, Andy Shevchenko wrote:
> > On Monday, May 3, 2021, Hans de Goede <hdegoede@redhat.com <mailto:hdegoede@redhat.com>> wrote:

...

> >     +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode)
> >     +{
> >     +       struct drm_connector *connector, *found = ERR_PTR(-ENODEV);
> >     +
> >     +       if (!fwnode)
> >     +               return ERR_PTR(-ENODEV);
> >     +
> >     +       mutex_lock(&connector_list_lock);
> >     +
> >     +       list_for_each_entry(connector, &connector_list, global_connector_list_entry) {
> >     +               if (connector->fwnode == fwnode ||
> >     +                   (connector->fwnode && connector->fwnode->secondary == fwnode)) {
> >     +                       drm_connector_get(connector);
> >     +                       found = connector;
> >     +                       break;
> >     +               }
> >     +       }
> >     +
> >     +       mutex_unlock(&connector_list_lock);
> >     +
> >     +       return found;
> >
> > If I am not mistaken you can replace this with
> >
> > return list_entry_is_head();
> >
> > call and remove additional Boolean variable.
>
> Found is not a boolean, it is a pointer to the found connector (or ERR_PTR(-ENODEV)).

Ah, perhaps giving a better name? `match` ?

And to the initial topic, it's either an additional variable or
additional branch in this case. I think additional branch (taking into
account the length of the line or amount of lines) doesn't buy us
anything.

> >     +}

-- 
With Best Regards,
Andy Shevchenko
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

WARNING: multiple messages have this Message-ID (diff)
From: Andy Shevchenko <andy.shevchenko@gmail.com>
To: Hans de Goede <hdegoede@redhat.com>
Cc: "dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	Heikki Krogerus <heikki.krogerus@linux.intel.com>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	David Airlie <airlied@linux.ie>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	intel-gfx <intel-gfx@lists.freedesktop.org>,
	"platform-driver-x86@vger.kernel.org"
	<platform-driver-x86@vger.kernel.org>,
	"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>,
	Maxime Ripard <mripard@kernel.org>,
	Guenter Roeck <linux@roeck-us.net>
Subject: Re: [Intel-gfx] [PATCH 3/9] drm/connector: Add drm_connector_find_by_fwnode() function (v2)
Date: Tue, 4 May 2021 15:35:27 +0300	[thread overview]
Message-ID: <CAHp75VcsyiWQ_LN8qNQU72SgWyzy0TWcq=N0BLTHHWLSA9Rz1Q@mail.gmail.com> (raw)
In-Reply-To: <afbfa6fb-8b1d-3d3c-96b4-d3045584d2b8@redhat.com>

On Tue, May 4, 2021 at 2:53 PM Hans de Goede <hdegoede@redhat.com> wrote:
> On 5/4/21 10:00 AM, Andy Shevchenko wrote:
> > On Monday, May 3, 2021, Hans de Goede <hdegoede@redhat.com <mailto:hdegoede@redhat.com>> wrote:

...

> >     +struct drm_connector *drm_connector_find_by_fwnode(struct fwnode_handle *fwnode)
> >     +{
> >     +       struct drm_connector *connector, *found = ERR_PTR(-ENODEV);
> >     +
> >     +       if (!fwnode)
> >     +               return ERR_PTR(-ENODEV);
> >     +
> >     +       mutex_lock(&connector_list_lock);
> >     +
> >     +       list_for_each_entry(connector, &connector_list, global_connector_list_entry) {
> >     +               if (connector->fwnode == fwnode ||
> >     +                   (connector->fwnode && connector->fwnode->secondary == fwnode)) {
> >     +                       drm_connector_get(connector);
> >     +                       found = connector;
> >     +                       break;
> >     +               }
> >     +       }
> >     +
> >     +       mutex_unlock(&connector_list_lock);
> >     +
> >     +       return found;
> >
> > If I am not mistaken you can replace this with
> >
> > return list_entry_is_head();
> >
> > call and remove additional Boolean variable.
>
> Found is not a boolean, it is a pointer to the found connector (or ERR_PTR(-ENODEV)).

Ah, perhaps giving a better name? `match` ?

And to the initial topic, it's either an additional variable or
additional branch in this case. I think additional branch (taking into
account the length of the line or amount of lines) doesn't buy us
anything.

> >     +}

-- 
With Best Regards,
Andy Shevchenko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2021-05-04 12:35 UTC|newest]

Thread overview: 91+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-03 15:46 [PATCH 0/9] drm + usb-type-c: Add support for out-of-band hotplug notification (v2) Hans de Goede
2021-05-03 15:46 ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46 ` Hans de Goede
2021-05-03 15:46 ` [PATCH 1/9] drm/connector: Give connector sysfs devices there own device_type Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-03 15:46 ` [PATCH 2/9] drm/connector: Add a fwnode pointer to drm_connector and register with ACPI Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-04  7:57   ` Andy Shevchenko
2021-05-04  7:57     ` [Intel-gfx] " Andy Shevchenko
2021-05-03 15:46 ` [PATCH 3/9] drm/connector: Add drm_connector_find_by_fwnode() function (v2) Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-04  8:00   ` Andy Shevchenko
2021-05-04  8:00     ` [Intel-gfx] " Andy Shevchenko
2021-05-04 11:53     ` Hans de Goede
2021-05-04 11:53       ` [Intel-gfx] " Hans de Goede
2021-05-04 11:53       ` Hans de Goede
2021-05-04 12:35       ` Andy Shevchenko [this message]
2021-05-04 12:35         ` [Intel-gfx] " Andy Shevchenko
2021-05-04 12:35         ` Andy Shevchenko
2021-05-03 15:46 ` [PATCH 4/9] drm/connector: Add support for out-of-band hotplug notification (v2) Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-04 15:10   ` Heikki Krogerus
2021-05-04 15:10     ` [Intel-gfx] " Heikki Krogerus
2021-05-04 15:10     ` Heikki Krogerus
2021-05-04 15:35     ` Hans de Goede
2021-05-04 15:35       ` [Intel-gfx] " Hans de Goede
2021-05-04 15:35       ` Hans de Goede
2021-05-05  9:50       ` Heikki Krogerus
2021-05-05  9:50         ` [Intel-gfx] " Heikki Krogerus
2021-05-05  9:50         ` Heikki Krogerus
2021-05-05 10:42         ` Hans de Goede
2021-05-05 10:42           ` [Intel-gfx] " Hans de Goede
2021-05-05 10:42           ` Hans de Goede
2021-05-03 15:46 ` [PATCH 5/9] drm/i915: Associate ACPI connector nodes with connector entries Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-04  7:52   ` Andy Shevchenko
2021-05-04  7:52     ` [Intel-gfx] " Andy Shevchenko
2021-05-04 14:56     ` Heikki Krogerus
2021-05-04 14:56       ` [Intel-gfx] " Heikki Krogerus
2021-05-04 14:56       ` Heikki Krogerus
2021-05-05  9:07     ` Hans de Goede
2021-05-05  9:07       ` [Intel-gfx] " Hans de Goede
2021-05-05  9:07       ` Hans de Goede
2021-05-05  9:17       ` Andy Shevchenko
2021-05-05  9:17         ` [Intel-gfx] " Andy Shevchenko
2021-05-05  9:17         ` Andy Shevchenko
2021-05-05  9:28         ` Hans de Goede
2021-05-05  9:28           ` [Intel-gfx] " Hans de Goede
2021-05-05  9:28           ` Hans de Goede
2021-05-05 10:02           ` Andy Shevchenko
2021-05-05 10:02             ` [Intel-gfx] " Andy Shevchenko
2021-05-05 10:02             ` Andy Shevchenko
2021-05-05 10:30             ` Hans de Goede
2021-05-05 10:30               ` [Intel-gfx] " Hans de Goede
2021-05-05 10:30               ` Hans de Goede
2021-05-05 12:55               ` Andy Shevchenko
2021-05-05 12:55                 ` [Intel-gfx] " Andy Shevchenko
2021-05-05 12:55                 ` Andy Shevchenko
2021-05-05 10:28         ` Sakari Ailus
2021-05-05 10:28           ` [Intel-gfx] " Sakari Ailus
2021-05-05 10:28           ` Sakari Ailus
2021-05-03 15:46 ` [PATCH 6/9] drm/i915/dp: Add support for out-of-bound hotplug events Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-03 15:46 ` [PATCH 7/9] usb: typec: altmodes/displayport: Make dp_altmode_notify() more generic Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-03 15:46 ` [PATCH 8/9] usb: typec: altmodes/displayport: Notify drm subsys of hotplug events Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-05 10:17   ` Heikki Krogerus
2021-05-05 10:17     ` [Intel-gfx] " Heikki Krogerus
2021-05-05 10:17     ` Heikki Krogerus
2021-05-05 10:44     ` Hans de Goede
2021-05-05 10:44       ` [Intel-gfx] " Hans de Goede
2021-05-05 10:44       ` Hans de Goede
2021-05-03 15:46 ` [PATCH 9/9] platform/x86/intel_cht_int33fe: Correct "displayport" fwnode reference Hans de Goede
2021-05-03 15:46   ` [Intel-gfx] " Hans de Goede
2021-05-03 15:46   ` Hans de Goede
2021-05-19 13:37   ` Hans de Goede
2021-05-19 13:37     ` [Intel-gfx] " Hans de Goede
2021-05-19 13:37     ` Hans de Goede
2021-05-03 20:25 ` [Intel-gfx] ✗ Fi.CI.BUILD: failure for drm + usb-type-c: Add support for out-of-band hotplug notification (rev2) Patchwork
2021-05-04 15:22 ` [PATCH 0/9] drm + usb-type-c: Add support for out-of-band hotplug notification (v2) Heikki Krogerus
2021-05-04 15:22   ` [Intel-gfx] " Heikki Krogerus
2021-05-04 15:22   ` Heikki Krogerus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHp75VcsyiWQ_LN8qNQU72SgWyzy0TWcq=N0BLTHHWLSA9Rz1Q@mail.gmail.com' \
    --to=andy.shevchenko@gmail.com \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hdegoede@redhat.com \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jani.nikula@linux.intel.com \
    --cc=joonas.lahtinen@linux.intel.com \
    --cc=linux-usb@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mripard@kernel.org \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rodrigo.vivi@intel.com \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.