All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 00/18] chardev: QOM cleanups
@ 2020-09-10 19:48 Eduardo Habkost
  2020-09-10 19:48 ` [PATCH 01/18] chardev: Move PARALLEL_CHARDEV macro to common code Eduardo Habkost
                   ` (18 more replies)
  0 siblings, 19 replies; 24+ messages in thread
From: Eduardo Habkost @ 2020-09-10 19:48 UTC (permalink / raw)
  To: qemu-devel
  Cc: Daniel P. Berrange, Paolo Bonzini, Gerd Hoffmann,
	Samuel Thibault, Marc-André Lureau,
	Philippe Mathieu-Daudé

Some chardev QOM cleanup patches had to be dropped from my queue
due to build erros introduced by code movements across ifdef
boundaries at char-parallel.c.  This series redo the changes from
those patches, but the macro renames are now a little different:

In this version I have decided to rename the type checking macros
from *_CHARDEV to CHARDEV_* instead of renaming tye
TYPE_CHARDEV_* constants to TYPE_*_CHARDEV, to make the
identifiers actually match the QOM type name strings
("chardev-*").

Eduardo Habkost (18):
  chardev: Move PARALLEL_CHARDEV macro to common code
  chardev: Move ParallelChardev typedef to common code
  chardev: Use DECLARE_INSTANCE_CHECKER macro for PARALLEL_CHARDEV
  chardev: Rename MOUSE_CHARDEV to CHARDEV_MSMOUSE
  chardev: Rename BAUM_CHARDEV to CHARDEV_BRAILLE
  chardev: Rename FD_CHARDEV to CHARDEV_FD
  chardev: Rename MUX_CHARDEV to CHARDEV_MUX
  chardev: Rename PARALLEL_CHARDEV to CHARDEV_PARALLEL
  chardev: Rename PTY_CHARDEV to CHARDEV_PTY
  chardev: Rename RINGBUF_CHARDEV to CHARDEV_RINGBUF
  chardev: Rename SOCKET_CHARDEV to CHARDEV_SOCKET
  chardev: Rename SPICE_CHARDEV to CHARDEV_SPICE
  chardev: Rename TESTDEV_CHARDEV to CHARDEV_TESTDEV
  chardev: Rename UDP_CHARDEV to CHARDEV_UDP
  chardev: Rename VC_CHARDEV to CHARDEV_VC
  chardev: Rename WCTABLET_CHARDEV to CHARDEV_WCTABLET
  chardev: Rename WIN_CHARDEV to CHARDEV_WIN
  chardev: Rename WIN_STDIO_CHARDEV to CHARDEV_WIN_STDIO

 chardev/chardev-internal.h |  2 +-
 include/chardev/char-fd.h  |  2 +-
 include/chardev/char-win.h |  2 +-
 include/chardev/spice.h    |  2 +-
 chardev/baum.c             | 14 ++++----
 chardev/char-fd.c          | 14 ++++----
 chardev/char-fe.c          |  4 +--
 chardev/char-mux.c         | 22 ++++++------
 chardev/char-parallel.c    | 28 ++++++++--------
 chardev/char-pipe.c        |  2 +-
 chardev/char-pty.c         | 22 ++++++------
 chardev/char-ringbuf.c     | 12 +++----
 chardev/char-serial.c      |  2 +-
 chardev/char-socket.c      | 68 +++++++++++++++++++-------------------
 chardev/char-udp.c         | 14 ++++----
 chardev/char-win-stdio.c   | 14 ++++----
 chardev/char-win.c         | 14 ++++----
 chardev/char.c             |  2 +-
 chardev/msmouse.c          | 12 +++----
 chardev/spice.c            | 16 ++++-----
 chardev/testdev.c          |  4 +--
 chardev/wctablet.c         | 12 +++----
 ui/console.c               | 10 +++---
 ui/gtk.c                   |  8 ++---
 ui/spice-app.c             |  2 +-
 25 files changed, 151 insertions(+), 153 deletions(-)

-- 
2.26.2




^ permalink raw reply	[flat|nested] 24+ messages in thread

end of thread, other threads:[~2020-09-11 13:51 UTC | newest]

Thread overview: 24+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-09-10 19:48 [PATCH 00/18] chardev: QOM cleanups Eduardo Habkost
2020-09-10 19:48 ` [PATCH 01/18] chardev: Move PARALLEL_CHARDEV macro to common code Eduardo Habkost
2020-09-10 19:48 ` [PATCH 02/18] chardev: Move ParallelChardev typedef " Eduardo Habkost
2020-09-10 19:48 ` [PATCH 03/18] chardev: Use DECLARE_INSTANCE_CHECKER macro for PARALLEL_CHARDEV Eduardo Habkost
2020-09-10 19:48 ` [PATCH 04/18] chardev: Rename MOUSE_CHARDEV to CHARDEV_MSMOUSE Eduardo Habkost
2020-09-10 19:48 ` [PATCH 05/18] chardev: Rename BAUM_CHARDEV to CHARDEV_BRAILLE Eduardo Habkost
2020-09-10 19:48 ` [PATCH 06/18] chardev: Rename FD_CHARDEV to CHARDEV_FD Eduardo Habkost
2020-09-10 19:48 ` [PATCH 07/18] chardev: Rename MUX_CHARDEV to CHARDEV_MUX Eduardo Habkost
2020-09-10 19:48 ` [PATCH 08/18] chardev: Rename PARALLEL_CHARDEV to CHARDEV_PARALLEL Eduardo Habkost
2020-09-10 19:48 ` [PATCH 09/18] chardev: Rename PTY_CHARDEV to CHARDEV_PTY Eduardo Habkost
2020-09-10 19:48 ` [PATCH 10/18] chardev: Rename RINGBUF_CHARDEV to CHARDEV_RINGBUF Eduardo Habkost
2020-09-10 19:48 ` [PATCH 11/18] chardev: Rename SOCKET_CHARDEV to CHARDEV_SOCKET Eduardo Habkost
2020-09-10 19:48 ` [PATCH 12/18] chardev: Rename SPICE_CHARDEV to CHARDEV_SPICE Eduardo Habkost
2020-09-10 19:48 ` [PATCH 13/18] chardev: Rename TESTDEV_CHARDEV to CHARDEV_TESTDEV Eduardo Habkost
2020-09-10 19:48 ` [PATCH 14/18] chardev: Rename UDP_CHARDEV to CHARDEV_UDP Eduardo Habkost
2020-09-10 19:49 ` [PATCH 15/18] chardev: Rename VC_CHARDEV to CHARDEV_VC Eduardo Habkost
2020-09-10 19:49 ` [PATCH 16/18] chardev: Rename WCTABLET_CHARDEV to CHARDEV_WCTABLET Eduardo Habkost
2020-09-10 19:49 ` [PATCH 17/18] chardev: Rename WIN_CHARDEV to CHARDEV_WIN Eduardo Habkost
2020-09-10 19:49 ` [PATCH 18/18] chardev: Rename WIN_STDIO_CHARDEV to CHARDEV_WIN_STDIO Eduardo Habkost
2020-09-11  8:07 ` [PATCH 00/18] chardev: QOM cleanups Marc-André Lureau
2020-09-11  8:10   ` Daniel P. Berrangé
2020-09-11  8:19     ` Marc-André Lureau
2020-09-11  8:32       ` Daniel P. Berrangé
2020-09-11 13:50     ` Eduardo Habkost

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.