All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mathieu Poirier <mathieu.poirier@linaro.org>
To: Suzuki K Poulose <Suzuki.Poulose@arm.com>
Cc: "linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH V2 04/15] coresight: tmc: introducing new header file
Date: Fri, 15 Apr 2016 10:15:17 -0600	[thread overview]
Message-ID: <CANLsYkxL1c=RioUsT+1U49fcf=fGFFFedFTyOP20tuTxg3a15A@mail.gmail.com> (raw)
In-Reply-To: <571111E8.2000804@arm.com>

On 15 April 2016 at 10:08, Suzuki K Poulose <Suzuki.Poulose@arm.com> wrote:
> On 15/04/16 17:03, Mathieu Poirier wrote:
>>
>> On 14 April 2016 at 11:33, Suzuki K Poulose <Suzuki.Poulose@arm.com>
>> wrote:
>>>
>>> On 12/04/16 18:54, Mathieu Poirier wrote:
>>>>
>>>>
>>>> The amount of #define, enumeration and structure definition
>>>> is big enough to justify moving them to a new header file.
>>>>
>>>
>>>
>>>> +/* TMC_STS - 0x00C */
>>>> +#define TMC_STS_TRIGGERED      BIT(1)
>>>
>>>
>>>
>>> ...
>>>
>>>> +#define TMC_AXICTL_WR_BURST_LEN 0xF00
>>>
>>>
>>>
>>> Nit: The value above signifies, 16 data transfers per burst.
>>> So ideally it would be good to rename it to reflect that. say,
>>>
>>> TMC_AXICTL_WR_BURST_16
>>
>>
>> Will do.  But I'll have to do this in a separate patch then the
>> grouping of STS_ and FFCR_ defines you're referring to below since it
>> will also require changes to the .c files.
>
>
> Yes, I don't expect this change to be part of the patch. Separate patch
> is fine.
>
>>
>>>
>>>
>>>
>>>> +/* TMC_FFCR - 0x304 */
>>>> +#define TMC_FFCR_EN_FMT                BIT(0)
>>>> +#define TMC_FFCR_EN_TI         BIT(1)
>>>> +#define TMC_FFCR_FON_FLIN      BIT(4)
>>>> +#define TMC_FFCR_FON_TRIG_EVT  BIT(5)
>>>> +#define TMC_FFCR_FLUSHMAN      BIT(6)
>>>> +#define TMC_FFCR_TRIGON_TRIGIN BIT(8)
>>>> +#define TMC_FFCR_STOP_ON_FLUSH BIT(12)
>>>> +
>>>> +#define TMC_STS_TMCREADY_BIT   2
>>>
>>>
>>>
>>>> +#define TMC_FFCR_FLUSHMAN_BIT  6
>>>
>>>
>>>
>>> nit: It would be nice to group the STS_ and FFCR_ bits together.
>>> Also I see that the defintion for
>>> TMC_STS_FULL is added in a completely unrelated patch (TMC-ETF AUX SPACE
>>> patch ?). It would be good to add it either here or in a different patch.
>>
>>
>> TMC_STS_FULL is not added here because at this point it is not used by
>> the code - it is only added later when it is useful.
>
>
> I agree. But the patch which introduces the definition doesn't deal with
> TMC_STS_ at all either.

Patch 13/15 is using the TMC_STS_FULL define on line 147.  Am I
missing your point?

>Thats why I said, either here or in a different
> patch
> than what is there. May be you could club the change above and the STS_FULL
> into a new single patch. Its not mandatory though.
>
> Suzuki

WARNING: multiple messages have this Message-ID (diff)
From: mathieu.poirier@linaro.org (Mathieu Poirier)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH V2 04/15] coresight: tmc: introducing new header file
Date: Fri, 15 Apr 2016 10:15:17 -0600	[thread overview]
Message-ID: <CANLsYkxL1c=RioUsT+1U49fcf=fGFFFedFTyOP20tuTxg3a15A@mail.gmail.com> (raw)
In-Reply-To: <571111E8.2000804@arm.com>

On 15 April 2016 at 10:08, Suzuki K Poulose <Suzuki.Poulose@arm.com> wrote:
> On 15/04/16 17:03, Mathieu Poirier wrote:
>>
>> On 14 April 2016 at 11:33, Suzuki K Poulose <Suzuki.Poulose@arm.com>
>> wrote:
>>>
>>> On 12/04/16 18:54, Mathieu Poirier wrote:
>>>>
>>>>
>>>> The amount of #define, enumeration and structure definition
>>>> is big enough to justify moving them to a new header file.
>>>>
>>>
>>>
>>>> +/* TMC_STS - 0x00C */
>>>> +#define TMC_STS_TRIGGERED      BIT(1)
>>>
>>>
>>>
>>> ...
>>>
>>>> +#define TMC_AXICTL_WR_BURST_LEN 0xF00
>>>
>>>
>>>
>>> Nit: The value above signifies, 16 data transfers per burst.
>>> So ideally it would be good to rename it to reflect that. say,
>>>
>>> TMC_AXICTL_WR_BURST_16
>>
>>
>> Will do.  But I'll have to do this in a separate patch then the
>> grouping of STS_ and FFCR_ defines you're referring to below since it
>> will also require changes to the .c files.
>
>
> Yes, I don't expect this change to be part of the patch. Separate patch
> is fine.
>
>>
>>>
>>>
>>>
>>>> +/* TMC_FFCR - 0x304 */
>>>> +#define TMC_FFCR_EN_FMT                BIT(0)
>>>> +#define TMC_FFCR_EN_TI         BIT(1)
>>>> +#define TMC_FFCR_FON_FLIN      BIT(4)
>>>> +#define TMC_FFCR_FON_TRIG_EVT  BIT(5)
>>>> +#define TMC_FFCR_FLUSHMAN      BIT(6)
>>>> +#define TMC_FFCR_TRIGON_TRIGIN BIT(8)
>>>> +#define TMC_FFCR_STOP_ON_FLUSH BIT(12)
>>>> +
>>>> +#define TMC_STS_TMCREADY_BIT   2
>>>
>>>
>>>
>>>> +#define TMC_FFCR_FLUSHMAN_BIT  6
>>>
>>>
>>>
>>> nit: It would be nice to group the STS_ and FFCR_ bits together.
>>> Also I see that the defintion for
>>> TMC_STS_FULL is added in a completely unrelated patch (TMC-ETF AUX SPACE
>>> patch ?). It would be good to add it either here or in a different patch.
>>
>>
>> TMC_STS_FULL is not added here because at this point it is not used by
>> the code - it is only added later when it is useful.
>
>
> I agree. But the patch which introduces the definition doesn't deal with
> TMC_STS_ at all either.

Patch 13/15 is using the TMC_STS_FULL define on line 147.  Am I
missing your point?

>Thats why I said, either here or in a different
> patch
> than what is there. May be you could club the change above and the STS_FULL
> into a new single patch. Its not mandatory though.
>
> Suzuki

  reply	other threads:[~2016-04-15 16:15 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-12 17:54 [PATCH V2 00/15] coresight: tmc: make driver usable by Perf Mathieu Poirier
2016-04-12 17:54 ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 01/15] coresight: tmc: modifying naming convention Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-14 17:01   ` Suzuki K Poulose
2016-04-14 17:01     ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 02/15] coresight: tmc: waiting for TMCReady bit before programming Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-14 17:05   ` Suzuki K Poulose
2016-04-14 17:05     ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 03/15] coresight: tmc: re-implementing tmc_read_prepare/unprepare() functions Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-14 17:11   ` Suzuki K Poulose
2016-04-14 17:11     ` Suzuki K Poulose
2016-04-15 15:40     ` Mathieu Poirier
2016-04-15 15:40       ` Mathieu Poirier
2016-04-15 17:41       ` Suzuki K Poulose
2016-04-15 17:41         ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 04/15] coresight: tmc: introducing new header file Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-14 17:33   ` Suzuki K Poulose
2016-04-14 17:33     ` Suzuki K Poulose
2016-04-15 16:03     ` Mathieu Poirier
2016-04-15 16:03       ` Mathieu Poirier
2016-04-15 16:08       ` Suzuki K Poulose
2016-04-15 16:08         ` Suzuki K Poulose
2016-04-15 16:15         ` Mathieu Poirier [this message]
2016-04-15 16:15           ` Mathieu Poirier
2016-04-15 16:18           ` Suzuki K Poulose
2016-04-15 16:18             ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 05/15] coresight: tmc: splitting driver in ETB/ETF and ETR components Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 12:20   ` Suzuki K Poulose
2016-04-19 12:20     ` Suzuki K Poulose
2016-04-19 15:14     ` Mathieu Poirier
2016-04-19 15:14       ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 06/15] coresight: tmc: making prepare/unprepare functions generic Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 12:30   ` Suzuki K Poulose
2016-04-19 12:30     ` Suzuki K Poulose
2016-04-19 15:22     ` Mathieu Poirier
2016-04-19 15:22       ` Mathieu Poirier
2016-04-19 15:32       ` Suzuki K Poulose
2016-04-19 15:32         ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 07/15] coresight: tmc: allocating memory when needed Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 12:55   ` Suzuki K Poulose
2016-04-19 12:55     ` Suzuki K Poulose
2016-04-19 13:14     ` Suzuki K Poulose
2016-04-19 13:14       ` Suzuki K Poulose
2016-04-19 15:39     ` Mathieu Poirier
2016-04-19 15:39       ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 08/15] coresight: tmc: getting the right read_count on tmc_open() Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 13:07   ` Suzuki K Poulose
2016-04-19 13:07     ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 09/15] coresight: tmc: adding mode of operation for link/sinks Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 13:19   ` Suzuki K Poulose
2016-04-19 13:19     ` Suzuki K Poulose
2016-04-19 15:45     ` Mathieu Poirier
2016-04-19 15:45       ` Mathieu Poirier
2016-04-19 15:49       ` Suzuki K Poulose
2016-04-19 15:49         ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 10/15] coresight: tmc: dump system memory content only when needed Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 11/15] coresight: tmc: make sysFS and Perf mode mutually exclusive Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 13:42   ` Suzuki K Poulose
2016-04-19 13:42     ` Suzuki K Poulose
2016-04-19 16:16     ` Mathieu Poirier
2016-04-19 16:16       ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 12/15] coresight: tmc: keep track of memory width Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-14 11:19   ` Suzuki K Poulose
2016-04-14 11:19     ` Suzuki K Poulose
2016-04-15 16:10     ` Mathieu Poirier
2016-04-15 16:10       ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 13/15] coresight: tmc: implementing TMC-ETF AUX space API Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-19 16:16   ` Suzuki K Poulose
2016-04-19 16:16     ` Suzuki K Poulose
2016-04-19 16:45     ` Mathieu Poirier
2016-04-19 16:45       ` Mathieu Poirier
2016-04-19 16:50       ` Suzuki K Poulose
2016-04-19 16:50         ` Suzuki K Poulose
2016-04-12 17:54 ` [PATCH V2 14/15] coresight: tmc: implementing TMC-ETR " Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-21 16:10   ` Suzuki K Poulose
2016-04-21 16:10     ` Suzuki K Poulose
2016-04-21 22:00     ` Mathieu Poirier
2016-04-21 22:00       ` Mathieu Poirier
2016-04-12 17:54 ` [PATCH V2 15/15] coresight: configuring ETF in FIFO mode when acting as link Mathieu Poirier
2016-04-12 17:54   ` Mathieu Poirier
2016-04-21 12:53   ` Suzuki K Poulose
2016-04-21 12:53     ` Suzuki K Poulose

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CANLsYkxL1c=RioUsT+1U49fcf=fGFFFedFTyOP20tuTxg3a15A@mail.gmail.com' \
    --to=mathieu.poirier@linaro.org \
    --cc=Suzuki.Poulose@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.