All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jacek Anaszewski <jacek.anaszewski@gmail.com>
To: Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>
Cc: "Michał Kępień" <kernel@kempniu.pl>,
	"Richard Purdie" <rpurdie@rpsys.net>,
	"Pavel Machek" <pavel@ucw.cz>,
	"Pali Rohár" <pali.rohar@gmail.com>,
	"Darren Hart" <dvhart@infradead.org>,
	"Andy Shevchenko" <andy.shevchenko@gmail.com>,
	"Anthony Wong" <anthony.wong@canonical.com>,
	linux-leds@vger.kernel.org, platform-driver-x86@vger.kernel.org,
	alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 3/6] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func
Date: Tue, 17 Jan 2017 22:20:14 +0100	[thread overview]
Message-ID: <ceb198ea-5864-349d-f0c8-6ecf337139cc@gmail.com> (raw)
In-Reply-To: <20170116132204.6421-4-kernel@kempniu.pl>

Hi Jaroslav, Takashi,

I need an ack from sound sybsystem maintainer.
Are you OK with this patch going through LED tree?

Best regards,
Jacek Anaszewski

On 01/16/2017 02:22 PM, Michał Kępień wrote:
> With dell_app_wmi_led_set() replaced by dell_micmute_led_set(), rename
> the function pointer to the latter for consistency.
> 
> Signed-off-by: Michał Kępień <kernel@kempniu.pl>
> ---
>  sound/pci/hda/dell_wmi_helper.c | 20 ++++++++++----------
>  1 file changed, 10 insertions(+), 10 deletions(-)
> 
> diff --git a/sound/pci/hda/dell_wmi_helper.c b/sound/pci/hda/dell_wmi_helper.c
> index e128c8096772..516237ad6ef5 100644
> --- a/sound/pci/hda/dell_wmi_helper.c
> +++ b/sound/pci/hda/dell_wmi_helper.c
> @@ -6,7 +6,7 @@
>  #include <linux/dell-led.h>
>  
>  static int dell_led_value;
> -static int (*dell_led_set_func)(int);
> +static int (*dell_micmute_led_set_func)(int);
>  static void (*dell_old_cap_hook)(struct hda_codec *,
>  			         struct snd_kcontrol *,
>  				 struct snd_ctl_elem_value *);
> @@ -18,7 +18,7 @@ static void update_dell_wmi_micmute_led(struct hda_codec *codec,
>  	if (dell_old_cap_hook)
>  		dell_old_cap_hook(codec, kcontrol, ucontrol);
>  
> -	if (!ucontrol || !dell_led_set_func)
> +	if (!ucontrol || !dell_micmute_led_set_func)
>  		return;
>  	if (strcmp("Capture Switch", ucontrol->id.name) == 0 && ucontrol->id.index == 0) {
>  		/* TODO: How do I verify if it's a mono or stereo here? */
> @@ -26,8 +26,8 @@ static void update_dell_wmi_micmute_led(struct hda_codec *codec,
>  		if (val == dell_led_value)
>  			return;
>  		dell_led_value = val;
> -		if (dell_led_set_func)
> -			dell_led_set_func(dell_led_value);
> +		if (dell_micmute_led_set_func)
> +			dell_micmute_led_set_func(dell_led_value);
>  	}
>  }
>  
> @@ -39,15 +39,15 @@ static void alc_fixup_dell_wmi(struct hda_codec *codec,
>  	bool removefunc = false;
>  
>  	if (action == HDA_FIXUP_ACT_PROBE) {
> -		if (!dell_led_set_func)
> -			dell_led_set_func = symbol_request(dell_micmute_led_set);
> -		if (!dell_led_set_func) {
> +		if (!dell_micmute_led_set_func)
> +			dell_micmute_led_set_func = symbol_request(dell_micmute_led_set);
> +		if (!dell_micmute_led_set_func) {
>  			codec_warn(codec, "Failed to find dell wmi symbol dell_micmute_led_set\n");
>  			return;
>  		}
>  
>  		removefunc = true;
> -		if (dell_led_set_func(false) >= 0) {
> +		if (dell_micmute_led_set_func(false) >= 0) {
>  			dell_led_value = 0;
>  			if (spec->gen.num_adc_nids > 1 && !spec->gen.dyn_adc_switch)
>  				codec_dbg(codec, "Skipping micmute LED control due to several ADCs");
> @@ -60,9 +60,9 @@ static void alc_fixup_dell_wmi(struct hda_codec *codec,
>  
>  	}
>  
> -	if (dell_led_set_func && (action == HDA_FIXUP_ACT_FREE || removefunc)) {
> +	if (dell_micmute_led_set_func && (action == HDA_FIXUP_ACT_FREE || removefunc)) {
>  		symbol_put(dell_micmute_led_set);
> -		dell_led_set_func = NULL;
> +		dell_micmute_led_set_func = NULL;
>  		dell_old_cap_hook = NULL;
>  	}
>  }
> 

  parent reply	other threads:[~2017-01-17 21:20 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-16 13:21 [PATCH v2 0/6] Move dell-led to drivers/platform/x86 Michał Kępień
2017-01-16 13:21 ` [PATCH v2 1/6] dell-led: remove GUID check from dell_micmute_led_set() Michał Kępień
2017-01-16 13:22 ` [PATCH v2 2/6] ALSA: hda - use dell_micmute_led_set() instead of dell_app_wmi_led_set() Michał Kępień
2017-01-16 13:22 ` [PATCH v2 3/6] ALSA: hda - rename dell_led_set_func to dell_micmute_led_set_func Michał Kępień
2017-01-17 11:12   ` Pali Rohár
2017-01-17 21:20   ` Jacek Anaszewski [this message]
2017-01-16 13:22 ` [PATCH v2 4/6] platform/x86: dell-laptop: import dell_micmute_led_set() from drivers/leds/dell-led.c Michał Kępień
2017-01-17 11:23   ` Pali Rohár
2017-01-18 19:12   ` Andy Shevchenko
2017-01-16 13:22 ` [PATCH v2 5/6] dell-led: remove code related to mic mute LED Michał Kępień
2017-01-17 11:24   ` Pali Rohár
2017-01-16 13:22 ` [PATCH v2 6/6] dell-led: move driver to drivers/platform/x86/dell-wmi-led.c Michał Kępień
2017-01-16 20:49   ` Jacek Anaszewski
2017-01-17 11:08     ` Pavel Machek
2017-01-17 11:28       ` Pali Rohár
2017-01-18 19:08   ` Andy Shevchenko
2017-01-17  7:17 ` [PATCH v2 6+/6] platform/x86: dell-wmi-led: fix coding style issues Michał Kępień
2017-01-17  8:21   ` Joe Perches
2017-01-17  9:19     ` Michał Kępień
2017-01-17 21:20       ` Jacek Anaszewski
2017-01-17 11:08   ` Pavel Machek
2017-01-18 19:06   ` Andy Shevchenko
2017-01-17 21:20 ` [PATCH v2 0/6] Move dell-led to drivers/platform/x86 Jacek Anaszewski
2017-02-13 11:26 ` Michał Kępień
2017-02-15 11:56   ` Alex Hung
2017-02-15 11:56     ` Alex Hung
2017-02-15 13:54     ` Michał Kępień
2017-02-15 14:31       ` Alex Hung
2017-02-15 14:31         ` Alex Hung
2017-02-15 15:12         ` Pali Rohár
2017-02-16  9:33           ` Michał Kępień
2017-02-16  9:33             ` Michał Kępień
2017-02-16  9:27         ` Michał Kępień
2017-02-16 10:35           ` Alex Hung
2017-02-16 11:32             ` Michał Kępień
2017-02-16 11:38               ` Alex Hung
2017-02-16 11:41               ` Andy Shevchenko
2017-02-16 12:01                 ` Michał Kępień
2017-02-16 13:11                   ` Andy Shevchenko
2017-02-16 13:11                     ` Andy Shevchenko
2017-02-16 22:11               ` Jacek Anaszewski
2017-02-15 20:28   ` Takashi Iwai
2017-02-15 20:28     ` Takashi Iwai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ceb198ea-5864-349d-f0c8-6ecf337139cc@gmail.com \
    --to=jacek.anaszewski@gmail.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=andy.shevchenko@gmail.com \
    --cc=anthony.wong@canonical.com \
    --cc=dvhart@infradead.org \
    --cc=kernel@kempniu.pl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=pali.rohar@gmail.com \
    --cc=pavel@ucw.cz \
    --cc=perex@perex.cz \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=rpurdie@rpsys.net \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.