All of lore.kernel.org
 help / color / mirror / Atom feed
From: Robin Murphy <robin.murphy@arm.com>
To: Ray Jui <ray.jui@broadcom.com>,
	Scott Branden <scott.branden@broadcom.com>,
	Guenter Roeck <linux@roeck-us.net>
Cc: Mark Rutland <mark.rutland@arm.com>,
	devicetree@vger.kernel.org, linux-watchdog@vger.kernel.org,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	linux-kernel@vger.kernel.org, Rob Herring <robh+dt@kernel.org>,
	bcm-kernel-feedback-list@broadcom.com,
	Wim Van Sebroeck <wim@linux-watchdog.org>,
	Frank Rowand <frowand.list@gmail.com>,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 3/5] watchdog: sp805: set WDOG_HW_RUNNING when appropriate
Date: Wed, 23 May 2018 18:15:14 +0100	[thread overview]
Message-ID: <ef3539fd-c95c-f364-93c7-680aabd1eea3@arm.com> (raw)
In-Reply-To: <5a996888-d3d3-9ae6-e438-5de4d5e3ea32@broadcom.com>

On 23/05/18 17:29, Ray Jui wrote:
> Hi Robin,
> 
> On 5/23/2018 4:48 AM, Robin Murphy wrote:
>> On 23/05/18 08:52, Scott Branden wrote:
>>>
>>>
>>> On 18-05-22 04:24 PM, Ray Jui wrote:
>>>> Hi Guenter,
>>>>
>>>> On 5/22/2018 1:54 PM, Guenter Roeck wrote:
>>>>> On Tue, May 22, 2018 at 11:47:18AM -0700, Ray Jui wrote:
>>>>>> If the watchdog hardware is already enabled during the boot process,
>>>>>> when the Linux watchdog driver loads, it should reset the watchdog 
>>>>>> and
>>>>>> tell the watchdog framework. As a result, ping can be generated from
>>>>>> the watchdog framework, until the userspace watchdog daemon takes 
>>>>>> over
>>>>>> control
>>>>>>
>>>>>> Signed-off-by: Ray Jui <ray.jui@broadcom.com>
>>>>>> Reviewed-by: Vladimir Olovyannikov 
>>>>>> <vladimir.olovyannikov@broadcom.com>
>>>>>> Reviewed-by: Scott Branden <scott.branden@broadcom.com>
>>>>>> ---
>>>>>>   drivers/watchdog/sp805_wdt.c | 22 ++++++++++++++++++++++
>>>>>>   1 file changed, 22 insertions(+)
>>>>>>
>>>>>> diff --git a/drivers/watchdog/sp805_wdt.c 
>>>>>> b/drivers/watchdog/sp805_wdt.c
>>>>>> index 1484609..408ffbe 100644
>>>>>> --- a/drivers/watchdog/sp805_wdt.c
>>>>>> +++ b/drivers/watchdog/sp805_wdt.c
>>>>>> @@ -42,6 +42,7 @@
>>>>>>       /* control register masks */
>>>>>>       #define    INT_ENABLE    (1 << 0)
>>>>>>       #define    RESET_ENABLE    (1 << 1)
>>>>>> +    #define    ENABLE_MASK    (INT_ENABLE | RESET_ENABLE)
>>>>>>   #define WDTINTCLR        0x00C
>>>>>>   #define WDTRIS            0x010
>>>>>>   #define WDTMIS            0x014
>>>>>> @@ -74,6 +75,18 @@ module_param(nowayout, bool, 0);
>>>>>>   MODULE_PARM_DESC(nowayout,
>>>>>>           "Set to 1 to keep watchdog running after device release");
>>>>>>   +/* returns true if wdt is running; otherwise returns false */
>>>>>> +static bool wdt_is_running(struct watchdog_device *wdd)
>>>>>> +{
>>>>>> +    struct sp805_wdt *wdt = watchdog_get_drvdata(wdd);
>>>>>> +
>>>>>> +    if ((readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK) ==
>>>>>> +        ENABLE_MASK)
>>>>>> +        return true;
>>>>>> +    else
>>>>>> +        return false;
>>>>>
>>>>>     return !!(readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK));
>>>>>
>>>>
>>>> Note ENABLE_MASK contains two bits (INT_ENABLE and RESET_ENABLE); 
>>>> therefore, a simple !!(expression) would not work? That is, the 
>>>> masked result needs to be compared against the mask again to ensure 
>>>> both bits are set, right?
>>> Ray - your original code looks correct to me.  Easier to read and 
>>> less prone to errors as shown in the attempted translation to a 
>>> single statement.
>>
>>      if (<boolean condition>)
>>          return true;
>>      else
>>          return false;
>>
>> still looks really dumb, though, and IMO is actually harder to read 
>> than just "return <boolean condition>;" because it forces you to stop 
>> and double-check that the logic is, in fact, only doing the obvious 
>> thing.
> 
> If you can propose a way to modify my original code above to make it 
> more readable, I'm fine to make the change.

Well,

	return readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK == ENABLE_MASK;

would probably be reasonable to anyone other than the 80-column zealots, 
but removing the silly boolean-to-boolean translation idiom really only 
emphasises the fact that it's fundamentally a big complex statement; for 
maximum clarity I'd be inclined to separate the two logical operations 
(read and comparison), e.g.:

	u32 wdtcontrol = readl_relaxed(wdt->base + WDTCONTROL);

	return wdtcontrol & ENABLE_MASK == ENABLE_MASK;

which is still -3 lines vs. the original.

> As I mentioned, I don't think the following change proposed by Guenter 
> will work due to the reason I pointed out:
> 
> return !!(readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK));

FWIW, getting the desired result should only need one logical not 
swapping for a bitwise one there:

	return !(~readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK);

but that's well into "too clever for its own good" territory ;)

Robin.

WARNING: multiple messages have this Message-ID (diff)
From: robin.murphy@arm.com (Robin Murphy)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 3/5] watchdog: sp805: set WDOG_HW_RUNNING when appropriate
Date: Wed, 23 May 2018 18:15:14 +0100	[thread overview]
Message-ID: <ef3539fd-c95c-f364-93c7-680aabd1eea3@arm.com> (raw)
In-Reply-To: <5a996888-d3d3-9ae6-e438-5de4d5e3ea32@broadcom.com>

On 23/05/18 17:29, Ray Jui wrote:
> Hi Robin,
> 
> On 5/23/2018 4:48 AM, Robin Murphy wrote:
>> On 23/05/18 08:52, Scott Branden wrote:
>>>
>>>
>>> On 18-05-22 04:24 PM, Ray Jui wrote:
>>>> Hi Guenter,
>>>>
>>>> On 5/22/2018 1:54 PM, Guenter Roeck wrote:
>>>>> On Tue, May 22, 2018 at 11:47:18AM -0700, Ray Jui wrote:
>>>>>> If the watchdog hardware is already enabled during the boot process,
>>>>>> when the Linux watchdog driver loads, it should reset the watchdog 
>>>>>> and
>>>>>> tell the watchdog framework. As a result, ping can be generated from
>>>>>> the watchdog framework, until the userspace watchdog daemon takes 
>>>>>> over
>>>>>> control
>>>>>>
>>>>>> Signed-off-by: Ray Jui <ray.jui@broadcom.com>
>>>>>> Reviewed-by: Vladimir Olovyannikov 
>>>>>> <vladimir.olovyannikov@broadcom.com>
>>>>>> Reviewed-by: Scott Branden <scott.branden@broadcom.com>
>>>>>> ---
>>>>>> ? drivers/watchdog/sp805_wdt.c | 22 ++++++++++++++++++++++
>>>>>> ? 1 file changed, 22 insertions(+)
>>>>>>
>>>>>> diff --git a/drivers/watchdog/sp805_wdt.c 
>>>>>> b/drivers/watchdog/sp805_wdt.c
>>>>>> index 1484609..408ffbe 100644
>>>>>> --- a/drivers/watchdog/sp805_wdt.c
>>>>>> +++ b/drivers/watchdog/sp805_wdt.c
>>>>>> @@ -42,6 +42,7 @@
>>>>>> ????? /* control register masks */
>>>>>> ????? #define??? INT_ENABLE??? (1 << 0)
>>>>>> ????? #define??? RESET_ENABLE??? (1 << 1)
>>>>>> +??? #define??? ENABLE_MASK??? (INT_ENABLE | RESET_ENABLE)
>>>>>> ? #define WDTINTCLR??????? 0x00C
>>>>>> ? #define WDTRIS??????????? 0x010
>>>>>> ? #define WDTMIS??????????? 0x014
>>>>>> @@ -74,6 +75,18 @@ module_param(nowayout, bool, 0);
>>>>>> ? MODULE_PARM_DESC(nowayout,
>>>>>> ????????? "Set to 1 to keep watchdog running after device release");
>>>>>> ? +/* returns true if wdt is running; otherwise returns false */
>>>>>> +static bool wdt_is_running(struct watchdog_device *wdd)
>>>>>> +{
>>>>>> +??? struct sp805_wdt *wdt = watchdog_get_drvdata(wdd);
>>>>>> +
>>>>>> +??? if ((readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK) ==
>>>>>> +??????? ENABLE_MASK)
>>>>>> +??????? return true;
>>>>>> +??? else
>>>>>> +??????? return false;
>>>>>
>>>>> ????return !!(readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK));
>>>>>
>>>>
>>>> Note ENABLE_MASK contains two bits (INT_ENABLE and RESET_ENABLE); 
>>>> therefore, a simple !!(expression) would not work? That is, the 
>>>> masked result needs to be compared against the mask again to ensure 
>>>> both bits are set, right?
>>> Ray - your original code looks correct to me.? Easier to read and 
>>> less prone to errors as shown in the attempted translation to a 
>>> single statement.
>>
>> ?????if (<boolean condition>)
>> ???????? return true;
>> ?????else
>> ???????? return false;
>>
>> still looks really dumb, though, and IMO is actually harder to read 
>> than just "return <boolean condition>;" because it forces you to stop 
>> and double-check that the logic is, in fact, only doing the obvious 
>> thing.
> 
> If you can propose a way to modify my original code above to make it 
> more readable, I'm fine to make the change.

Well,

	return readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK == ENABLE_MASK;

would probably be reasonable to anyone other than the 80-column zealots, 
but removing the silly boolean-to-boolean translation idiom really only 
emphasises the fact that it's fundamentally a big complex statement; for 
maximum clarity I'd be inclined to separate the two logical operations 
(read and comparison), e.g.:

	u32 wdtcontrol = readl_relaxed(wdt->base + WDTCONTROL);

	return wdtcontrol & ENABLE_MASK == ENABLE_MASK;

which is still -3 lines vs. the original.

> As I mentioned, I don't think the following change proposed by Guenter 
> will work due to the reason I pointed out:
> 
> return !!(readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK));

FWIW, getting the desired result should only need one logical not 
swapping for a bitwise one there:

	return !(~readl_relaxed(wdt->base + WDTCONTROL) & ENABLE_MASK);

but that's well into "too clever for its own good" territory ;)

Robin.

  reply	other threads:[~2018-05-23 17:15 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-22 18:47 [PATCH 0/5] Enhance support for the SP805 WDT Ray Jui
2018-05-22 18:47 ` Ray Jui
2018-05-22 18:47 ` [PATCH 1/5] Documentation: DT: Add optional 'timeout-sec' property for sp805 Ray Jui
2018-05-22 18:47   ` Ray Jui
2018-05-22 20:56   ` Guenter Roeck
2018-05-22 20:56     ` Guenter Roeck
2018-05-23 10:57   ` Robin Murphy
2018-05-23 10:57     ` Robin Murphy
2018-05-23 16:25     ` Ray Jui
2018-05-23 16:25       ` Ray Jui
2018-05-23 18:59       ` Rob Herring
2018-05-23 18:59         ` Rob Herring
2018-05-23 19:29         ` Ray Jui
2018-05-23 19:29           ` Ray Jui
2018-05-24 13:52           ` Robin Murphy
2018-05-24 13:52             ` Robin Murphy
2018-05-23 18:10     ` Guenter Roeck
2018-05-23 18:10       ` Guenter Roeck
2018-05-24 13:25       ` Robin Murphy
2018-05-24 13:25         ` Robin Murphy
2018-05-24 16:07         ` Guenter Roeck
2018-05-24 16:07           ` Guenter Roeck
2018-05-22 18:47 ` [PATCH 2/5] watchdog: sp805: add 'timeout-sec' DT property support Ray Jui
2018-05-22 18:47   ` Ray Jui
2018-05-22 20:57   ` Guenter Roeck
2018-05-22 20:57     ` Guenter Roeck
2018-05-22 18:47 ` [PATCH 3/5] watchdog: sp805: set WDOG_HW_RUNNING when appropriate Ray Jui
2018-05-22 18:47   ` Ray Jui
2018-05-22 20:54   ` Guenter Roeck
2018-05-22 20:54     ` Guenter Roeck
2018-05-22 23:24     ` Ray Jui
2018-05-22 23:24       ` Ray Jui
2018-05-23  7:52       ` Scott Branden
2018-05-23  7:52         ` Scott Branden
2018-05-23 11:48         ` Robin Murphy
2018-05-23 11:48           ` Robin Murphy
2018-05-23 16:29           ` Ray Jui
2018-05-23 16:29             ` Ray Jui
2018-05-23 17:15             ` Robin Murphy [this message]
2018-05-23 17:15               ` Robin Murphy
2018-05-23 18:09               ` Guenter Roeck
2018-05-23 18:09                 ` Guenter Roeck
2018-05-23 19:35                 ` Ray Jui
2018-05-23 19:35                   ` Ray Jui
2018-05-23 17:15             ` Scott Branden
2018-05-23 17:15               ` Scott Branden
2018-05-23 18:06           ` Guenter Roeck
2018-05-23 18:06             ` Guenter Roeck
2018-05-22 18:47 ` [PATCH 4/5] arm64: dt: set initial SR watchdog timeout to 60 seconds Ray Jui
2018-05-22 18:47   ` Ray Jui
2018-05-22 18:47 ` [PATCH 5/5] arm64: defconfig: add CONFIG_ARM_SP805_WATCHDOG Ray Jui
2018-05-22 18:47   ` Ray Jui

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ef3539fd-c95c-f364-93c7-680aabd1eea3@arm.com \
    --to=robin.murphy@arm.com \
    --cc=bcm-kernel-feedback-list@broadcom.com \
    --cc=catalin.marinas@arm.com \
    --cc=devicetree@vger.kernel.org \
    --cc=frowand.list@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-watchdog@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=mark.rutland@arm.com \
    --cc=ray.jui@broadcom.com \
    --cc=robh+dt@kernel.org \
    --cc=scott.branden@broadcom.com \
    --cc=will.deacon@arm.com \
    --cc=wim@linux-watchdog.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.