All of lore.kernel.org
 help / color / mirror / Atom feed
From: Julia Lawall <julia.lawall@lip6.fr>
To: walter harms <wharms@bfs.de>
Cc: Patrick Lai <plai@codeaurora.org>,
	kernel-janitors@vger.kernel.org,
	Banajit Goswami <bgoswami@codeaurora.org>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Mark Brown <broonie@kernel.org>, Jaroslav Kysela <perex@perex.cz>,
	Takashi Iwai <tiwai@suse.com>,
	alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument
Date: Sun, 30 Aug 2015 21:54:15 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.02.1508302152300.2062@localhost6.localdomain6> (raw)
In-Reply-To: <55E35169.3000703@bfs.de>



On Sun, 30 Aug 2015, walter harms wrote:

> 
> 
> Am 30.08.2015 20:05, schrieb Julia Lawall:
> > Apply PTR_ERR to the value that was recently assigned.
> > 
> > The semantic match that finds this problem is as follows:
> > (http://coccinelle.lip6.fr/)
> > 
> > // <smpl>
> > @@
> > expression x,y;
> > @@
> > 
> > if (IS_ERR(x) || ...) {
> >   ... when any
> >       when != IS_ERR(...)
> > (
> >    PTR_ERR(x)
> > |
> > *  PTR_ERR(y)
> > )
> >   ... when any
> > }
> > // </smpl>
> > 
> > Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
> > 
> > ---
> >  sound/soc/qcom/lpass-cpu.c |    3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> > 
> > diff --git a/sound/soc/qcom/lpass-cpu.c b/sound/soc/qcom/lpass-cpu.c
> > index 23f3d59..94beb99 100644
> > --- a/sound/soc/qcom/lpass-cpu.c
> > +++ b/sound/soc/qcom/lpass-cpu.c
> > @@ -438,7 +438,8 @@ int asoc_qcom_lpass_cpu_platform_probe(struct platform_device *pdev)
> >  		if (IS_ERR(drvdata->mi2s_bit_clk[dai_id])) {
> >  			dev_err(&pdev->dev,
> >  				"%s() error getting mi2s-bit-clk: %ld\n",
> > -				__func__, PTR_ERR(drvdata->mi2s_bit_clk[i]));
> > +				__func__,
> > +				PTR_ERR(drvdata->mi2s_bit_clk[dai_id]));
> >  			return PTR_ERR(drvdata->mi2s_bit_clk[dai_id]);
> >  		}
> >  	}
> > 
> 
> just a note:
> using a shorter name instead of drvdata->mi2s_bit_clk[dai_id] whould help to make the code
> more readable (yes, the other code is alike). something like:
> 
> struct clk *tmp =  devm_clk_get(&pdev->dev,clk_name);

Where do you suggest to put this?

Maybe it would be reasonable to declare a variable struct clk *clk; at the 
top of the function, and then use that as a temporary variable for all 
three calls.

However, now I see that the first call, unlike the other two doesn't cause 
a return from the function.

                if (IS_ERR(drvdata->mi2s_osr_clk[dai_id])) {
                        dev_warn(&pdev->dev,
                                "%s() error getting mi2s-osr-clk: %ld\n",
				__func__,
		                PTR_ERR(drvdata->mi2s_osr_clk[dai_id]));
                }

Is that intentional?

thanks,
julia

> if (IS_ERR(tmp)) {
> 	dev_err(&pdev->dev,"%s() error getting mi2s-bit-clk: %ld\n",__func__, PTR_ERR(tmp));
>         return PTR_ERR(tmp);
> }
> drvdata->mi2s_bit_clk[dai_id]=tmp;
> 
> 
> just one minor:
> the dev_warn() just before says: " error getting mi2s-osr-clk" may be it should be "warnig ..."
> That will make it more easy to rep for real error in a log.
> 
> re,
>  wh
> 
> --
> To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 

WARNING: multiple messages have this Message-ID (diff)
From: Julia Lawall <julia.lawall@lip6.fr>
To: walter harms <wharms@bfs.de>
Cc: Patrick Lai <plai@codeaurora.org>,
	kernel-janitors@vger.kernel.org,
	Banajit Goswami <bgoswami@codeaurora.org>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Mark Brown <broonie@kernel.org>, Jaroslav Kysela <perex@perex.cz>,
	Takashi Iwai <tiwai@suse.com>,
	alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] ASoC: qcom: change PTR_ERR argument
Date: Sun, 30 Aug 2015 19:54:15 +0000	[thread overview]
Message-ID: <alpine.DEB.2.02.1508302152300.2062@localhost6.localdomain6> (raw)
In-Reply-To: <55E35169.3000703@bfs.de>



On Sun, 30 Aug 2015, walter harms wrote:

> 
> 
> Am 30.08.2015 20:05, schrieb Julia Lawall:
> > Apply PTR_ERR to the value that was recently assigned.
> > 
> > The semantic match that finds this problem is as follows:
> > (http://coccinelle.lip6.fr/)
> > 
> > // <smpl>
> > @@
> > expression x,y;
> > @@
> > 
> > if (IS_ERR(x) || ...) {
> >   ... when any
> >       when != IS_ERR(...)
> > (
> >    PTR_ERR(x)
> > |
> > *  PTR_ERR(y)
> > )
> >   ... when any
> > }
> > // </smpl>
> > 
> > Signed-off-by: Julia Lawall <Julia.Lawall@lip6.fr>
> > 
> > ---
> >  sound/soc/qcom/lpass-cpu.c |    3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> > 
> > diff --git a/sound/soc/qcom/lpass-cpu.c b/sound/soc/qcom/lpass-cpu.c
> > index 23f3d59..94beb99 100644
> > --- a/sound/soc/qcom/lpass-cpu.c
> > +++ b/sound/soc/qcom/lpass-cpu.c
> > @@ -438,7 +438,8 @@ int asoc_qcom_lpass_cpu_platform_probe(struct platform_device *pdev)
> >  		if (IS_ERR(drvdata->mi2s_bit_clk[dai_id])) {
> >  			dev_err(&pdev->dev,
> >  				"%s() error getting mi2s-bit-clk: %ld\n",
> > -				__func__, PTR_ERR(drvdata->mi2s_bit_clk[i]));
> > +				__func__,
> > +				PTR_ERR(drvdata->mi2s_bit_clk[dai_id]));
> >  			return PTR_ERR(drvdata->mi2s_bit_clk[dai_id]);
> >  		}
> >  	}
> > 
> 
> just a note:
> using a shorter name instead of drvdata->mi2s_bit_clk[dai_id] whould help to make the code
> more readable (yes, the other code is alike). something like:
> 
> struct clk *tmp =  devm_clk_get(&pdev->dev,clk_name);

Where do you suggest to put this?

Maybe it would be reasonable to declare a variable struct clk *clk; at the 
top of the function, and then use that as a temporary variable for all 
three calls.

However, now I see that the first call, unlike the other two doesn't cause 
a return from the function.

                if (IS_ERR(drvdata->mi2s_osr_clk[dai_id])) {
                        dev_warn(&pdev->dev,
                                "%s() error getting mi2s-osr-clk: %ld\n",
				__func__,
		                PTR_ERR(drvdata->mi2s_osr_clk[dai_id]));
                }

Is that intentional?

thanks,
julia

> if (IS_ERR(tmp)) {
> 	dev_err(&pdev->dev,"%s() error getting mi2s-bit-clk: %ld\n",__func__, PTR_ERR(tmp));
>         return PTR_ERR(tmp);
> }
> drvdata->mi2s_bit_clk[dai_id]=tmp;
> 
> 
> just one minor:
> the dev_warn() just before says: " error getting mi2s-osr-clk" may be it should be "warnig ..."
> That will make it more easy to rep for real error in a log.
> 
> re,
>  wh
> 
> --
> To unsubscribe from this list: send the line "unsubscribe kernel-janitors" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 

  reply	other threads:[~2015-08-30 19:54 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-08-30 18:05 [PATCH 0/2] change PTR_ERR argument Julia Lawall
2015-08-30 18:05 ` Julia Lawall
2015-08-30 18:05 ` Julia Lawall
2015-08-30 18:05 ` [PATCH 1/2] ASoC: qcom: " Julia Lawall
2015-08-30 18:05   ` Julia Lawall
2015-08-30 18:54   ` walter harms
2015-08-30 18:54     ` walter harms
2015-08-30 19:54     ` Julia Lawall [this message]
2015-08-30 19:54       ` Julia Lawall
2015-09-03 21:36       ` [alsa-devel] " Kenneth Westfield
2015-09-03 21:36         ` Kenneth Westfield
2015-09-03 21:33     ` Kenneth Westfield
2015-09-03 21:33       ` Kenneth Westfield
2015-09-03 21:19   ` Kenneth Westfield
2015-09-03 21:19     ` Kenneth Westfield
2015-09-14 18:04   ` Mark Brown
2015-09-14 18:04     ` Mark Brown
2015-09-14 18:04     ` Mark Brown
2015-09-17  8:46     ` Julia Lawall
2015-09-17  8:46       ` Julia Lawall
2015-09-17  8:46       ` Julia Lawall
2015-09-17  9:21       ` Mark Brown
2015-09-17  9:21         ` Mark Brown
2015-09-17  9:21         ` Mark Brown
2015-09-17  8:47     ` Julia Lawall
2015-09-17  8:47       ` Julia Lawall
2015-09-17 17:36   ` Applied "ASoC: qcom: change PTR_ERR argument" to the asoc tree Mark Brown
2015-08-30 18:05 ` [PATCH 2/2] spi: spi-ep93xx: change PTR_ERR argument Julia Lawall
2015-08-30 18:05   ` Julia Lawall
2015-08-30 18:31   ` walter harms
2015-08-30 18:31     ` walter harms
2015-08-30 20:10     ` [PATCH 2/2 v2] spi: spi-ep93xx: fix PTR_ERR problem Julia Lawall
2015-08-30 20:10       ` Julia Lawall

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.02.1508302152300.2062@localhost6.localdomain6 \
    --to=julia.lawall@lip6.fr \
    --cc=alsa-devel@alsa-project.org \
    --cc=bgoswami@codeaurora.org \
    --cc=broonie@kernel.org \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=perex@perex.cz \
    --cc=plai@codeaurora.org \
    --cc=tiwai@suse.com \
    --cc=wharms@bfs.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.