linux-sparse.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-06-15 22:54:50 to 2020-07-31 16:13:16 UTC [more...]

[PATCH] dissect: add support for _Generic
 2020-07-31 16:13 UTC  (11+ messages)
    ` [PATCH] dissect: support _Generic() a bit more

[PATCH v1] sindex: allow indexing outside the project tree
 2020-07-30 21:02 UTC  (4+ messages)

[PATCH] fix stream_prev() for invalid (negative) stream
 2020-07-29 22:01 UTC 

[PATCH] dissect: use struct symbol::visited/inspected instead of ::examined/evaluated
 2020-07-29 15:48 UTC  (3+ messages)

[PATCH] xtensa: fix configuration of endianness
 2020-07-25 20:56 UTC 

[PATCH] remove unsed field for EXPR_GENERIC
 2020-07-25 20:56 UTC 

[PATCH] generic: fix missing inlining of generic expression
 2020-07-24 22:26 UTC 

[PATCH 0/6] fix parsing of C99's array declarators
 2020-07-23 23:46 UTC  (7+ messages)
` [PATCH 1/6] add testcase for comma in array declarator
` [PATCH 2/6] do not accept comma expressions "
` [PATCH 3/6] add testcases for C99 array declarators
` [PATCH 4/6] simplify & fix parsing of "
` [PATCH 5/6] remove now unused match_idents()
` [PATCH 6/6] allow [*] in array declarators

[PATCH] attribute: simplify parsing of attributes
 2020-07-22 21:51 UTC 

[PATCH] doc: use https URLs
 2020-07-22 21:47 UTC 

[PATCH] manpage: replace homepage to sparse.docs.kernel.org
 2020-07-22 21:42 UTC 

[PATCH] option: accept 'sparse -U ...'
 2020-07-22 21:28 UTC 

[PATCH] add position to struct stream
 2020-07-18 23:40 UTC 

[PATCH] warnings: ensure the source filename is shown at least once
 2020-07-18 23:36 UTC  (3+ messages)

[PATCH] teach sparse about -fmax-errors
 2020-07-14 21:45 UTC 

[PATCH] syntax errors in numbers are not fatal
 2020-07-14 21:43 UTC 

[PATCH 0/3] warn on empty expressions
 2020-07-14  0:00 UTC  (4+ messages)
` [PATCH 1/3] add testcase for incorrect "
` [PATCH 2/3] warn on empty assignments
` [PATCH 3/3] warn on empty initializations

[PATCH 0/9] arch specific predefines
 2020-07-13 22:33 UTC  (10+ messages)
` [PATCH 1/9] sparc: add 'sparcv8' predefines for sparc32
` [PATCH 2/9] alpha: has 64-bit long double & int128
` [PATCH 3/9] ppc: add predefines __LONGDOUBLE128 & __LONG_DOUBLE_128__
` [PATCH 4/9] arch: add predefines __INT_LEAST${N}_TYPE__
` [PATCH 5/9] arch: add predefines __INT_FAST${N}_TYPE__
` [PATCH 6/9] predefine: teach sparse about __SIG_ATOMIC_TYPE__
` [PATCH 7/9] arch: allow target specific [u]intptr_t & ptrdiff_t
` [PATCH 8/9] x86-x32: fix it by defining a separate target for it
` [PATCH 9/9] predefine: let predefine_width() take the usual interface

using sparse to catch refcount leaks
 2020-07-13 10:50 UTC  (4+ messages)

[PATCH 5/5] crypto: arm/ghash - use variably sized key struct
 2020-07-10  0:16 UTC  (2+ messages)

[PATCH 0/4] fix evaluation of assignment and qualified arrays
 2020-07-10  0:13 UTC  (5+ messages)
` [PATCH 1/4] add a testcase for assignment to const <type> (*)[]
` [PATCH 2/4] add another testcase with const array/pointer
` [PATCH 3/4] add testcase for missing warning for assignment to const
` [PATCH 4/4] [RFC] fix evaluation error with assignment of qualified arrays

[PATCH] xtensa: add minimal support
 2020-07-09  0:26 UTC 

[PATCH 0/9] OS-specific small fixes & cleanup
 2020-07-08 23:41 UTC  (10+ messages)
` [PATCH 1/9] x86: reorg the target file
` [PATCH 2/9] arch: add an option to specify the OS: --os=$OS
` [PATCH 3/9] predefine: add __linux__ & __linux
` [PATCH 4/9] predefine: no __unix__ for Darwin
` [PATCH 5/9] x86: fixes types for NetBSD & OpenBSD
` [PATCH 6/9] sparc: char are unsigned on Solaris
` [PATCH 7/9] arch: add predefines for OS identification
` [PATCH 8/9] cygwin: add the predefines '__cdecl',
` [PATCH 9/9] cgcc: remove now unneeded options & defines

[PATCH] h8300: add minimal support
 2020-07-08 22:24 UTC 

[PATCH] target: keep tables sorted
 2020-07-08 22:24 UTC 

[PATCH 0/2] small fixes for NIOS2
 2020-07-08 22:19 UTC  (3+ messages)
` [PATCH 1/2] nios2: long double is 64-bit
` [PATCH 2/2] nios2: add non-trailing double underscore predefines

[PATCH 0/3] add the predefines for endianness
 2020-07-08 21:53 UTC  (4+ messages)
` [PATCH 1/3] mips: add predefines __MIPSEL__ or __MIPSEB__ & friends
` [PATCH 2/3] arm64: add predefine for endianness
` [PATCH 3/3] arm: add predefine __ARMEL__ or __ARMEB__

[PATCH 0/3] teach sparse about the '-march' for RISC-V
 2020-07-08 21:48 UTC  (4+ messages)
` [PATCH 1/3] arch: teach sparse about the '-march' option
` [PATCH 2/3] riscv: parse '-march=....'
` [PATCH 3/3] riscv: add the predefines for the extensions

[PATCH 0/3] make the keyword table more readable
 2020-07-08 19:26 UTC  (4+ messages)
` [PATCH 1/3] keyword: reorganize the keyword table
` [PATCH 2/3] keyword: reorder the keywords
` [PATCH 3/3] keyword: use some macros to avoid duplication

Sparse improvements & regressions for Linux v5.7-rc1 -> v5.8-rc1
 2020-07-08 10:43 UTC  (3+ messages)

[PATCH] c2x: message in _Static_assert() is now optional
 2020-07-07 23:49 UTC 

lock checking issues (was: Re: [PATCH v3] cifs: Fix leak when handling lease break for cached root fid)
 2020-07-07 20:34 UTC  (3+ messages)

[PATCH] test-inspect: reset locale after gtk_init()
 2020-07-05 23:28 UTC  (4+ messages)

[PATCH] arch: add minimal support for microblaze
 2020-07-05 23:23 UTC 

[PATCH 00/15] tidy-up options / reorganize lib.c
 2020-07-05 20:45 UTC  (23+ messages)
` [PATCH 01/15] options: let handle_onoff_switch() use null terminated arrays
` [PATCH 02/15] options: move -Wsparse-all's processing out of handle_onoff_switch()
` [PATCH 03/15] options: move on top the definition of warning type enums
` [PATCH 04/15] options: make Wsparse_error less special
` [PATCH 05/15] options: handle_onoff_switch() can handle any flags, not only warnings
` [PATCH 06/15] options: move helpers up
` [PATCH 07/15] options: alphasort the handle_switch_[a-zA_Z]()
` [PATCH 08/15] options: avoid spaces between function name and arguments list
` [PATCH 09/15] options: move declaration of tabstop out of "token.h"
` [PATCH 10/15] options: add a small helper: handle_switch_finalize()
` [PATCH 11/15] options: move option parsing in a separate file
` [PATCH 12/15] options: keep the options sorted
` [PATCH 13/15] cleanup: move predefines in a separate file
` [PATCH 14/15] cleanup: move parsing helpers to parse.c
` [PATCH 15/15] cleanup: move hexval() to utils.c

[PATCH 0/2] add helper predefine_{strong,weak}()
 2020-07-05 13:16 UTC  (3+ messages)
` [PATCH 1/2] predefine: "
` [PATCH 2/2] predefine: avoid add_pre_buffer() for targets

[PATCH 0/2] predefine: fix multi-token predefine
 2020-07-05 13:11 UTC  (3+ messages)
` [PATCH 1/2] predefine: add testcase for multi-token predefines
` [PATCH 2/2] predefine: fix multi-token predefine

[PATCH] testsuite: add testcase for bogus linearization of >>= & /=
 2020-07-05 12:38 UTC 

[PATCH] sindex: avoid a warning with 'case -1:'
 2020-07-05 11:45 UTC  (3+ messages)

[PATCH] predef: simplify add_pre_buffer()
 2020-07-05 10:29 UTC 

[PATCH 0/3] teach sparse about arch specific asm constraints
 2020-07-04 22:44 UTC  (9+ messages)
` [PATCH 1/3] add support for "
` [PATCH 2/3] add memory asm constraint for PPC
` [PATCH 3/3] add memory asm constraint for S390

[PATCH] testsuite: add new flag '-p' to subcommand 'format'
 2020-07-03  0:06 UTC 

[PATCH] manpage: annotations
 2020-07-03  0:04 UTC 

[Possible Spam] Covid 19 Wohltätigkeitsfonds
 2020-06-30  8:18 UTC 

[PATCH] preprocess: use predefine() also for __%s__TYPE__
 2020-06-29 19:20 UTC 

Hello,
 2020-06-29 19:15 UTC 

[PATCH] remove unneeded BSD & Solaris compatibility layer
 2020-06-28  9:09 UTC  (2+ messages)

[PATCH] avoid multiple warnings when inlining undeclared calls
 2020-06-25 19:03 UTC 

Hello
 2020-06-23 12:13 UTC 

Greetings From Mrs. Sarah Koffi
 2020-06-23 11:15 UTC 

[PATCH] testsuite: fix 'format help' / validate number of arguments
 2020-06-22 23:34 UTC 

[PATCH] teach sparse about __STDC_HOSTED__
 2020-06-22 23:12 UTC 

[PATCH] gensel: remove unneeded test/uninitialized warning
 2020-06-22 22:38 UTC  (2+ messages)

URGENT REPLY
 2020-06-22 16:02 UTC 

[PATCH] evaluate.c: fix a gcc 'may be used uninitialized' warning
 2020-06-21 20:18 UTC  (3+ messages)

[ANNOUNCE] Sparse v0.6.2
 2020-06-21 13:34 UTC 

[PATCH] doc: add some info to the main page
 2020-06-21  9:39 UTC 

[ANNOUNCE] Sparse v0.6.2-rc2
 2020-06-20 14:12 UTC  (3+ messages)

[PATCH 0/5] Fixes for generic selection
 2020-06-19 15:03 UTC  (6+ messages)
` [PATCH 1/5] gensel: add testcases from DR481
` [PATCH 2/5] gensel: use temporary variable in generic selection
` [PATCH 3/5] gensel: controlling expression must be lvalue converted
` [PATCH 4/5] gensel: controlling expression must be pointer-converted
` [PATCH 5/5] gensel: validate the type of the associations

[PATCH 0/5] support builtin macros & __has_feature()
 2020-06-18 20:47 UTC  (6+ messages)
` [PATCH 1/5] pre-process: add testcases for __has_feature() & __has_extension()
` [PATCH 2/5] pre-process: rename 'expander' into 'expand_simple'
` [PATCH 3/5] pre-process: add support for builtin macros
` [PATCH 4/5] pre-process: add support for __has_feature() & __has_extension()
` [PATCH 5/5] pre-process: make __has_{attribute,builtin}() true builtin macros

[PATCH] ir-validate: remove orphan comments
 2020-06-18 18:58 UTC  (2+ messages)

[PATCH] testsuite: be less paranoid with timeout
 2020-06-16 21:11 UTC 

[PATCH] build: let the C++ compiler be configurable
 2020-06-16 21:10 UTC 

[PATCH] doc: reformulate an item in the TODO
 2020-06-16 21:04 UTC 

[PATCH] doc: fix markup in types.rst (s/```/``/)
 2020-06-16 21:04 UTC 

[PATCH] doc: fix some typos
 2020-06-16 21:03 UTC 

[PATCH] doc: update TODO
 2020-06-16 21:02 UTC 

[PATCH] doc: add intro stolen from the wiki
 2020-06-16 20:57 UTC  (3+ messages)

[PATCH] predefine: add a macro telling about named address spaces
 2020-06-16 20:51 UTC  (3+ messages)

[PATCH] doc: copy the old relnotes here
 2020-06-16  0:09 UTC 

donation of Euro 2,000,000.00
 2020-06-15 21:54 UTC 

[ANNOUNCE] Sparse v0.6.2-rc1
 2020-06-15 23:33 UTC  (7+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).