linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "CK Hu (胡俊光)" <ck.hu@mediatek.com>
To: "Shawn Sung (宋孝謙)" <Shawn.Sung@mediatek.com>,
	"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>,
	"angelogioacchino.delregno@collabora.com"
	<angelogioacchino.delregno@collabora.com>
Cc: "sumit.semwal@linaro.org" <sumit.semwal@linaro.org>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linaro-mm-sig@lists.linaro.org" <linaro-mm-sig@lists.linaro.org>,
	"christian.koenig@amd.com" <christian.koenig@amd.com>,
	"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"shawn.sung@mediatek.corp-partner.google.com"
	<shawn.sung@mediatek.corp-partner.google.com>,
	"airlied@gmail.com" <airlied@gmail.com>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>
Subject: Re: [PATCH 10/11] drm/mediatek: Rename mtk_ddp_comp functions
Date: Thu, 14 Mar 2024 07:09:44 +0000	[thread overview]
Message-ID: <1497bc29a540de194751b2f7202f0ab0b8669787.camel@mediatek.com> (raw)
In-Reply-To: <20240226085059.26850-11-shawn.sung@mediatek.com>

Hi, Shawn:

On Mon, 2024-02-26 at 16:50 +0800, Shawn Sung wrote:
> From: Hsiao Chien Sung <shawn.sung@mediatek.corp-partner.google.com>
> 
> Rename functions of mtk_ddp_comp:
> - To align the naming rule
> - To reduce the code size

Reviewed-by: CK Hu <ck.hu@mediatek.com>

> 
> Signed-off-by: Hsiao Chien Sung <
> shawn.sung@mediatek.corp-partner.google.com>
> ---
>  drivers/gpu/drm/mediatek/mtk_ddp_comp.c | 45 ++++++++++++++---------
> --
>  drivers/gpu/drm/mediatek/mtk_ddp_comp.h |  3 +-
>  drivers/gpu/drm/mediatek/mtk_dpi.c      |  2 +-
>  drivers/gpu/drm/mediatek/mtk_dsi.c      |  2 +-
>  4 files changed, 28 insertions(+), 24 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_ddp_comp.c
> b/drivers/gpu/drm/mediatek/mtk_ddp_comp.c
> index ab846a9f98c5..f6d482d27c63 100644
> --- a/drivers/gpu/drm/mediatek/mtk_ddp_comp.c
> +++ b/drivers/gpu/drm/mediatek/mtk_ddp_comp.c
> @@ -497,10 +497,10 @@ static const struct mtk_ddp_comp_match
> mtk_ddp_matches[DDP_COMPONENT_DRM_ID_MAX]
>  	[DDP_COMPONENT_WDMA1]		= { MTK_DISP_WDMA,		
> 1, NULL },
>  };
>  
> -static bool mtk_drm_find_comp_in_ddp(struct device *dev,
> -				     const unsigned int *path,
> -				     unsigned int path_len,
> -				     struct mtk_ddp_comp *ddp_comp)
> +static bool mtk_ddp_comp_find(struct device *dev,
> +			      const unsigned int *path,
> +			      unsigned int path_len,
> +			      struct mtk_ddp_comp *ddp_comp)
>  {
>  	unsigned int i;
>  
> @@ -514,10 +514,10 @@ static bool mtk_drm_find_comp_in_ddp(struct
> device *dev,
>  	return false;
>  }
>  
> -static unsigned int mtk_drm_find_comp_in_ddp_conn_path(struct device
> *dev,
> -						       const struct
> mtk_drm_route *routes,
> -						       unsigned int
> num_routes,
> -						       struct
> mtk_ddp_comp *ddp_comp)
> +static unsigned int mtk_ddp_comp_find_in_route(struct device *dev,
> +					       const struct
> mtk_drm_route *routes,
> +					       unsigned int num_routes,
> +					       struct mtk_ddp_comp
> *ddp_comp)
>  {
>  	int ret;
>  	unsigned int i;
> @@ -554,26 +554,31 @@ int mtk_ddp_comp_get_id(struct device_node
> *node,
>  	return -EINVAL;
>  }
>  
> -unsigned int mtk_drm_find_possible_crtc_by_comp(struct drm_device
> *drm,
> -						struct device *dev)
> +unsigned int mtk_find_possible_crtcs(struct drm_device *drm, struct
> device *dev)
>  {
>  	struct mtk_drm_private *private = drm->dev_private;
>  	unsigned int ret = 0;
>  
> -	if (mtk_drm_find_comp_in_ddp(dev, private->data->main_path,
> private->data->main_len,
> -				     private->ddp_comp))
> +	if (mtk_ddp_comp_find(dev,
> +			      private->data->main_path,
> +			      private->data->main_len,
> +			      private->ddp_comp))
>  		ret = BIT(0);
> -	else if (mtk_drm_find_comp_in_ddp(dev, private->data->ext_path,
> -					  private->data->ext_len,
> private->ddp_comp))
> +	else if (mtk_ddp_comp_find(dev,
> +				   private->data->ext_path,
> +				   private->data->ext_len,
> +				   private->ddp_comp))
>  		ret = BIT(1);
> -	else if (mtk_drm_find_comp_in_ddp(dev, private->data-
> >third_path,
> -					  private->data->third_len,
> private->ddp_comp))
> +	else if (mtk_ddp_comp_find(dev,
> +				   private->data->third_path,
> +				   private->data->third_len,
> +				   private->ddp_comp))
>  		ret = BIT(2);
>  	else
> -		ret = mtk_drm_find_comp_in_ddp_conn_path(dev,
> -							 private->data-
> >conn_routes,
> -							 private->data-
> >num_conn_routes,
> -							 private-
> >ddp_comp);
> +		ret = mtk_ddp_comp_find_in_route(dev,
> +						 private->data-
> >conn_routes,
> +						 private->data-
> >num_conn_routes,
> +						 private->ddp_comp);
>  
>  	return ret;
>  }
> diff --git a/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> b/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> index ba985206fdd2..26236691ce4c 100644
> --- a/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> +++ b/drivers/gpu/drm/mediatek/mtk_ddp_comp.h
> @@ -326,8 +326,7 @@ static inline void
> mtk_ddp_comp_encoder_index_set(struct mtk_ddp_comp *comp)
>  
>  int mtk_ddp_comp_get_id(struct device_node *node,
>  			enum mtk_ddp_comp_type comp_type);
> -unsigned int mtk_drm_find_possible_crtc_by_comp(struct drm_device
> *drm,
> -						struct device *dev);
> +unsigned int mtk_find_possible_crtcs(struct drm_device *drm, struct
> device *dev);
>  int mtk_ddp_comp_init(struct device_node *comp_node, struct
> mtk_ddp_comp *comp,
>  		      unsigned int comp_id);
>  enum mtk_ddp_comp_type mtk_ddp_comp_get_type(unsigned int comp_id);
> diff --git a/drivers/gpu/drm/mediatek/mtk_dpi.c
> b/drivers/gpu/drm/mediatek/mtk_dpi.c
> index 84745ec9dd7c..0c83a4400088 100644
> --- a/drivers/gpu/drm/mediatek/mtk_dpi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_dpi.c
> @@ -805,7 +805,7 @@ static int mtk_dpi_bind(struct device *dev,
> struct device *master, void *data)
>  		return ret;
>  	}
>  
> -	dpi->encoder.possible_crtcs =
> mtk_drm_find_possible_crtc_by_comp(drm_dev, dpi->dev);
> +	dpi->encoder.possible_crtcs = mtk_find_possible_crtcs(drm_dev,
> dpi->dev);
>  
>  	ret = drm_bridge_attach(&dpi->encoder, &dpi->bridge, NULL,
>  				DRM_BRIDGE_ATTACH_NO_CONNECTOR);
> diff --git a/drivers/gpu/drm/mediatek/mtk_dsi.c
> b/drivers/gpu/drm/mediatek/mtk_dsi.c
> index a9071c4dce0e..811b7305668f 100644
> --- a/drivers/gpu/drm/mediatek/mtk_dsi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_dsi.c
> @@ -836,7 +836,7 @@ static int mtk_dsi_encoder_init(struct drm_device
> *drm, struct mtk_dsi *dsi)
>  		return ret;
>  	}
>  
> -	dsi->encoder.possible_crtcs =
> mtk_drm_find_possible_crtc_by_comp(drm, dsi->host.dev);
> +	dsi->encoder.possible_crtcs = mtk_find_possible_crtcs(drm, dsi-
> >host.dev);
>  
>  	ret = drm_bridge_attach(&dsi->encoder, &dsi->bridge, NULL,
>  				DRM_BRIDGE_ATTACH_NO_CONNECTOR);

  parent reply	other threads:[~2024-03-14  7:09 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-26  8:50 [PATCH 00/11] Rename mtk_drm_* to mtk_* Shawn Sung
2024-02-26  8:50 ` [PATCH 01/11] drm/mediatek: Rename "mtk_drm_crtc" to "mtk_crtc" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  3:26   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 02/11] drm/mediatek: Rename "mtk_drm_ddp_comp" to "mtk_ddp_comp" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  5:14   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 03/11] drm/mediatek: Rename "mtk_drm_plane" to "mtk_plane" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  5:20   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 04/11] drm/mediatek: Rename "mtk_drm_gem" to "mtk_gem" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  5:49   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 05/11] drm/mediatek: Rename "mtk_drm_hdmi" to "mtk_hdmi" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:24   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 06/11] drm/mediatek: Rename files "mtk_drm_crtc.*" to "mtk_crtc.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:40   ` CK Hu (胡俊光)
2024-03-14  6:50     ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 07/11] drm/mediatek: Rename files "mtk_drm_ddp_comp.*" to "mtk_ddp_comp.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:54   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 08/11] drm/mediatek: Rename files "mtk_drm_plane.*" to "mtk_plane.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:57   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 09/11] drm/mediatek: Rename files "mtk_drm_gem.*" to "mtk_gem.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  7:03   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 10/11] drm/mediatek: Rename mtk_ddp_comp functions Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  7:09   ` CK Hu (胡俊光) [this message]
2024-02-26  8:50 ` [PATCH 11/11] drm/mediatek: Rename "pending_needs_vblank" to "needs_vblank" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-02-29  2:35     ` Shawn Sung (宋孝謙)
2024-03-14  7:26   ` CK Hu (胡俊光)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1497bc29a540de194751b2f7202f0ab0b8669787.camel@mediatek.com \
    --to=ck.hu@mediatek.com \
    --cc=Shawn.Sung@mediatek.com \
    --cc=airlied@gmail.com \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=christian.koenig@amd.com \
    --cc=chunkuang.hu@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=p.zabel@pengutronix.de \
    --cc=shawn.sung@mediatek.corp-partner.google.com \
    --cc=sumit.semwal@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).