linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "CK Hu (胡俊光)" <ck.hu@mediatek.com>
To: "Shawn Sung (宋孝謙)" <Shawn.Sung@mediatek.com>,
	"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>,
	"angelogioacchino.delregno@collabora.com"
	<angelogioacchino.delregno@collabora.com>
Cc: "sumit.semwal@linaro.org" <sumit.semwal@linaro.org>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linaro-mm-sig@lists.linaro.org" <linaro-mm-sig@lists.linaro.org>,
	"christian.koenig@amd.com" <christian.koenig@amd.com>,
	"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"shawn.sung@mediatek.corp-partner.google.com"
	<shawn.sung@mediatek.corp-partner.google.com>,
	"airlied@gmail.com" <airlied@gmail.com>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>
Subject: Re: [PATCH 05/11] drm/mediatek: Rename "mtk_drm_hdmi" to "mtk_hdmi"
Date: Thu, 14 Mar 2024 06:24:18 +0000	[thread overview]
Message-ID: <f3976174c6e034d7498b0565dcbc88269fd74a2f.camel@mediatek.com> (raw)
In-Reply-To: <20240226085059.26850-6-shawn.sung@mediatek.com>

Hi, Shawn:

On Mon, 2024-02-26 at 16:50 +0800, Shawn Sung wrote:
> From: Hsiao Chien Sung <shawn.sung@mediatek.corp-partner.google.com>
> 
> Rename all "mtk_drm_hdmi" to "mtk_hdmi":
> - To align the naming rule
> - To reduce the code size

Reviewed-by: CK Hu <ck.hu@mediatek.com>

> 
> Signed-off-by: Hsiao Chien Sung <
> shawn.sung@mediatek.corp-partner.google.com>
> ---
>  drivers/gpu/drm/mediatek/mtk_hdmi.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi.c
> b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> index 86133bf16326..d2876da1b43a 100644
> --- a/drivers/gpu/drm/mediatek/mtk_hdmi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> @@ -1687,7 +1687,7 @@ static int
> mtk_hdmi_register_audio_driver(struct device *dev)
>  	return 0;
>  }
>  
> -static int mtk_drm_hdmi_probe(struct platform_device *pdev)
> +static int mtk_hdmi_probe(struct platform_device *pdev)
>  {
>  	struct mtk_hdmi *hdmi;
>  	struct device *dev = &pdev->dev;
> @@ -1746,7 +1746,7 @@ static int mtk_drm_hdmi_probe(struct
> platform_device *pdev)
>  	return ret;
>  }
>  
> -static void mtk_drm_hdmi_remove(struct platform_device *pdev)
> +static void mtk_hdmi_remove(struct platform_device *pdev)
>  {
>  	struct mtk_hdmi *hdmi = platform_get_drvdata(pdev);
>  
> @@ -1790,7 +1790,7 @@ static const struct mtk_hdmi_conf
> mtk_hdmi_conf_mt8167 = {
>  	.cea_modes_only = true,
>  };
>  
> -static const struct of_device_id mtk_drm_hdmi_of_ids[] = {
> +static const struct of_device_id mtk_hdmi_of_ids[] = {
>  	{ .compatible = "mediatek,mt2701-hdmi",
>  	  .data = &mtk_hdmi_conf_mt2701,
>  	},
> @@ -1801,14 +1801,14 @@ static const struct of_device_id
> mtk_drm_hdmi_of_ids[] = {
>  	},
>  	{}
>  };
> -MODULE_DEVICE_TABLE(of, mtk_drm_hdmi_of_ids);
> +MODULE_DEVICE_TABLE(of, mtk_hdmi_of_ids);
>  
>  static struct platform_driver mtk_hdmi_driver = {
> -	.probe = mtk_drm_hdmi_probe,
> -	.remove_new = mtk_drm_hdmi_remove,
> +	.probe = mtk_hdmi_probe,
> +	.remove_new = mtk_hdmi_remove,
>  	.driver = {
>  		.name = "mediatek-drm-hdmi",
> -		.of_match_table = mtk_drm_hdmi_of_ids,
> +		.of_match_table = mtk_hdmi_of_ids,
>  		.pm = &mtk_hdmi_pm_ops,
>  	},
>  };

  parent reply	other threads:[~2024-03-14  6:24 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-26  8:50 [PATCH 00/11] Rename mtk_drm_* to mtk_* Shawn Sung
2024-02-26  8:50 ` [PATCH 01/11] drm/mediatek: Rename "mtk_drm_crtc" to "mtk_crtc" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  3:26   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 02/11] drm/mediatek: Rename "mtk_drm_ddp_comp" to "mtk_ddp_comp" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  5:14   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 03/11] drm/mediatek: Rename "mtk_drm_plane" to "mtk_plane" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  5:20   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 04/11] drm/mediatek: Rename "mtk_drm_gem" to "mtk_gem" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  5:49   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 05/11] drm/mediatek: Rename "mtk_drm_hdmi" to "mtk_hdmi" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:24   ` CK Hu (胡俊光) [this message]
2024-02-26  8:50 ` [PATCH 06/11] drm/mediatek: Rename files "mtk_drm_crtc.*" to "mtk_crtc.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:40   ` CK Hu (胡俊光)
2024-03-14  6:50     ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 07/11] drm/mediatek: Rename files "mtk_drm_ddp_comp.*" to "mtk_ddp_comp.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:54   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 08/11] drm/mediatek: Rename files "mtk_drm_plane.*" to "mtk_plane.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  6:57   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 09/11] drm/mediatek: Rename files "mtk_drm_gem.*" to "mtk_gem.*" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  7:03   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 10/11] drm/mediatek: Rename mtk_ddp_comp functions Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-03-14  7:09   ` CK Hu (胡俊光)
2024-02-26  8:50 ` [PATCH 11/11] drm/mediatek: Rename "pending_needs_vblank" to "needs_vblank" Shawn Sung
2024-02-26 12:39   ` AngeloGioacchino Del Regno
2024-02-29  2:35     ` Shawn Sung (宋孝謙)
2024-03-14  7:26   ` CK Hu (胡俊光)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f3976174c6e034d7498b0565dcbc88269fd74a2f.camel@mediatek.com \
    --to=ck.hu@mediatek.com \
    --cc=Shawn.Sung@mediatek.com \
    --cc=airlied@gmail.com \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=christian.koenig@amd.com \
    --cc=chunkuang.hu@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=p.zabel@pengutronix.de \
    --cc=shawn.sung@mediatek.corp-partner.google.com \
    --cc=sumit.semwal@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).