linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] staging: xgifb: remove unused macro XGIPART3
@ 2017-11-30  2:53 Joshua Abraham
  2017-11-30  5:55 ` Dan Carpenter
  0 siblings, 1 reply; 3+ messages in thread
From: Joshua Abraham @ 2017-11-30  2:53 UTC (permalink / raw)
  To: arnaud.patard
  Cc: gregkh, j.abraham1776, pombredanne, tglx, kstewart, devel, linux-kernel

Signed-off-by: Joshua Abraham <j.abraham1776@gmail.com>

This patch removes the unused macro XGIPART3.

---
 drivers/staging/xgifb/XGI_main.h | 1 -
 1 file changed, 1 deletion(-)

diff --git a/drivers/staging/xgifb/XGI_main.h b/drivers/staging/xgifb/XGI_main.h
index a3af1cbbf8ee..5f55d0a39bc1 100644
--- a/drivers/staging/xgifb/XGI_main.h
+++ b/drivers/staging/xgifb/XGI_main.h
@@ -25,7 +25,6 @@ MODULE_DEVICE_TABLE(pci, xgifb_pci_table);
 #define XGIDACD			  (xgifb_info->dev_info.P3c9)
 #define XGIPART1		  (xgifb_info->dev_info.Part1Port)
 #define XGIPART2		  (xgifb_info->dev_info.Part2Port)
-#define XGIPART3		  (xgifb_info->dev_info.Part3Port)
 #define XGIPART4		  (xgifb_info->dev_info.Part4Port)
 #define XGIPART5		  (xgifb_info->dev_info.Part5Port)
 #define XGIDAC2A                  XGIPART5
-- 
2.15.0

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] staging: xgifb: remove unused macro XGIPART3
  2017-11-30  2:53 [PATCH] staging: xgifb: remove unused macro XGIPART3 Joshua Abraham
@ 2017-11-30  5:55 ` Dan Carpenter
  2017-11-30 12:52   ` Josh Abraham
  0 siblings, 1 reply; 3+ messages in thread
From: Dan Carpenter @ 2017-11-30  5:55 UTC (permalink / raw)
  To: Joshua Abraham
  Cc: arnaud.patard, kstewart, devel, gregkh, linux-kernel, pombredanne, tglx

On Wed, Nov 29, 2017 at 09:53:48PM -0500, Joshua Abraham wrote:
> Signed-off-by: Joshua Abraham <j.abraham1776@gmail.com>
> 
> This patch removes the unused macro XGIPART3.
> 

The Signed-off-by line goes after the changelog.

> ---
>  drivers/staging/xgifb/XGI_main.h | 1 -
>  1 file changed, 1 deletion(-)
> 
> diff --git a/drivers/staging/xgifb/XGI_main.h b/drivers/staging/xgifb/XGI_main.h
> index a3af1cbbf8ee..5f55d0a39bc1 100644
> --- a/drivers/staging/xgifb/XGI_main.h
> +++ b/drivers/staging/xgifb/XGI_main.h
> @@ -25,7 +25,6 @@ MODULE_DEVICE_TABLE(pci, xgifb_pci_table);
>  #define XGIDACD			  (xgifb_info->dev_info.P3c9)
>  #define XGIPART1		  (xgifb_info->dev_info.Part1Port)
>  #define XGIPART2		  (xgifb_info->dev_info.Part2Port)
> -#define XGIPART3		  (xgifb_info->dev_info.Part3Port)

That define isn't hurting anyone.

>  #define XGIPART4		  (xgifb_info->dev_info.Part4Port)
>  #define XGIPART5		  (xgifb_info->dev_info.Part5Port)

Actually these should all be deleted because they mean you have to have
a xgifb_info variable and they hurt readability by hiding stuff behind a
define.  It would be better to remove them all than to just remove one
from the middle.  That's a more complicated patch, but it's a useful
patch.

regards,
dan carpenter

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] staging: xgifb: remove unused macro XGIPART3
  2017-11-30  5:55 ` Dan Carpenter
@ 2017-11-30 12:52   ` Josh Abraham
  0 siblings, 0 replies; 3+ messages in thread
From: Josh Abraham @ 2017-11-30 12:52 UTC (permalink / raw)
  To: Dan Carpenter
  Cc: arnaud.patard, kstewart, devel, gregkh, linux-kernel, pombredanne, tglx

On Thu, Nov 30, 2017 at 08:55:44AM +0300, Dan Carpenter wrote:
> On Wed, Nov 29, 2017 at 09:53:48PM -0500, Joshua Abraham wrote:
> > Signed-off-by: Joshua Abraham <j.abraham1776@gmail.com>
> > 
> > This patch removes the unused macro XGIPART3.
> > 
> 
> The Signed-off-by line goes after the changelog.
> 
> > ---
> >  drivers/staging/xgifb/XGI_main.h | 1 -
> >  1 file changed, 1 deletion(-)
> > 
> > diff --git a/drivers/staging/xgifb/XGI_main.h b/drivers/staging/xgifb/XGI_main.h
> > index a3af1cbbf8ee..5f55d0a39bc1 100644
> > --- a/drivers/staging/xgifb/XGI_main.h
> > +++ b/drivers/staging/xgifb/XGI_main.h
> > @@ -25,7 +25,6 @@ MODULE_DEVICE_TABLE(pci, xgifb_pci_table);
> >  #define XGIDACD			  (xgifb_info->dev_info.P3c9)
> >  #define XGIPART1		  (xgifb_info->dev_info.Part1Port)
> >  #define XGIPART2		  (xgifb_info->dev_info.Part2Port)
> > -#define XGIPART3		  (xgifb_info->dev_info.Part3Port)
> 
> That define isn't hurting anyone.
> 
> >  #define XGIPART4		  (xgifb_info->dev_info.Part4Port)
> >  #define XGIPART5		  (xgifb_info->dev_info.Part5Port)
> 
> Actually these should all be deleted because they mean you have to have
> a xgifb_info variable and they hurt readability by hiding stuff behind a
> define.  It would be better to remove them all than to just remove one
> from the middle.  That's a more complicated patch, but it's a useful
> patch.
> 
> regards,
> dan carpenter
> 

Great point.  I will work on that and get the patch out!

-Josh

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2017-11-30 12:52 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-11-30  2:53 [PATCH] staging: xgifb: remove unused macro XGIPART3 Joshua Abraham
2017-11-30  5:55 ` Dan Carpenter
2017-11-30 12:52   ` Josh Abraham

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).