linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v15 0/8] Add Rockchip NFC drivers for RK3308 and others
@ 2020-11-30 10:00 Yifeng Zhao
  2020-11-30 10:00 ` [PATCH v15 1/8] dt-bindings: mtd: Describe Rockchip RK3xxx NAND flash controller Yifeng Zhao
                   ` (4 more replies)
  0 siblings, 5 replies; 13+ messages in thread
From: Yifeng Zhao @ 2020-11-30 10:00 UTC (permalink / raw)
  To: miquel.raynal, richard, vigneshr, robh+dt
  Cc: devicetree, linux-mtd, heiko, linux-rockchip, linux-arm-kernel,
	linux-kernel, Yifeng Zhao


Rockchp's NFC(Nand Flash Controller) has four versions: V600, V622, V800 and
V900.This series patch can support all four versions.


Changes in v15:
- Use a buffer pointer nfc->page_buf instead of the original two pointers.
- Fix coding style.
- Fix some comments.

Changes in v14:
- Add oob_read and oob_write hook api.
- Support timing config and ecc config for each chips.
- Fix some comments.

Changes in v13:
- The nfc->buffer will realloc while the page size of the second mtd
  is large than the first one.
- Fix coding style.
- Fix some comments.

Changes in v12:
- Fix some warnings while make dt_binding_check
- Drop a allOf defined

Changes in v11:
- Fix compile error.

Changes in v10:
- Fix compile error on master v5.9-rc7.

Changes in v9:
- The nfc->buffer will realloc while the page size of the second mtd
  is large than the first one
- Fix coding style.
- Remove struct rk_nfc_clk.
- Prepend some function with rk_nfc_.
- Replace function readl_poll_timeout_atomic with readl_relaxed_poll_timeout.
- Remove function rk_nfc_read_byte and rk_nfc_write_byte.
- Don't select the die if 'check_only == true' in function rk_nfc_exec_op.
- Modify function rk_nfc_write_page and rk_nfc_write_page_raw.

Changes in v8:
- Fix a error while make dt_binding_check

Changes in v7:
- Fix some wrong define
- Rebase to linux-next.
- Fix coding style.
- Reserved 4 bytes at the beginning of the oob area.
- Page raw read and write included ecc data.

Changes in v6:
- Fix some wrong define
- Modified the definition of compatible
- The mtd->name set by NAND label property.
- Add some comments.
- Fix compile error.

Changes in v5:
- Fix some wrong define.
- Add boot-medium define.
- Remove some compatible define.
- Add boot blocks support  with different ECC for bootROM.
- Rename rockchip-nand.c to rockchip-nand-controller.c.
- Unification of other variable names.
- Remove some compatible define.

Changes in v4:
- The compatible define with rkxx_nfc.
- Add assigned-clocks.
- Fix some wrong defineChanges in.
- Define platform data structure for the register offsets.
- The compatible define with rkxx_nfc.
- Use SET_SYSTEM_SLEEP_PM_OPS to define PM_OPS.
- Use exec_op instead of legacy hooks.

Changes in v3:
- Change the title for the dt-bindings.

Changes in v2:
- Fix compile error.
- Include header files sorted by file name.

Yifeng Zhao (8):
  dt-bindings: mtd: Describe Rockchip RK3xxx NAND flash controller
  mtd: rawnand: rockchip: NFC drivers for RK3308, RK2928 and others
  MAINTAINERS: add maintainers to ROCKCHIP NFC
  arm64: dts: rockchip: Add NFC node for RK3308 SoC
  arm64: dts: rockchip: Add NFC node for PX30 SoC
  arm: dts: rockchip: Add NFC node for RV1108 SoC
  arm: dts: rockchip: Add NFC node for RK2928 and other SoCs
  arm: dts: rockchip: Add NFC node for RK3036 SoC

 .../mtd/rockchip,nand-controller.yaml         |  161 ++
 MAINTAINERS                                   |    4 +-
 arch/arm/boot/dts/rk3036.dtsi                 |   52 +
 arch/arm/boot/dts/rk3xxx.dtsi                 |    9 +
 arch/arm/boot/dts/rv1108.dtsi                 |   11 +
 arch/arm64/boot/dts/rockchip/px30.dtsi        |   15 +
 arch/arm64/boot/dts/rockchip/rk3308.dtsi      |   15 +
 drivers/mtd/nand/raw/Kconfig                  |   12 +
 drivers/mtd/nand/raw/Makefile                 |    1 +
 .../mtd/nand/raw/rockchip-nand-controller.c   | 1500 +++++++++++++++++
 10 files changed, 1778 insertions(+), 2 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/mtd/rockchip,nand-controller.yaml
 create mode 100644 drivers/mtd/nand/raw/rockchip-nand-controller.c

-- 
2.17.1




^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2020-12-08  7:30 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-30 10:00 [PATCH v15 0/8] Add Rockchip NFC drivers for RK3308 and others Yifeng Zhao
2020-11-30 10:00 ` [PATCH v15 1/8] dt-bindings: mtd: Describe Rockchip RK3xxx NAND flash controller Yifeng Zhao
2020-11-30 10:00 ` [PATCH v15 2/8] mtd: rawnand: rockchip: NFC drivers for RK3308, RK2928 and others Yifeng Zhao
2020-11-30 12:49   ` Johan Jonker
2020-12-06 14:10     ` Johan Jonker
2020-12-07  9:56       ` Miquel Raynal
2020-12-08  7:23       ` 赵仪峰
2020-11-30 10:00 ` [PATCH v15 3/8] MAINTAINERS: add maintainers to ROCKCHIP NFC Yifeng Zhao
2020-11-30 10:00 ` [PATCH v15 4/8] arm64: dts: rockchip: Add NFC node for RK3308 SoC Yifeng Zhao
2020-11-30 10:01 ` [PATCH v15 5/8] arm64: dts: rockchip: Add NFC node for PX30 SoC Yifeng Zhao
2020-11-30 10:01   ` [PATCH v15 6/8] arm: dts: rockchip: Add NFC node for RV1108 SoC Yifeng Zhao
2020-11-30 10:01   ` [PATCH v15 7/8] arm: dts: rockchip: Add NFC node for RK2928 and other SoCs Yifeng Zhao
2020-11-30 10:01   ` [PATCH v15 8/8] arm: dts: rockchip: Add NFC node for RK3036 SoC Yifeng Zhao

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).