linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible
@ 2022-07-12 16:33 Francesco Dolcini
  2022-07-12 16:33 ` [PATCH v2 1/5] mfd: stmpe: Remove rotator block from probe Francesco Dolcini
                   ` (5 more replies)
  0 siblings, 6 replies; 25+ messages in thread
From: Francesco Dolcini @ 2022-07-12 16:33 UTC (permalink / raw)
  To: Lee Jones, Maxime Coquelin, Alexandre Torgue, Rob Herring,
	Krzysztof Kozlowski
  Cc: Francesco Dolcini, Linus Walleij, Bartosz Golaszewski,
	Jonathan Cameron, Lars-Peter Clausen, Dmitry Torokhov,
	linux-input, linux-stm32, linux-arm-kernel, linux-kernel,
	linux-gpio, devicetree, linux-iio

Hi all,
This series update the STMPE MFD driver to use of_compatible to probe for
sub-functions instead of using hardcoded names.  Matching by name does not seems
in general a good idea, in this specific case it is even worst since the node
name are not compliant to the current naming convention (they are not generic
and they do include underscores), and because of that recently
we had a regression introduced [1].

This change was suggested by Ahmad Fatoum [2].

[1] commit 56086b5e ("ARM: dts: imx6qdl-apalis: Avoid underscore in node name")
[2] https://lore.kernel.org/all/86815346-209e-304e-3565-b4160afa48e8@pengutronix.de/

Changes in v2:
 - split in a separate patch the removal of rotator from probe
 - remove define usage for compatible strings

Francesco Dolcini (5):
  mfd: stmpe: Remove rotator block from probe
  mfd: stmpe: Probe sub-function by compatible
  dt-bindings: gpio: stmpe: Remove node name requirement
  dt-bindings: iio: adc: stmpe: Remove node name requirement
  dt-bindings: input: touchscreen: stmpe: Remove node name requirement

 .../devicetree/bindings/gpio/gpio-stmpe.txt         |  3 +--
 .../devicetree/bindings/iio/adc/st,stmpe-adc.yaml   |  3 +--
 .../devicetree/bindings/input/touchscreen/stmpe.txt |  3 +--
 drivers/mfd/stmpe.c                                 | 13 +++++--------
 4 files changed, 8 insertions(+), 14 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 25+ messages in thread

end of thread, other threads:[~2022-09-06  3:15 UTC | newest]

Thread overview: 25+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-07-12 16:33 [PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible Francesco Dolcini
2022-07-12 16:33 ` [PATCH v2 1/5] mfd: stmpe: Remove rotator block from probe Francesco Dolcini
2022-08-08 15:17   ` Lee Jones
2022-07-12 16:33 ` [PATCH v2 2/5] mfd: stmpe: Probe sub-function by compatible Francesco Dolcini
2022-07-18  9:20   ` Linus Walleij
2022-08-08 15:18   ` Lee Jones
2022-07-12 16:33 ` [PATCH v2 3/5] dt-bindings: gpio: stmpe: Remove node name requirement Francesco Dolcini
2022-07-12 21:23   ` Krzysztof Kozlowski
2022-07-13  7:43   ` Bartosz Golaszewski
2022-07-18 10:43   ` Francesco Dolcini
2022-08-09 13:48   ` Francesco Dolcini
2022-08-31 19:57     ` Bartosz Golaszewski
2022-07-12 16:33 ` [PATCH v2 4/5] dt-bindings: iio: adc: " Francesco Dolcini
2022-07-12 21:23   ` Krzysztof Kozlowski
2022-07-13 16:24   ` Jonathan Cameron
2022-08-09 13:46   ` Francesco Dolcini
2022-08-09 15:37     ` Lee Jones
2022-08-13 15:05       ` Jonathan Cameron
2022-07-12 16:33 ` [PATCH v2 5/5] dt-bindings: input: touchscreen: " Francesco Dolcini
2022-07-12 21:23   ` Krzysztof Kozlowski
2022-08-09 13:50   ` Francesco Dolcini
2022-09-05  7:22   ` Francesco Dolcini
2022-09-06  3:15   ` Dmitry Torokhov
2022-08-09  7:54 ` [PATCH v2 0/5] mfd: stmpe: Probe sub-function by compatible Francesco Dolcini
2022-08-09 13:38   ` Lee Jones

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).