linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] deprecated.rst: Remove now removed uninitialized_var
@ 2020-08-27  3:12 Joe Perches
  2020-08-27  3:27 ` Nick Desaulniers
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Joe Perches @ 2020-08-27  3:12 UTC (permalink / raw)
  To: Linus Torvalds
  Cc: Jonathan Corbet, Kees Cook, Nick Desaulniers, LKML, linux-doc

It's now gone from the kernel so remove it from the deprecated API text.

Signed-off-by: Joe Perches <joe@perches.com>
---
 Documentation/process/deprecated.rst | 18 ------------------
 1 file changed, 18 deletions(-)

diff --git a/Documentation/process/deprecated.rst b/Documentation/process/deprecated.rst
index 918e32d76fc4..70720f00b9aa 100644
--- a/Documentation/process/deprecated.rst
+++ b/Documentation/process/deprecated.rst
@@ -51,24 +51,6 @@ to make sure their systems do not continue running in the face of
 "unreachable" conditions. (For example, see commits like `this one
 <https://git.kernel.org/linus/d4689846881d160a4d12a514e991a740bcb5d65a>`_.)
 
-uninitialized_var()
--------------------
-For any compiler warnings about uninitialized variables, just add
-an initializer. Using the uninitialized_var() macro (or similar
-warning-silencing tricks) is dangerous as it papers over `real bugs
-<https://lore.kernel.org/lkml/20200603174714.192027-1-glider@google.com/>`_
-(or can in the future), and suppresses unrelated compiler warnings
-(e.g. "unused variable"). If the compiler thinks it is uninitialized,
-either simply initialize the variable or make compiler changes. Keep in
-mind that in most cases, if an initialization is obviously redundant,
-the compiler's dead-store elimination pass will make sure there are no
-needless variable writes.
-
-As Linus has said, this macro
-`must <https://lore.kernel.org/lkml/CA+55aFw+Vbj0i=1TGqCR5vQkCzWJ0QxK6CernOU6eedsudAixw@mail.gmail.com/>`_
-`be <https://lore.kernel.org/lkml/CA+55aFwgbgqhbp1fkxvRKEpzyR5J8n1vKT1VZdz9knmPuXhOeg@mail.gmail.com/>`_
-`removed <https://lore.kernel.org/lkml/CA+55aFz2500WfbKXAx8s67wrm9=yVJu65TpLgN_ybYNv0VEOKA@mail.gmail.com/>`_.
-
 open-coded arithmetic in allocator arguments
 --------------------------------------------
 Dynamic size calculations (especially multiplication) should not be



^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] deprecated.rst: Remove now removed uninitialized_var
  2020-08-27  3:12 [PATCH] deprecated.rst: Remove now removed uninitialized_var Joe Perches
@ 2020-08-27  3:27 ` Nick Desaulniers
  2020-08-27 14:58 ` Kees Cook
  2020-08-31 22:31 ` Jonathan Corbet
  2 siblings, 0 replies; 5+ messages in thread
From: Nick Desaulniers @ 2020-08-27  3:27 UTC (permalink / raw)
  To: Joe Perches; +Cc: Linus Torvalds, Jonathan Corbet, Kees Cook, LKML, linux-doc

On Wed, Aug 26, 2020 at 8:12 PM Joe Perches <joe@perches.com> wrote:
>
> It's now gone from the kernel so remove it from the deprecated API text.
>
> Signed-off-by: Joe Perches <joe@perches.com>

Thanks Joe.
Reviewed-by: Nick Desaulniers <ndesaulniers@google.com>

> ---
>  Documentation/process/deprecated.rst | 18 ------------------
>  1 file changed, 18 deletions(-)
>
> diff --git a/Documentation/process/deprecated.rst b/Documentation/process/deprecated.rst
> index 918e32d76fc4..70720f00b9aa 100644
> --- a/Documentation/process/deprecated.rst
> +++ b/Documentation/process/deprecated.rst
> @@ -51,24 +51,6 @@ to make sure their systems do not continue running in the face of
>  "unreachable" conditions. (For example, see commits like `this one
>  <https://git.kernel.org/linus/d4689846881d160a4d12a514e991a740bcb5d65a>`_.)
>
> -uninitialized_var()
> --------------------
> -For any compiler warnings about uninitialized variables, just add
> -an initializer. Using the uninitialized_var() macro (or similar
> -warning-silencing tricks) is dangerous as it papers over `real bugs
> -<https://lore.kernel.org/lkml/20200603174714.192027-1-glider@google.com/>`_
> -(or can in the future), and suppresses unrelated compiler warnings
> -(e.g. "unused variable"). If the compiler thinks it is uninitialized,
> -either simply initialize the variable or make compiler changes. Keep in
> -mind that in most cases, if an initialization is obviously redundant,
> -the compiler's dead-store elimination pass will make sure there are no
> -needless variable writes.
> -
> -As Linus has said, this macro
> -`must <https://lore.kernel.org/lkml/CA+55aFw+Vbj0i=1TGqCR5vQkCzWJ0QxK6CernOU6eedsudAixw@mail.gmail.com/>`_
> -`be <https://lore.kernel.org/lkml/CA+55aFwgbgqhbp1fkxvRKEpzyR5J8n1vKT1VZdz9knmPuXhOeg@mail.gmail.com/>`_
> -`removed <https://lore.kernel.org/lkml/CA+55aFz2500WfbKXAx8s67wrm9=yVJu65TpLgN_ybYNv0VEOKA@mail.gmail.com/>`_.
> -
>  open-coded arithmetic in allocator arguments
>  --------------------------------------------
>  Dynamic size calculations (especially multiplication) should not be
>
>


-- 
Thanks,
~Nick Desaulniers

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] deprecated.rst: Remove now removed uninitialized_var
  2020-08-27  3:12 [PATCH] deprecated.rst: Remove now removed uninitialized_var Joe Perches
  2020-08-27  3:27 ` Nick Desaulniers
@ 2020-08-27 14:58 ` Kees Cook
  2020-08-27 15:56   ` Joe Perches
  2020-08-31 22:31 ` Jonathan Corbet
  2 siblings, 1 reply; 5+ messages in thread
From: Kees Cook @ 2020-08-27 14:58 UTC (permalink / raw)
  To: Joe Perches
  Cc: Linus Torvalds, Jonathan Corbet, Nick Desaulniers, LKML, linux-doc

On Wed, Aug 26, 2020 at 08:12:01PM -0700, Joe Perches wrote:
> It's now gone from the kernel so remove it from the deprecated API text.
> 
> Signed-off-by: Joe Perches <joe@perches.com>

Oh! Right, thank you. I forgot to rewrite this. I'd like to keep the
details about why "tricking the compiler to be quiet" should not be
done. One of my fears about removing uninitialized_var() is that folks
may start adding open-coded versions to silence warnings. I'd like to
keep a section in deprecated.rst that describes the problem and why
those kinds of work-arounds should not be used.

-- 
Kees Cook

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] deprecated.rst: Remove now removed uninitialized_var
  2020-08-27 14:58 ` Kees Cook
@ 2020-08-27 15:56   ` Joe Perches
  0 siblings, 0 replies; 5+ messages in thread
From: Joe Perches @ 2020-08-27 15:56 UTC (permalink / raw)
  To: Kees Cook
  Cc: Linus Torvalds, Jonathan Corbet, Nick Desaulniers, LKML, linux-doc

On Thu, 2020-08-27 at 07:58 -0700, Kees Cook wrote:
> On Wed, Aug 26, 2020 at 08:12:01PM -0700, Joe Perches wrote:
> > It's now gone from the kernel so remove it from the deprecated API text.
> > 
> > Signed-off-by: Joe Perches <joe@perches.com>
> 
> Oh! Right, thank you. I forgot to rewrite this. I'd like to keep the
> details about why "tricking the compiler to be quiet" should not be
> done.

Probably better in coding style.

>  One of my fears about removing uninitialized_var() is that folks
> may start adding open-coded versions to silence warnings. I'd like to
> keep a section in deprecated.rst that describes the problem and why
> those kinds of work-arounds should not be used.
> 


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] deprecated.rst: Remove now removed uninitialized_var
  2020-08-27  3:12 [PATCH] deprecated.rst: Remove now removed uninitialized_var Joe Perches
  2020-08-27  3:27 ` Nick Desaulniers
  2020-08-27 14:58 ` Kees Cook
@ 2020-08-31 22:31 ` Jonathan Corbet
  2 siblings, 0 replies; 5+ messages in thread
From: Jonathan Corbet @ 2020-08-31 22:31 UTC (permalink / raw)
  To: Joe Perches; +Cc: Linus Torvalds, Kees Cook, Nick Desaulniers, LKML, linux-doc

On Wed, 26 Aug 2020 20:12:01 -0700
Joe Perches <joe@perches.com> wrote:

> It's now gone from the kernel so remove it from the deprecated API text.
> 
> Signed-off-by: Joe Perches <joe@perches.com>
> ---
>  Documentation/process/deprecated.rst | 18 ------------------
>  1 file changed, 18 deletions(-)

Applied, thanks.

jon

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-08-31 22:31 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-08-27  3:12 [PATCH] deprecated.rst: Remove now removed uninitialized_var Joe Perches
2020-08-27  3:27 ` Nick Desaulniers
2020-08-27 14:58 ` Kees Cook
2020-08-27 15:56   ` Joe Perches
2020-08-31 22:31 ` Jonathan Corbet

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).