All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v13 0/9] ZPODD Patches
@ 2013-01-15  9:20 Aaron Lu
  2013-01-15  9:20 ` [PATCH v13 1/9] scsi: sr: support runtime pm Aaron Lu
                   ` (8 more replies)
  0 siblings, 9 replies; 33+ messages in thread
From: Aaron Lu @ 2013-01-15  9:20 UTC (permalink / raw)
  To: Jeff Garzik, James Bottomley, Rafael J. Wysocki, Alan Stern, Tejun Heo
  Cc: Aaron Lu, Jeff Wu, linux-ide, linux-pm, linux-scsi, linux-acpi

v13:
Use atomic type for disk_events_disable_depth, so that disabling can
stack and has its own synchronization rule as suggested by Tejun Heo;

Set zp_ready to false whenever we found the ODD is not in ZP ready state
due to support of NO_POWEROFF qos flag. This change is made in patch 6
instead of patch 4 so that it is clear why this change is necessary.

v12:
Suggestions by Tejun Heo:
Fold patch 2 into patch 3;
Do not use bitfields in zpodd structure;
Call zpodd_exit in ata_scsi_remove_dev;
Remove run_atapi_cmd, use ata_exec_internal directly;
Use enum to return ODD loading mechanism type information;
Added some comments.

Typo fix:
Fixed some mis-spellings as pointed out by Sergei Shtylyov.

Several function name changes:
Rename zpodd_pre_poweroff to zpodd_enable_run_wake, zpodd_pre_poweron
to zpodd_disable_run_wake. This feels clearer and people can get what
the two functions are supposed to do by their names;
Rename zpodd_post_resume to zpodd_post_poweron, since this function is
only useful when the ODD is powered off during suspend.
I decided to rename these functions when I'm adding comments for them
as suggested by Tejun Heo, and I felt I didn't name them well...

QOS no_poweroff flag:
Only export qos flag for ZPODD devices, disks that can be runtime
powered off should also export this interface, but it doesn't belong
to this patchset so will be done in other patches.

A new patch:
Added a patch to remove a no more useful scsi_device flag can_power_off.

A git repo for it:
https://github.com/aaronlu/linux.git zpodd_v12

v11:
Introduce event_driven flag in scsi_device to silence the media event
poll after ODD is powered off;
Removed ata layer PM QOS control, instead, simply limit ACPI state to
D3_HOT when choosing state;
Make the power off delay a module param named zpodd_poweroff_delay,
defaults to 30 seconds.

v10:
Introduce PM_QOS_NO_POLL flag to skip calling disk's events_check
callback;
Do not use zero power ready hint information from event poll;
Check attached device in port's runtime idle callback to decide if
suspend is desired;
Address various comments from Tejun Heo.

v9:
Build ZPODD as part of libata instead of another standalone module
as it is tightly related to other libata files.
Identify and init ZPODD during probe time instead of after SCSI
device is created as suggested by Tejun Heo.
Make use of pm qos flag to give ACPI hint when choosing ACPI state.
Expose qos flag to give user control of whether power off is allowed.

This patchset used Rafael's pm-qos work:
git://git.kernel.org/pub/scm/linux/kernel/git/rafael/linux-pm.git pm-qos

v8:
This version is a redesign, it doesn't have much to do with previous
versions. The ZPODD implementation is done almost entirely in ATA layer
now, except 2 helper functions from SCSI sr driver to block disk events.

The basic idea is that, when ata port is runtime suspended, it will
check if the ODD is ready to be powered off. And if yes, events is
blocked and power omitted; if not, ODD's power supply remains unchanged
by keeping ACPI state at D0.

Some background knowledge about ZPODD is added below v1 history log.

v7:
Re work of runtime pm of sr driver, based on ideas of Alan Stern and
Oliver Neukum.

Jeff, due to the ready_to_power_off flag added, there is a small
change in [PATCH v7 6/6] libata: acpi: respect may_power_off flag,
please check if I can still get your ack, thanks.

v6:
When user changes may_power_off flag through sysfs entry and if device
is already runtime suspended, resume resume it so that it can respect
this flag next time it is runtime suspended as suggested by Alan Stern.
Call scsi_autopm_get/put_device once in sr_check_events as suggested by
Alan Stern.

v5:
Add may_power_off flag to scsi device.
Alan Stern suggested that I should not mess runtime suspend with
runtime power off, but the current zpodd implementation made it not
easy to seperate. So I re-wrote the zpodd implementation, the end
result is, normal ODD can also enter runtime suspended state, but
their power won't be removed.

v4:
Rebase on top of Linus' tree, due to this, the problem of a missing
flag in v3 is gone;
Add a new function scsi_autopm_put_device_autosuspend to first mark
last busy for the device and then put autosuspend it as suggested by
Oliver Neukum.
Typo fix as pointed by Sergei Shtylyov.
Check can_power_off flag before any runtime pm operations in sr.

v3:
Rebase on top of scsi-misc tree;
Add the sr related patches previously in Jeff's libata tree;
Re-organize the sr patches.
A problem for now: for patch
scsi: sr: support zero power ODD(ZPODD)
I can't set a flag in libata-acpi.c since a related function is
missing in scsi-misc tree. Will fix this when 3.6-rc1 released.

v2:
Bug fix for v1;
Use scsi_autopm_* in sr driver instead of pm_runtime_*;

v1:
Here are some patches to make ZPODD easier to use for end users and
a fix for using ZPODD with system suspend.

Some background knowledge about ZPODD:
ODD means Optical Disc Drive.
ZPODD means Zero Power ODD, it is a mechanism to place the ODD into
zero power state when the system is running at S0 system state without
user's awareness.
It achieved this by ACPI and SATA device attention pin. For power off,
normal ACPI control method is used to place the device into D3 cold
ACPI device state, aka. device power supply omitted. For power on, when
user press the eject button of a drawer type ODD or when user inserts
an ODD into a slot type ODD, the device attention pin will trigger. In
the current x86 implementation, this pin will connect to a GPE, and the
GPE will trigger an ACPI interrupt. With our pre-registered ACPI
notification code, the device can be runtime resumed, and we place the
device back to full power state by setting its ACPI state to D0. The
whole process is transparent to the end user.

Aaron Lu (9):
  scsi: sr: support runtime pm
  libata: identify and init ZPODD devices
  libata: move acpi notification code to zpodd
  libata: check zero power ready status for ZPODD
  libata: handle power transition of ODD
  libata: expose pm qos flags for ata device
  libata: scsi: no poll when ODD is powered off
  libata: do not suspend port if normal ODD is attached
  scsi: remove can_power_off flag from scsi_device

 drivers/ata/Kconfig        |  13 ++
 drivers/ata/Makefile       |   1 +
 drivers/ata/libata-acpi.c  | 109 +++++-----------
 drivers/ata/libata-core.c  |  23 +++-
 drivers/ata/libata-eh.c    |  16 ++-
 drivers/ata/libata-scsi.c  |   2 +
 drivers/ata/libata-zpodd.c | 300 +++++++++++++++++++++++++++++++++++++++++++++
 drivers/ata/libata.h       |  27 ++++
 drivers/scsi/scsi_lib.c    |  14 +++
 drivers/scsi/sr.c          |  36 +++++-
 include/linux/libata.h     |   3 +
 include/scsi/scsi_device.h |   5 +-
 include/uapi/linux/cdrom.h |  34 +++++
 13 files changed, 492 insertions(+), 91 deletions(-)
 create mode 100644 drivers/ata/libata-zpodd.c

-- 
1.7.11.7


^ permalink raw reply	[flat|nested] 33+ messages in thread

end of thread, other threads:[~2013-01-22 11:27 UTC | newest]

Thread overview: 33+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-01-15  9:20 [PATCH v13 0/9] ZPODD Patches Aaron Lu
2013-01-15  9:20 ` [PATCH v13 1/9] scsi: sr: support runtime pm Aaron Lu
2013-01-16 15:45   ` James Bottomley
2013-01-16 16:31     ` Alan Stern
2013-01-18  7:42       ` Aaron Lu
2013-01-18 15:24         ` Alan Stern
2013-01-19  8:55           ` Aaron Lu
2013-01-19 18:46             ` Alan Stern
2013-01-21  3:31               ` Julian Calaby
2013-01-21  8:14                 ` Aaron Lu
2013-01-21  8:55                   ` Julian Calaby
2013-01-21  9:11                     ` Aaron Lu
2013-01-21 14:56                       ` Oliver Neukum
2013-01-22  2:25                         ` Aaron Lu
2013-01-22  9:13                           ` Oliver Neukum
2013-01-22  9:20                             ` Aaron Lu
2013-01-21  8:04               ` Aaron Lu
2013-01-21  9:37               ` [RFC PATCH] " Aaron Lu
2013-01-21 16:59                 ` Alan Stern
2013-01-22  2:27                   ` Aaron Lu
2013-01-21 13:36               ` [PATCH v13 1/9] " Aaron Lu
2013-01-15  9:20 ` [PATCH v13 2/9] libata: identify and init ZPODD devices Aaron Lu
2013-01-21  9:16   ` Jeff Garzik
2013-01-21  9:28     ` Aaron Lu
2013-01-15  9:20 ` [PATCH v13 3/9] libata: move acpi notification code to zpodd Aaron Lu
2013-01-15  9:21 ` [PATCH v13 4/9] libata: check zero power ready status for ZPODD Aaron Lu
2013-01-15  9:21 ` [PATCH v13 5/9] libata: handle power transition of ODD Aaron Lu
2013-01-15  9:21 ` [PATCH v13 6/9] libata: expose pm qos flags for ata device Aaron Lu
2013-01-15  9:21 ` [PATCH v13 7/9] libata: scsi: no poll when ODD is powered off Aaron Lu
2013-01-15  9:21 ` [PATCH v13 8/9] libata: do not suspend port if normal ODD is attached Aaron Lu
2013-01-21 20:42   ` Jeff Garzik
2013-01-22 11:27     ` Aaron Lu
2013-01-15  9:21 ` [PATCH v13 9/9] scsi: remove can_power_off flag from scsi_device Aaron Lu

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.