All of lore.kernel.org
 help / color / mirror / Atom feed
From: Byungchul Park <byungchul.park@lge.com>
To: Peter Zijlstra <peterz@infradead.org>
Cc: mingo@kernel.org, tglx@linutronix.de, walken@google.com,
	boqun.feng@gmail.com, kirill@shutemov.name,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	iamjoonsoo.kim@lge.com, akpm@linux-foundation.org,
	npiggin@gmail.com, kernel-team@lge.com
Subject: Re: [PATCH v5 06/13] lockdep: Implement crossrelease feature
Date: Wed, 1 Mar 2017 13:40:33 +0900	[thread overview]
Message-ID: <20170301044033.GC11663@X58A-UD3R> (raw)
In-Reply-To: <20170228182902.GN5680@worktop>

On Tue, Feb 28, 2017 at 07:29:02PM +0100, Peter Zijlstra wrote:
> On Tue, Feb 28, 2017 at 10:24:44PM +0900, Byungchul Park wrote:
> > On Tue, Feb 28, 2017 at 02:10:12PM +0100, Peter Zijlstra wrote:
> 
> > > > +/* For easy access to xhlock */
> > > > +#define xhlock(t, i)		((t)->xhlocks + (i))
> > > > +#define xhlock_prev(t, l)	xhlock(t, idx_prev((l) - (t)->xhlocks))
> > > > +#define xhlock_curr(t)		xhlock(t, idx(t))
> > > 
> > > So these result in an xhlock pointer
> > > 
> > > > +#define xhlock_incr(t)		({idx(t) = idx_next(idx(t));})
> > > 
> > > This does not; which is confusing seeing how they share the same
> > > namespace; also incr is weird.
> > 
> > OK.. Could you suggest a better name? xhlock_adv()? advance_xhlock()?
> > And.. replace it with a function?
> 
> How about doing: xhlocks_idx++ ? That is, keep all the indexes as
> regular u32 and only reduce the space when using them as index.

OK.

> 
> Also, I would write the loop:
> 
> > +static int commit_xhlocks(struct cross_lock *xlock)
> > +{
> > +     struct task_struct *curr = current;
> > +     struct hist_lock *xhlock_c = xhlock_curr(curr);
> > +     struct hist_lock *xhlock = xhlock_c;
> > +
> > +     do {
> > +             xhlock = xhlock_prev(curr, xhlock);
> > +
> > +             if (!xhlock_used(xhlock))
> > +                     break;
> > +
> > +             if (before(xhlock->hlock.gen_id, xlock->hlock.gen_id))
> > +                     break;
> > +
> > +             if (same_context_xhlock(xhlock) &&
> > +                 before(xhlock->prev_gen_id, xlock->hlock.gen_id) &&
> > +                 !commit_xhlock(xlock, xhlock))
> > +                     return 0;
> > +     } while (xhlock_c != xhlock);
> > +
> > +     return 1;
> > +}
> 
> like:
> 
> #define xhlock(i)	current->xhlocks[i % MAX_XHLOCKS_NR]
> 
> 	for (i = 0; i < MAX_XHLOCKS_NR; i++) {
> 		xhlock = xhlock(curr->xhlock_idx - i);
> 
> 		/* ... */
> 	}
> 
> That avoids that horrible xhlock_prev() thing.

Right. I decided to force MAX_XHLOCKS_NR to be power of 2 and everything
became easy. Thank you very much.

WARNING: multiple messages have this Message-ID (diff)
From: Byungchul Park <byungchul.park@lge.com>
To: Peter Zijlstra <peterz@infradead.org>
Cc: mingo@kernel.org, tglx@linutronix.de, walken@google.com,
	boqun.feng@gmail.com, kirill@shutemov.name,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	iamjoonsoo.kim@lge.com, akpm@linux-foundation.org,
	npiggin@gmail.com, kernel-team@lge.com
Subject: Re: [PATCH v5 06/13] lockdep: Implement crossrelease feature
Date: Wed, 1 Mar 2017 13:40:33 +0900	[thread overview]
Message-ID: <20170301044033.GC11663@X58A-UD3R> (raw)
In-Reply-To: <20170228182902.GN5680@worktop>

On Tue, Feb 28, 2017 at 07:29:02PM +0100, Peter Zijlstra wrote:
> On Tue, Feb 28, 2017 at 10:24:44PM +0900, Byungchul Park wrote:
> > On Tue, Feb 28, 2017 at 02:10:12PM +0100, Peter Zijlstra wrote:
> 
> > > > +/* For easy access to xhlock */
> > > > +#define xhlock(t, i)		((t)->xhlocks + (i))
> > > > +#define xhlock_prev(t, l)	xhlock(t, idx_prev((l) - (t)->xhlocks))
> > > > +#define xhlock_curr(t)		xhlock(t, idx(t))
> > > 
> > > So these result in an xhlock pointer
> > > 
> > > > +#define xhlock_incr(t)		({idx(t) = idx_next(idx(t));})
> > > 
> > > This does not; which is confusing seeing how they share the same
> > > namespace; also incr is weird.
> > 
> > OK.. Could you suggest a better name? xhlock_adv()? advance_xhlock()?
> > And.. replace it with a function?
> 
> How about doing: xhlocks_idx++ ? That is, keep all the indexes as
> regular u32 and only reduce the space when using them as index.

OK.

> 
> Also, I would write the loop:
> 
> > +static int commit_xhlocks(struct cross_lock *xlock)
> > +{
> > +     struct task_struct *curr = current;
> > +     struct hist_lock *xhlock_c = xhlock_curr(curr);
> > +     struct hist_lock *xhlock = xhlock_c;
> > +
> > +     do {
> > +             xhlock = xhlock_prev(curr, xhlock);
> > +
> > +             if (!xhlock_used(xhlock))
> > +                     break;
> > +
> > +             if (before(xhlock->hlock.gen_id, xlock->hlock.gen_id))
> > +                     break;
> > +
> > +             if (same_context_xhlock(xhlock) &&
> > +                 before(xhlock->prev_gen_id, xlock->hlock.gen_id) &&
> > +                 !commit_xhlock(xlock, xhlock))
> > +                     return 0;
> > +     } while (xhlock_c != xhlock);
> > +
> > +     return 1;
> > +}
> 
> like:
> 
> #define xhlock(i)	current->xhlocks[i % MAX_XHLOCKS_NR]
> 
> 	for (i = 0; i < MAX_XHLOCKS_NR; i++) {
> 		xhlock = xhlock(curr->xhlock_idx - i);
> 
> 		/* ... */
> 	}
> 
> That avoids that horrible xhlock_prev() thing.

Right. I decided to force MAX_XHLOCKS_NR to be power of 2 and everything
became easy. Thank you very much.

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

  reply	other threads:[~2017-03-01  5:27 UTC|newest]

Thread overview: 124+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-18 13:17 [PATCH v5 00/13] lockdep: Implement crossrelease feature Byungchul Park
2017-01-18 13:17 ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 01/13] lockdep: Refactor lookup_chain_cache() Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-19  9:16   ` Boqun Feng
2017-01-19  9:52     ` Byungchul Park
2017-01-19  9:52       ` Byungchul Park
2017-01-26  7:53     ` Byungchul Park
2017-01-26  7:53       ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 02/13] lockdep: Fix wrong condition to print bug msgs for MAX_LOCKDEP_CHAIN_HLOCKS Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 03/13] lockdep: Add a function building a chain between two classes Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 04/13] lockdep: Refactor save_trace() Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 05/13] lockdep: Pass a callback arg to check_prev_add() to handle stack_trace Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-26  7:43   ` Byungchul Park
2017-01-26  7:43     ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 06/13] lockdep: Implement crossrelease feature Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-02-28 12:26   ` Peter Zijlstra
2017-02-28 12:26     ` Peter Zijlstra
2017-02-28 12:45   ` Peter Zijlstra
2017-02-28 12:45     ` Peter Zijlstra
2017-02-28 12:49     ` Peter Zijlstra
2017-02-28 12:49       ` Peter Zijlstra
2017-03-01  6:20       ` Byungchul Park
2017-03-01  6:20         ` Byungchul Park
2017-02-28 13:05   ` Peter Zijlstra
2017-02-28 13:05     ` Peter Zijlstra
2017-02-28 13:28     ` Byungchul Park
2017-02-28 13:28       ` Byungchul Park
2017-02-28 13:35       ` Peter Zijlstra
2017-02-28 13:35         ` Peter Zijlstra
2017-02-28 14:00         ` Byungchul Park
2017-02-28 14:00           ` Byungchul Park
2017-02-28 13:10   ` Peter Zijlstra
2017-02-28 13:10     ` Peter Zijlstra
2017-02-28 13:24     ` Byungchul Park
2017-02-28 13:24       ` Byungchul Park
2017-02-28 18:29       ` Peter Zijlstra
2017-02-28 18:29         ` Peter Zijlstra
2017-03-01  4:40         ` Byungchul Park [this message]
2017-03-01  4:40           ` Byungchul Park
2017-03-01 10:45           ` Peter Zijlstra
2017-03-01 10:45             ` Peter Zijlstra
2017-03-01 12:10             ` Byungchul Park
2017-03-01 12:10               ` Byungchul Park
2017-02-28 13:40   ` Peter Zijlstra
2017-02-28 13:40     ` Peter Zijlstra
2017-03-01  5:43     ` Byungchul Park
2017-03-01  5:43       ` Byungchul Park
2017-03-01 12:28       ` Peter Zijlstra
2017-03-01 12:28         ` Peter Zijlstra
2017-03-02 13:40         ` Peter Zijlstra
2017-03-02 13:40           ` Peter Zijlstra
2017-03-03  0:17           ` Byungchul Park
2017-03-03  0:17             ` Byungchul Park
2017-03-03  8:14             ` Peter Zijlstra
2017-03-03  8:14               ` Peter Zijlstra
2017-03-03  9:13               ` Peter Zijlstra
2017-03-03  9:13                 ` Peter Zijlstra
2017-03-03  9:32                 ` Peter Zijlstra
2017-03-03  9:32                   ` Peter Zijlstra
2017-03-05  3:33                 ` Byungchul Park
2017-03-05  3:33                   ` Byungchul Park
2017-08-10 12:18                 ` [tip:locking/core] locking/lockdep: Avoid creating redundant links tip-bot for Peter Zijlstra
2017-03-05  3:08               ` [PATCH v5 06/13] lockdep: Implement crossrelease feature Byungchul Park
2017-03-05  3:08                 ` Byungchul Park
2017-03-07 11:42                 ` Peter Zijlstra
2017-03-07 11:42                   ` Peter Zijlstra
2017-03-03  0:39           ` Byungchul Park
2017-03-03  0:39             ` Byungchul Park
2017-02-28 15:49   ` Peter Zijlstra
2017-02-28 15:49     ` Peter Zijlstra
2017-03-01  5:17     ` Byungchul Park
2017-03-01  5:17       ` Byungchul Park
2017-03-01  6:18       ` Byungchul Park
2017-03-01  6:18         ` Byungchul Park
2017-03-02  2:52       ` Byungchul Park
2017-03-02  2:52         ` Byungchul Park
2017-02-28 18:15   ` Peter Zijlstra
2017-02-28 18:15     ` Peter Zijlstra
2017-03-01  7:21     ` Byungchul Park
2017-03-01  7:21       ` Byungchul Park
2017-03-01 10:43       ` Peter Zijlstra
2017-03-01 10:43         ` Peter Zijlstra
2017-03-01 12:27         ` Byungchul Park
2017-03-01 12:27           ` Byungchul Park
2017-03-02  4:20     ` Matthew Wilcox
2017-03-02  4:20       ` Matthew Wilcox
2017-03-02  4:45       ` byungchul.park
2017-03-02  4:45         ` byungchul.park
2017-03-02 14:39         ` Matthew Wilcox
2017-03-02 14:39           ` Matthew Wilcox
2017-03-02 23:50           ` Byungchul Park
2017-03-02 23:50             ` Byungchul Park
2017-03-05  8:01             ` Byungchul Park
2017-03-05  8:01               ` Byungchul Park
2017-03-14  7:36     ` Byungchul Park
2017-03-14  7:36       ` Byungchul Park
2017-03-02 13:41   ` Peter Zijlstra
2017-03-02 13:41     ` Peter Zijlstra
2017-03-02 23:43     ` Byungchul Park
2017-03-02 23:43       ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 07/13] lockdep: Make print_circular_bug() aware of crossrelease Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 08/13] lockdep: Apply crossrelease to completions Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 09/13] pagemap.h: Remove trailing white space Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 10/13] lockdep: Apply crossrelease to PG_locked locks Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 11/13] lockdep: Apply lock_acquire(release) on __Set(__Clear)PageLocked Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 12/13] lockdep: Move data of CONFIG_LOCKDEP_PAGELOCK from page to page_ext Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-18 13:17 ` [PATCH v5 13/13] lockdep: Crossrelease feature documentation Byungchul Park
2017-01-18 13:17   ` Byungchul Park
2017-01-20  9:08   ` [REVISED DOCUMENT] " Byungchul Park
2017-01-20  9:08     ` Byungchul Park
2017-02-20  8:38 ` [PATCH v5 00/13] lockdep: Implement crossrelease feature Byungchul Park
2017-02-20  8:38   ` Byungchul Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170301044033.GC11663@X58A-UD3R \
    --to=byungchul.park@lge.com \
    --cc=akpm@linux-foundation.org \
    --cc=boqun.feng@gmail.com \
    --cc=iamjoonsoo.kim@lge.com \
    --cc=kernel-team@lge.com \
    --cc=kirill@shutemov.name \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mingo@kernel.org \
    --cc=npiggin@gmail.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=walken@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.