All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dave Martin <Dave.Martin@arm.com>
To: Mark Rutland <mark.rutland@arm.com>
Cc: "Paul Elliott" <paul.elliott@arm.com>,
	"Peter Zijlstra" <peterz@infradead.org>,
	"Catalin Marinas" <catalin.marinas@arm.com>,
	"Will Deacon" <will.deacon@arm.com>,
	"Andrew Jones" <drjones@redhat.com>,
	"Amit Kachhap" <amit.kachhap@arm.com>,
	"Vincenzo Frascino" <vincenzo.frascino@arm.com>,
	linux-arch@vger.kernel.org,
	"Eugene Syromiatnikov" <esyr@redhat.com>,
	"Szabolcs Nagy" <szabolcs.nagy@arm.com>,
	"H.J. Lu" <hjl.tools@gmail.com>,
	"Yu-cheng Yu" <yu-cheng.yu@intel.com>,
	"Kees Cook" <keescook@chromium.org>,
	"Arnd Bergmann" <arnd@arndb.de>, "Jann Horn" <jannh@google.com>,
	"Richard Henderson" <richard.henderson@linaro.org>,
	"Kristina Martšenko" <kristina.martsenko@arm.com>,
	"Mark Brown" <broonie@kernel.org>,
	"Thomas Gleixner" <tglx@linutronix.de>,
	linux-arm-kernel@lists.infradead.org,
	"Florian Weimer" <fweimer@redhat.com>,
	linux-kernel@vger.kernel.org, "Sudakshina Das" <sudi.das@arm.com>
Subject: Re: [PATCH v2 05/12] arm64: Basic Branch Target Identification support
Date: Fri, 18 Oct 2019 14:37:40 +0100	[thread overview]
Message-ID: <20191018133739.GD27757@arm.com> (raw)
In-Reply-To: <20191018111003.GC27759@lakrids.cambridge.arm.com>

On Fri, Oct 18, 2019 at 12:10:03PM +0100, Mark Rutland wrote:
> On Fri, Oct 11, 2019 at 06:20:15PM +0100, Dave Martin wrote:
> > On Fri, Oct 11, 2019 at 04:10:29PM +0100, Mark Rutland wrote:
> > > On Thu, Oct 10, 2019 at 07:44:33PM +0100, Dave Martin wrote:
> > > > +#define arch_calc_vm_prot_bits(prot, pkey) arm64_calc_vm_prot_bits(prot)
> > > > +static inline unsigned long arm64_calc_vm_prot_bits(unsigned long prot)
> > > > +{
> > > > +	if (system_supports_bti() && (prot & PROT_BTI))
> > > > +		return VM_ARM64_BTI;
> > > > +
> > > > +	return 0;
> > > > +}
> > > 
> > > Can we call this arch_calc_vm_prot_bits() directly, with all the
> > > arguments:
> > > 
> > > static inline unsigned long arch_calc_vm_prot_bits(unsigned long prot,
> > > 						   unsigned long pkey)
> > > {
> > > 	...
> > > }
> > > #define arch_calc_vm_prot_bits arch_calc_vm_prot_bits
> > > 
> > > ... as that makes it a bit easier to match definition with use, and just
> > > definign the name makes it a bit clearer that that's probably for the
> > > benefit of some ifdeffery.
> > > 
> > > Likewise for the other functions here.
> > > 
> > > > +#define arch_vm_get_page_prot(vm_flags) arm64_vm_get_page_prot(vm_flags)
> > > > +static inline pgprot_t arm64_vm_get_page_prot(unsigned long vm_flags)
> > > > +{
> > > > +	return (vm_flags & VM_ARM64_BTI) ? __pgprot(PTE_GP) : __pgprot(0);
> > > > +}
> > > > +
> > > > +#define arch_validate_prot(prot, addr) arm64_validate_prot(prot, addr)
> > > > +static inline int arm64_validate_prot(unsigned long prot, unsigned long addr)
> > 
> > Can do, though it looks like a used sparc as a template, and that has a
> > sparc_ prefix.
> > 
> > powerpc uses the generic name, as does x86 ... in its UAPI headers.
> > Odd.
> > 
> > I can change the names here, though I'm not sure it adds a lot of value.
> > 
> > If you feel strongly I can do it.
> 
> I'd really prefer it because it minimizes surprises, and makes it much
> easier to hop around the codebase and find the thing you're looking for.

OK, I've no objection in that case.  I'll make the change.

[...]

Cheers
---Dave

WARNING: multiple messages have this Message-ID (diff)
From: Dave Martin <Dave.Martin@arm.com>
To: Mark Rutland <mark.rutland@arm.com>
Cc: "Paul Elliott" <paul.elliott@arm.com>,
	"Peter Zijlstra" <peterz@infradead.org>,
	"Catalin Marinas" <catalin.marinas@arm.com>,
	"Will Deacon" <will.deacon@arm.com>,
	"Yu-cheng Yu" <yu-cheng.yu@intel.com>,
	"Amit Kachhap" <amit.kachhap@arm.com>,
	"Vincenzo Frascino" <vincenzo.frascino@arm.com>,
	linux-arch@vger.kernel.org,
	"Eugene Syromiatnikov" <esyr@redhat.com>,
	"Szabolcs Nagy" <szabolcs.nagy@arm.com>,
	"H.J. Lu" <hjl.tools@gmail.com>,
	"Andrew Jones" <drjones@redhat.com>,
	"Kees Cook" <keescook@chromium.org>,
	"Arnd Bergmann" <arnd@arndb.de>, "Jann Horn" <jannh@google.com>,
	"Richard Henderson" <richard.henderson@linaro.org>,
	"Kristina Martšenko" <kristina.martsenko@arm.com>,
	"Mark Brown" <broonie@kernel.org>,
	"Thomas Gleixner" <tglx@linutronix.de>,
	linux-arm-kernel@lists.infradead.org,
	"Florian Weimer" <fweimer@redhat.com>,
	linux-kernel@vger.kernel.org, "Sudakshina Das" <sudi.das@arm.com>
Subject: Re: [PATCH v2 05/12] arm64: Basic Branch Target Identification support
Date: Fri, 18 Oct 2019 14:37:40 +0100	[thread overview]
Message-ID: <20191018133739.GD27757@arm.com> (raw)
In-Reply-To: <20191018111003.GC27759@lakrids.cambridge.arm.com>

On Fri, Oct 18, 2019 at 12:10:03PM +0100, Mark Rutland wrote:
> On Fri, Oct 11, 2019 at 06:20:15PM +0100, Dave Martin wrote:
> > On Fri, Oct 11, 2019 at 04:10:29PM +0100, Mark Rutland wrote:
> > > On Thu, Oct 10, 2019 at 07:44:33PM +0100, Dave Martin wrote:
> > > > +#define arch_calc_vm_prot_bits(prot, pkey) arm64_calc_vm_prot_bits(prot)
> > > > +static inline unsigned long arm64_calc_vm_prot_bits(unsigned long prot)
> > > > +{
> > > > +	if (system_supports_bti() && (prot & PROT_BTI))
> > > > +		return VM_ARM64_BTI;
> > > > +
> > > > +	return 0;
> > > > +}
> > > 
> > > Can we call this arch_calc_vm_prot_bits() directly, with all the
> > > arguments:
> > > 
> > > static inline unsigned long arch_calc_vm_prot_bits(unsigned long prot,
> > > 						   unsigned long pkey)
> > > {
> > > 	...
> > > }
> > > #define arch_calc_vm_prot_bits arch_calc_vm_prot_bits
> > > 
> > > ... as that makes it a bit easier to match definition with use, and just
> > > definign the name makes it a bit clearer that that's probably for the
> > > benefit of some ifdeffery.
> > > 
> > > Likewise for the other functions here.
> > > 
> > > > +#define arch_vm_get_page_prot(vm_flags) arm64_vm_get_page_prot(vm_flags)
> > > > +static inline pgprot_t arm64_vm_get_page_prot(unsigned long vm_flags)
> > > > +{
> > > > +	return (vm_flags & VM_ARM64_BTI) ? __pgprot(PTE_GP) : __pgprot(0);
> > > > +}
> > > > +
> > > > +#define arch_validate_prot(prot, addr) arm64_validate_prot(prot, addr)
> > > > +static inline int arm64_validate_prot(unsigned long prot, unsigned long addr)
> > 
> > Can do, though it looks like a used sparc as a template, and that has a
> > sparc_ prefix.
> > 
> > powerpc uses the generic name, as does x86 ... in its UAPI headers.
> > Odd.
> > 
> > I can change the names here, though I'm not sure it adds a lot of value.
> > 
> > If you feel strongly I can do it.
> 
> I'd really prefer it because it minimizes surprises, and makes it much
> easier to hop around the codebase and find the thing you're looking for.

OK, I've no objection in that case.  I'll make the change.

[...]

Cheers
---Dave

WARNING: multiple messages have this Message-ID (diff)
From: Dave Martin <Dave.Martin@arm.com>
To: Mark Rutland <mark.rutland@arm.com>
Cc: "Paul Elliott" <paul.elliott@arm.com>,
	"Peter Zijlstra" <peterz@infradead.org>,
	"Catalin Marinas" <catalin.marinas@arm.com>,
	"Will Deacon" <will.deacon@arm.com>,
	"Yu-cheng Yu" <yu-cheng.yu@intel.com>,
	"Amit Kachhap" <amit.kachhap@arm.com>,
	"Vincenzo Frascino" <vincenzo.frascino@arm.com>,
	linux-arch@vger.kernel.org,
	"Eugene Syromiatnikov" <esyr@redhat.com>,
	"Szabolcs Nagy" <szabolcs.nagy@arm.com>,
	"H.J. Lu" <hjl.tools@gmail.com>,
	"Andrew Jones" <drjones@redhat.com>,
	"Kees Cook" <keescook@chromium.org>,
	"Arnd Bergmann" <arnd@arndb.de>, "Jann Horn" <jannh@google.com>,
	"Richard Henderson" <richard.henderson@linaro.org>,
	"Kristina Martšenko" <kristina.martsenko@arm.com>,
	"Mark Brown" <broonie@kernel.org>,
	"Thomas Gleixner" <tglx@linutronix.de>,
	linux-arm-kernel@lists.infradead.org,
	"Florian Weimer" <fweimer@redhat.com>,
	linux-kernel@vger.kernel.org, "Sudakshina Das" <sudi.das@arm.com>
Subject: Re: [PATCH v2 05/12] arm64: Basic Branch Target Identification support
Date: Fri, 18 Oct 2019 14:37:40 +0100	[thread overview]
Message-ID: <20191018133739.GD27757@arm.com> (raw)
In-Reply-To: <20191018111003.GC27759@lakrids.cambridge.arm.com>

On Fri, Oct 18, 2019 at 12:10:03PM +0100, Mark Rutland wrote:
> On Fri, Oct 11, 2019 at 06:20:15PM +0100, Dave Martin wrote:
> > On Fri, Oct 11, 2019 at 04:10:29PM +0100, Mark Rutland wrote:
> > > On Thu, Oct 10, 2019 at 07:44:33PM +0100, Dave Martin wrote:
> > > > +#define arch_calc_vm_prot_bits(prot, pkey) arm64_calc_vm_prot_bits(prot)
> > > > +static inline unsigned long arm64_calc_vm_prot_bits(unsigned long prot)
> > > > +{
> > > > +	if (system_supports_bti() && (prot & PROT_BTI))
> > > > +		return VM_ARM64_BTI;
> > > > +
> > > > +	return 0;
> > > > +}
> > > 
> > > Can we call this arch_calc_vm_prot_bits() directly, with all the
> > > arguments:
> > > 
> > > static inline unsigned long arch_calc_vm_prot_bits(unsigned long prot,
> > > 						   unsigned long pkey)
> > > {
> > > 	...
> > > }
> > > #define arch_calc_vm_prot_bits arch_calc_vm_prot_bits
> > > 
> > > ... as that makes it a bit easier to match definition with use, and just
> > > definign the name makes it a bit clearer that that's probably for the
> > > benefit of some ifdeffery.
> > > 
> > > Likewise for the other functions here.
> > > 
> > > > +#define arch_vm_get_page_prot(vm_flags) arm64_vm_get_page_prot(vm_flags)
> > > > +static inline pgprot_t arm64_vm_get_page_prot(unsigned long vm_flags)
> > > > +{
> > > > +	return (vm_flags & VM_ARM64_BTI) ? __pgprot(PTE_GP) : __pgprot(0);
> > > > +}
> > > > +
> > > > +#define arch_validate_prot(prot, addr) arm64_validate_prot(prot, addr)
> > > > +static inline int arm64_validate_prot(unsigned long prot, unsigned long addr)
> > 
> > Can do, though it looks like a used sparc as a template, and that has a
> > sparc_ prefix.
> > 
> > powerpc uses the generic name, as does x86 ... in its UAPI headers.
> > Odd.
> > 
> > I can change the names here, though I'm not sure it adds a lot of value.
> > 
> > If you feel strongly I can do it.
> 
> I'd really prefer it because it minimizes surprises, and makes it much
> easier to hop around the codebase and find the thing you're looking for.

OK, I've no objection in that case.  I'll make the change.

[...]

Cheers
---Dave

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2019-10-18 13:38 UTC|newest]

Thread overview: 145+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-10 18:44 [PATCH v2 00/12] arm64: ARMv8.5-A: Branch Target Identification support Dave Martin
2019-10-10 18:44 ` Dave Martin
2019-10-10 18:44 ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 01/12] ELF: UAPI and Kconfig additions for ELF program properties Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 02/12] ELF: Add ELF program property parsing support Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 03/12] mm: Reserve asm-generic prot flag 0x10 for arch use Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 04/12] arm64: docs: cpu-feature-registers: Document ID_AA64PFR1_EL1 Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-11 13:19   ` Alex Bennée
2019-10-11 13:19     ` Alex Bennée
2019-10-11 13:19     ` Alex Bennée
2019-10-11 14:51     ` Dave Martin
2019-10-11 14:51       ` Dave Martin
2019-10-11 14:51       ` Dave Martin
2019-10-21 19:18       ` Mark Brown
2019-10-21 19:18         ` Mark Brown
2019-10-21 19:18         ` Mark Brown
2019-10-22 10:32         ` Will Deacon
2019-10-22 10:32           ` Will Deacon
2019-10-22 10:32           ` Will Deacon
2019-10-10 18:44 ` [PATCH v2 05/12] arm64: Basic Branch Target Identification support Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-11 15:06   ` [FIXUP 0/2] Fixups to patch 5 Dave Martin
2019-10-11 15:06     ` Dave Martin
2019-10-11 15:06     ` Dave Martin
2019-10-11 15:06     ` [FIXUP 1/2] squash! arm64: Basic Branch Target Identification support Dave Martin
2019-10-11 15:06       ` Dave Martin
2019-10-11 15:06       ` Dave Martin
2019-10-11 15:06     ` [FIXUP 2/2] " Dave Martin
2019-10-11 15:06       ` Dave Martin
2019-10-11 15:06       ` Dave Martin
2019-10-11 15:10   ` [PATCH v2 05/12] " Mark Rutland
2019-10-11 15:10     ` Mark Rutland
2019-10-11 15:10     ` Mark Rutland
2019-10-11 15:25     ` Richard Henderson
2019-10-11 15:25       ` Richard Henderson
2019-10-11 15:25       ` Richard Henderson
2019-10-11 15:32       ` Dave Martin
2019-10-11 15:32         ` Dave Martin
2019-10-11 15:32         ` Dave Martin
2019-10-11 15:40         ` Mark Rutland
2019-10-11 15:40           ` Mark Rutland
2019-10-11 15:40           ` Mark Rutland
2019-10-11 15:44           ` Dave Martin
2019-10-11 15:44             ` Dave Martin
2019-10-11 15:44             ` Dave Martin
2019-10-11 16:01             ` Dave Martin
2019-10-11 16:01               ` Dave Martin
2019-10-11 16:01               ` Dave Martin
2019-10-11 16:42               ` Dave Martin
2019-10-11 16:42                 ` Dave Martin
2019-10-11 16:42                 ` Dave Martin
2019-10-18 11:05                 ` Mark Rutland
2019-10-18 11:05                   ` Mark Rutland
2019-10-18 11:05                   ` Mark Rutland
2019-10-18 13:36                   ` Dave Martin
2019-10-18 13:36                     ` Dave Martin
2019-10-18 13:36                     ` Dave Martin
2019-10-11 17:20     ` Dave Martin
2019-10-11 17:20       ` Dave Martin
2019-10-11 17:20       ` Dave Martin
2019-10-18 11:10       ` Mark Rutland
2019-10-18 11:10         ` Mark Rutland
2019-10-18 11:10         ` Mark Rutland
2019-10-18 13:37         ` Dave Martin [this message]
2019-10-18 13:37           ` Dave Martin
2019-10-18 13:37           ` Dave Martin
2019-10-18 11:16       ` Mark Rutland
2019-10-18 11:16         ` Mark Rutland
2019-10-18 11:16         ` Mark Rutland
2019-10-18 11:16         ` Mark Rutland
2019-10-18 13:40         ` Dave Martin
2019-10-18 13:40           ` Dave Martin
2019-10-18 13:40           ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 06/12] elf: Allow arch to tweak initial mmap prot flags Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 07/12] arm64: elf: Enable BTI at exec based on ELF program properties Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 08/12] arm64: BTI: Decode BYTPE bits when printing PSTATE Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-11 15:31   ` Richard Henderson
2019-10-11 15:31     ` Richard Henderson
2019-10-11 15:31     ` Richard Henderson
2019-10-11 15:33     ` Dave Martin
2019-10-11 15:33       ` Dave Martin
2019-10-11 15:33       ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 09/12] arm64: traps: Fix inconsistent faulting instruction skipping Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-11 15:24   ` Mark Rutland
2019-10-11 15:24     ` Mark Rutland
2019-10-11 15:24     ` Mark Rutland
2019-10-15 15:21     ` Dave Martin
2019-10-15 15:21       ` Dave Martin
2019-10-15 15:21       ` Dave Martin
2019-10-15 16:42       ` Mark Rutland
2019-10-15 16:42         ` Mark Rutland
2019-10-15 16:42         ` Mark Rutland
2019-10-15 16:49         ` Dave Martin
2019-10-15 16:49           ` Dave Martin
2019-10-15 16:49           ` Dave Martin
2019-10-18 16:40           ` Dave Martin
2019-10-18 16:40             ` Dave Martin
2019-10-18 16:40             ` Dave Martin
2019-10-22 11:09             ` Robin Murphy
2019-10-22 11:09               ` Robin Murphy
2019-10-22 11:09               ` Robin Murphy
2019-10-10 18:44 ` [PATCH v2 10/12] arm64: traps: Shuffle code to eliminate forward declarations Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 11/12] arm64: BTI: Reset BTYPE when skipping emulated instructions Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-11 14:21   ` Mark Rutland
2019-10-11 14:21     ` Mark Rutland
2019-10-11 14:21     ` Mark Rutland
2019-10-11 14:47     ` Dave Martin
2019-10-11 14:47       ` Dave Martin
2019-10-11 14:47       ` Dave Martin
2019-10-18 11:04       ` Mark Rutland
2019-10-18 11:04         ` Mark Rutland
2019-10-18 11:04         ` Mark Rutland
2019-10-18 14:49         ` Dave Martin
2019-10-18 14:49           ` Dave Martin
2019-10-18 14:49           ` Dave Martin
2019-10-10 18:44 ` [PATCH v2 12/12] KVM: " Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-10 18:44   ` Dave Martin
2019-10-11 14:24   ` Mark Rutland
2019-10-11 14:24     ` Mark Rutland
2019-10-11 14:24     ` Mark Rutland
2019-10-11 14:44     ` Dave Martin
2019-10-11 14:44       ` Dave Martin
2019-10-11 14:44       ` Dave Martin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191018133739.GD27757@arm.com \
    --to=dave.martin@arm.com \
    --cc=amit.kachhap@arm.com \
    --cc=arnd@arndb.de \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=drjones@redhat.com \
    --cc=esyr@redhat.com \
    --cc=fweimer@redhat.com \
    --cc=hjl.tools@gmail.com \
    --cc=jannh@google.com \
    --cc=keescook@chromium.org \
    --cc=kristina.martsenko@arm.com \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=paul.elliott@arm.com \
    --cc=peterz@infradead.org \
    --cc=richard.henderson@linaro.org \
    --cc=sudi.das@arm.com \
    --cc=szabolcs.nagy@arm.com \
    --cc=tglx@linutronix.de \
    --cc=vincenzo.frascino@arm.com \
    --cc=will.deacon@arm.com \
    --cc=yu-cheng.yu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.