All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kefeng Wang <wangkefeng.wang@huawei.com>
To: <catalin.marinas@arm.com>, <will@kernel.org>,
	<akpm@linux-foundation.org>,
	<linux-arm-kernel@lists.infradead.org>,
	<linux-kernel@vger.kernel.org>
Cc: <linux-mm@kvack.org>, <hch@infradead.org>, <arnd@arndb.de>,
	<anshuman.khandual@arm.com>,
	Kefeng Wang <wangkefeng.wang@huawei.com>
Subject: [PATCH v3 0/6] arm64: Cleanup ioremap() and support ioremap_prot()
Date: Thu, 19 May 2022 16:25:46 +0800	[thread overview]
Message-ID: <20220519082552.117736-1-wangkefeng.wang@huawei.com> (raw)

1. Enhance generic ioremap to make it more useful.
2. Let's arm64 use GENERIC_IOREMAP to cleanup code.
3. Support HAVE_IOREMAP_PROT on arm64, which enable generic_access_phys(),
   it is useful when debug(eg, gdb) via access_process_vm device memory
   infrastructure.

v3:
- add cleanup patch to kill ARM's unused arch_iounmap(the naming will be
  used in GENERIC_IOREMAP) and add comments for arch_ioremap/arch_iounmap
  hooks, per Anshuman Khandual
- collect ack/review 

v2:
- s/addr/phys_addr in ioremap_prot, suggested by Andrew Morton 
- rename arch_ioremap/iounmap_check to arch_ioremap/iounmad
  and change return value, per Christoph Hellwig and Andrew Morton
- and use 'ifndef arch_ioremap' instead of weak function, per Arnd Bergmann
- collect ack/review

Kefeng Wang (6):
  ARM: mm: kill unused runtime hook arch_iounmap()
  mm: ioremap: Use more sensibly name in ioremap_prot()
  mm: ioremap: Setup phys_addr of struct vm_struct
  mm: ioremap: Add arch_ioremap/iounmap()
  arm64: mm: Convert to GENERIC_IOREMAP
  arm64: Add HAVE_IOREMAP_PROT support

 .../features/vm/ioremap_prot/arch-support.txt |  2 +-
 arch/arm/include/asm/io.h                     |  4 +-
 arch/arm/mm/ioremap.c                         |  9 +-
 arch/arm/mm/nommu.c                           |  9 +-
 arch/arm64/Kconfig                            |  2 +
 arch/arm64/include/asm/io.h                   | 20 +++--
 arch/arm64/include/asm/pgtable.h              | 10 +++
 arch/arm64/kernel/acpi.c                      |  2 +-
 arch/arm64/mm/hugetlbpage.c                   | 10 ---
 arch/arm64/mm/ioremap.c                       | 85 +++----------------
 include/asm-generic/io.h                      | 26 +++++-
 mm/ioremap.c                                  | 30 +++++--
 12 files changed, 88 insertions(+), 121 deletions(-)

-- 
2.35.3


WARNING: multiple messages have this Message-ID (diff)
From: Kefeng Wang <wangkefeng.wang@huawei.com>
To: <catalin.marinas@arm.com>, <will@kernel.org>,
	<akpm@linux-foundation.org>,
	 <linux-arm-kernel@lists.infradead.org>,
	<linux-kernel@vger.kernel.org>
Cc: <linux-mm@kvack.org>, <hch@infradead.org>, <arnd@arndb.de>,
	<anshuman.khandual@arm.com>,
	Kefeng Wang <wangkefeng.wang@huawei.com>
Subject: [PATCH v3 0/6] arm64: Cleanup ioremap() and support ioremap_prot()
Date: Thu, 19 May 2022 16:25:46 +0800	[thread overview]
Message-ID: <20220519082552.117736-1-wangkefeng.wang@huawei.com> (raw)

1. Enhance generic ioremap to make it more useful.
2. Let's arm64 use GENERIC_IOREMAP to cleanup code.
3. Support HAVE_IOREMAP_PROT on arm64, which enable generic_access_phys(),
   it is useful when debug(eg, gdb) via access_process_vm device memory
   infrastructure.

v3:
- add cleanup patch to kill ARM's unused arch_iounmap(the naming will be
  used in GENERIC_IOREMAP) and add comments for arch_ioremap/arch_iounmap
  hooks, per Anshuman Khandual
- collect ack/review 

v2:
- s/addr/phys_addr in ioremap_prot, suggested by Andrew Morton 
- rename arch_ioremap/iounmap_check to arch_ioremap/iounmad
  and change return value, per Christoph Hellwig and Andrew Morton
- and use 'ifndef arch_ioremap' instead of weak function, per Arnd Bergmann
- collect ack/review

Kefeng Wang (6):
  ARM: mm: kill unused runtime hook arch_iounmap()
  mm: ioremap: Use more sensibly name in ioremap_prot()
  mm: ioremap: Setup phys_addr of struct vm_struct
  mm: ioremap: Add arch_ioremap/iounmap()
  arm64: mm: Convert to GENERIC_IOREMAP
  arm64: Add HAVE_IOREMAP_PROT support

 .../features/vm/ioremap_prot/arch-support.txt |  2 +-
 arch/arm/include/asm/io.h                     |  4 +-
 arch/arm/mm/ioremap.c                         |  9 +-
 arch/arm/mm/nommu.c                           |  9 +-
 arch/arm64/Kconfig                            |  2 +
 arch/arm64/include/asm/io.h                   | 20 +++--
 arch/arm64/include/asm/pgtable.h              | 10 +++
 arch/arm64/kernel/acpi.c                      |  2 +-
 arch/arm64/mm/hugetlbpage.c                   | 10 ---
 arch/arm64/mm/ioremap.c                       | 85 +++----------------
 include/asm-generic/io.h                      | 26 +++++-
 mm/ioremap.c                                  | 30 +++++--
 12 files changed, 88 insertions(+), 121 deletions(-)

-- 
2.35.3


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

             reply	other threads:[~2022-05-19  8:18 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-19  8:25 Kefeng Wang [this message]
2022-05-19  8:25 ` [PATCH v3 0/6] arm64: Cleanup ioremap() and support ioremap_prot() Kefeng Wang
2022-05-19  8:25 ` [PATCH v3 1/6] ARM: mm: kill unused runtime hook arch_iounmap() Kefeng Wang
2022-05-19  8:25   ` Kefeng Wang
2022-05-19  8:51   ` Anshuman Khandual
2022-05-19  8:51     ` Anshuman Khandual
2022-05-20 15:28   ` Catalin Marinas
2022-05-20 15:28     ` Catalin Marinas
2022-05-24  2:03     ` Kefeng Wang
2022-05-24  2:03       ` Kefeng Wang
2022-05-21 20:30   ` Arnd Bergmann
2022-05-21 20:30     ` Arnd Bergmann
2022-05-19  8:25 ` [PATCH v3 2/6] mm: ioremap: Use more sensibly name in ioremap_prot() Kefeng Wang
2022-05-19  8:25   ` Kefeng Wang
2022-05-19  8:25 ` [PATCH v3 3/6] mm: ioremap: Setup phys_addr of struct vm_struct Kefeng Wang
2022-05-19  8:25   ` Kefeng Wang
2022-05-19  8:25 ` [PATCH v3 4/6] mm: ioremap: Add arch_ioremap/iounmap() Kefeng Wang
2022-05-19  8:25   ` Kefeng Wang
2022-05-19 18:52   ` Andrew Morton
2022-05-19 18:52     ` Andrew Morton
2022-05-20  1:22     ` Kefeng Wang
2022-05-20  1:22       ` Kefeng Wang
2022-05-23  3:57     ` Anshuman Khandual
2022-05-23  3:57       ` Anshuman Khandual
2022-05-23 22:17   ` kernel test robot
2022-05-23 22:17     ` kernel test robot
2022-05-24  9:48     ` Kefeng Wang
2022-05-24  9:48       ` Kefeng Wang
2022-05-24  9:48       ` Kefeng Wang
2022-05-24 12:35       ` Arnd Bergmann
2022-05-24 12:35         ` Arnd Bergmann
2022-05-24 12:35         ` Arnd Bergmann
2022-05-24 14:31         ` Kefeng Wang
2022-05-24 14:31           ` Kefeng Wang
2022-05-24 14:31           ` Kefeng Wang
2022-05-24 12:37   ` Arnd Bergmann
2022-05-24 12:37     ` Arnd Bergmann
2022-05-24 14:32     ` Kefeng Wang
2022-05-24 14:32       ` Kefeng Wang
2022-05-24 14:47       ` Arnd Bergmann
2022-05-24 14:47         ` Arnd Bergmann
2022-05-24 14:53         ` Kefeng Wang
2022-05-24 14:53           ` Kefeng Wang
2022-05-31  6:13           ` Christoph Hellwig
2022-05-31  6:13             ` Christoph Hellwig
2022-06-01  1:05             ` Kefeng Wang
2022-06-01  1:05               ` Kefeng Wang
2022-05-19  8:25 ` [PATCH v3 5/6] arm64: mm: Convert to GENERIC_IOREMAP Kefeng Wang
2022-05-19  8:25   ` Kefeng Wang
2022-05-19  8:25 ` [PATCH v3 6/6] arm64: Add HAVE_IOREMAP_PROT support Kefeng Wang
2022-05-19  8:25   ` Kefeng Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220519082552.117736-1-wangkefeng.wang@huawei.com \
    --to=wangkefeng.wang@huawei.com \
    --cc=akpm@linux-foundation.org \
    --cc=anshuman.khandual@arm.com \
    --cc=arnd@arndb.de \
    --cc=catalin.marinas@arm.com \
    --cc=hch@infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.