All of lore.kernel.org
 help / color / mirror / Atom feed
From: Vladimir Zapolskiy <vz@mleia.com>
To: Arnd Bergmann <arnd@arndb.de>
Cc: linux-arm-kernel@lists.infradead.org,
	Rob Herring <robh+dt@kernel.org>,
	Stephen Boyd <sboyd@codeaurora.org>,
	Michael Turquette <mturquette@baylibre.com>,
	Roland Stigge <stigge@antcom.de>,
	devicetree@vger.kernel.org, Russell King <linux@arm.linux.org.uk>,
	linux-clk@vger.kernel.org
Subject: Re: [PATCH 09/11] clk: lpc32xx: add common clock framework driver
Date: Sun, 29 Nov 2015 15:00:12 +0200	[thread overview]
Message-ID: <565AF6DC.40100@mleia.com> (raw)
In-Reply-To: <4933690.HhBPeGYMb3@wuerfel>

Hi Arnd,

On 20.11.2015 22:20, Arnd Bergmann wrote:
> On Friday 20 November 2015 20:07:46 Vladimir Zapolskiy wrote:
>> On 20.11.2015 16:04, Arnd Bergmann wrote:
>>> On Friday 20 November 2015 03:05:09 Vladimir Zapolskiy wrote:
>>>> +
>>>> +struct clk_proto_t {
>>>> +       const char *name;
>>>> +       const u8 parents[LPC32XX_CLK_PARENTS_MAX];
>>>> +       u8 num_parents;
>>>> +       unsigned long flags;
>>>> +};
>>>> +
>>>> +#define CLK_PREFIX(LITERAL)            LPC32XX_CLK_ ## LITERAL
>>>> +#define NUMARGS(...)   (sizeof((int[]){__VA_ARGS__})/sizeof(int))
>>>> +
>>>> +#define LPC32XX_CLK_DEFINE(_idx, _name, _flags, ...)           \
>>>> +       [CLK_PREFIX(_idx)] = {                                  \
>>>> +               .name = #_name,                                 \
>>>> +               .flags = _flags,                                \
>>>> +               .parents = { __VA_ARGS__ },                     \
>>>> +               .num_parents = NUMARGS(__VA_ARGS__),            \
>>>> +        }
>>>> +
>>>
>>> Try to not outsmart yourself with the macros. It's better to avoid
>>> string concatenation so it's possible to grep for uses of some
>>> constant.
>>>
>>> I would probably not use a macro at all here and just open-code the
>>> entire table. If you ensure that '0' is not a valid parent, then
>>> you can leave out the .num_parents field and just look for the
>>> zero-termination.
>>
>> Macros are here for simplicity, code size reduction and to avoid some
>> stupid mistakes like different number of .parents and .num_parents.
>>
>> I believe macro unwrapping in this code will add another 1000 LoC and
>> will result in quite unreadable and less maintainable code.
> 
> I mean specifically the macro above:
> 
> static const struct clk_proto_t clk_proto[LPC32XX_CLK_CCF_MAX] __initconst = {
> +       LPC32XX_CLK_DEFINE(XTAL, xtal, 0x0),
> +       LPC32XX_CLK_DEFINE(XTAL_32K, xtal_32k, 0x0),
> +
> +       LPC32XX_CLK_DEFINE(RTC, rtc, 0x0, LPC32XX_CLK_XTAL_32K),
> +       LPC32XX_CLK_DEFINE(OSC, osc, CLK_IGNORE_UNUSED, LPC32XX_CLK_XTAL),
> +       LPC32XX_CLK_DEFINE(SYS, sys, CLK_IGNORE_UNUSED,
> +               LPC32XX_CLK_OSC, LPC32XX_CLK_PLL397X),
> +       LPC32XX_CLK_DEFINE(PLL397X, pll_397x, CLK_IGNORE_UNUSED,
> +               LPC32XX_CLK_RTC),
> 
> can become
> 
> static const struct clk_proto_t clk_proto[] __initconst = {
> 	[LPC32XX_CLK_XTAL]	= { "xtal" },
> 	[LPC32XX_CLK_XTAL_32K]	= { "xtal_32k" },
> 	[LPC32XX_CLK_RTC]	= { "rtc",
> 			.parents = { LPC32XX_CLK_XTAL_32K, 0 } },

this one and all below are two lines instead of one.

Also .num_parents is not set at compilation stage, this will require
running over parents arrays for every registered clock on boot, it might
noticeably slow down the booting process on a 200MHz core.

The clocks in the beginning have not so many parents, at the opposite
extreme the situation is worse:

	LPC32XX_CLK_DEFINE(TEST1, test1, 0x0,
		LPC32XX_CLK_PERIPH, LPC32XX_CLK_RTC, LPC32XX_CLK_OSC),
	LPC32XX_CLK_DEFINE(TEST2, test2, 0x0,
		LPC32XX_CLK_HCLK, LPC32XX_CLK_PERIPH, LPC32XX_CLK_USB,
		LPC32XX_CLK_OSC, LPC32XX_CLK_PLL397X),

vs.

	[LPC32XX_CLK_TEST1]	= { "test1",
		.parents = { LPC32XX_CLK_PERIPH, LPC32XX_CLK_RTC,
			     LPC32XX_CLK_OSC, 0 } },
	[LPC32XX_CLK_TEST1]	= { "test2",
		.parents = { LPC32XX_CLK_HCLK, LPC32XX_CLK_PERIPH,
			     LPC32XX_CLK_USB, LPC32XX_CLK_OSC,
			     LPC32XX_CLK_PLL397X, 0 } },


> 	[LPC32XX_CLK_OSC]	= { "osc", CLK_IGNORE_UNUSED,
> 			.parents = { LPC32XX_CLK_XTAL, 0 } },
> 	[LPC32XX_CLK_SYS]	= { "sys", CLK_IGNORE_UNUSED,
> 			.parents = { LPC32XX_CLK_OSC, LPC32XX_CLK_PLL397X, 0) },
> 	[LPC32XX_CLK_PLL397X]	= { "pll_397x", CLK_IGNORE_UNUSED,
> 			.parents = { LPC32XX_CLK_RTC, 0 },
> 
> Not harder to read at all, not really longer, but easier to grep for.
> 

If it is not principal, I would prefer to keep the original notation,
but convert stringified values to plane strings, all in all the table is
fixed and it is not supposed to be updated anymore.

But in general I got your idea, I can implement it in v2, if you ask.

--
With best wishes,
Vladimir

WARNING: multiple messages have this Message-ID (diff)
From: vz@mleia.com (Vladimir Zapolskiy)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 09/11] clk: lpc32xx: add common clock framework driver
Date: Sun, 29 Nov 2015 15:00:12 +0200	[thread overview]
Message-ID: <565AF6DC.40100@mleia.com> (raw)
In-Reply-To: <4933690.HhBPeGYMb3@wuerfel>

Hi Arnd,

On 20.11.2015 22:20, Arnd Bergmann wrote:
> On Friday 20 November 2015 20:07:46 Vladimir Zapolskiy wrote:
>> On 20.11.2015 16:04, Arnd Bergmann wrote:
>>> On Friday 20 November 2015 03:05:09 Vladimir Zapolskiy wrote:
>>>> +
>>>> +struct clk_proto_t {
>>>> +       const char *name;
>>>> +       const u8 parents[LPC32XX_CLK_PARENTS_MAX];
>>>> +       u8 num_parents;
>>>> +       unsigned long flags;
>>>> +};
>>>> +
>>>> +#define CLK_PREFIX(LITERAL)            LPC32XX_CLK_ ## LITERAL
>>>> +#define NUMARGS(...)   (sizeof((int[]){__VA_ARGS__})/sizeof(int))
>>>> +
>>>> +#define LPC32XX_CLK_DEFINE(_idx, _name, _flags, ...)           \
>>>> +       [CLK_PREFIX(_idx)] = {                                  \
>>>> +               .name = #_name,                                 \
>>>> +               .flags = _flags,                                \
>>>> +               .parents = { __VA_ARGS__ },                     \
>>>> +               .num_parents = NUMARGS(__VA_ARGS__),            \
>>>> +        }
>>>> +
>>>
>>> Try to not outsmart yourself with the macros. It's better to avoid
>>> string concatenation so it's possible to grep for uses of some
>>> constant.
>>>
>>> I would probably not use a macro at all here and just open-code the
>>> entire table. If you ensure that '0' is not a valid parent, then
>>> you can leave out the .num_parents field and just look for the
>>> zero-termination.
>>
>> Macros are here for simplicity, code size reduction and to avoid some
>> stupid mistakes like different number of .parents and .num_parents.
>>
>> I believe macro unwrapping in this code will add another 1000 LoC and
>> will result in quite unreadable and less maintainable code.
> 
> I mean specifically the macro above:
> 
> static const struct clk_proto_t clk_proto[LPC32XX_CLK_CCF_MAX] __initconst = {
> +       LPC32XX_CLK_DEFINE(XTAL, xtal, 0x0),
> +       LPC32XX_CLK_DEFINE(XTAL_32K, xtal_32k, 0x0),
> +
> +       LPC32XX_CLK_DEFINE(RTC, rtc, 0x0, LPC32XX_CLK_XTAL_32K),
> +       LPC32XX_CLK_DEFINE(OSC, osc, CLK_IGNORE_UNUSED, LPC32XX_CLK_XTAL),
> +       LPC32XX_CLK_DEFINE(SYS, sys, CLK_IGNORE_UNUSED,
> +               LPC32XX_CLK_OSC, LPC32XX_CLK_PLL397X),
> +       LPC32XX_CLK_DEFINE(PLL397X, pll_397x, CLK_IGNORE_UNUSED,
> +               LPC32XX_CLK_RTC),
> 
> can become
> 
> static const struct clk_proto_t clk_proto[] __initconst = {
> 	[LPC32XX_CLK_XTAL]	= { "xtal" },
> 	[LPC32XX_CLK_XTAL_32K]	= { "xtal_32k" },
> 	[LPC32XX_CLK_RTC]	= { "rtc",
> 			.parents = { LPC32XX_CLK_XTAL_32K, 0 } },

this one and all below are two lines instead of one.

Also .num_parents is not set at compilation stage, this will require
running over parents arrays for every registered clock on boot, it might
noticeably slow down the booting process on a 200MHz core.

The clocks in the beginning have not so many parents, at the opposite
extreme the situation is worse:

	LPC32XX_CLK_DEFINE(TEST1, test1, 0x0,
		LPC32XX_CLK_PERIPH, LPC32XX_CLK_RTC, LPC32XX_CLK_OSC),
	LPC32XX_CLK_DEFINE(TEST2, test2, 0x0,
		LPC32XX_CLK_HCLK, LPC32XX_CLK_PERIPH, LPC32XX_CLK_USB,
		LPC32XX_CLK_OSC, LPC32XX_CLK_PLL397X),

vs.

	[LPC32XX_CLK_TEST1]	= { "test1",
		.parents = { LPC32XX_CLK_PERIPH, LPC32XX_CLK_RTC,
			     LPC32XX_CLK_OSC, 0 } },
	[LPC32XX_CLK_TEST1]	= { "test2",
		.parents = { LPC32XX_CLK_HCLK, LPC32XX_CLK_PERIPH,
			     LPC32XX_CLK_USB, LPC32XX_CLK_OSC,
			     LPC32XX_CLK_PLL397X, 0 } },


> 	[LPC32XX_CLK_OSC]	= { "osc", CLK_IGNORE_UNUSED,
> 			.parents = { LPC32XX_CLK_XTAL, 0 } },
> 	[LPC32XX_CLK_SYS]	= { "sys", CLK_IGNORE_UNUSED,
> 			.parents = { LPC32XX_CLK_OSC, LPC32XX_CLK_PLL397X, 0) },
> 	[LPC32XX_CLK_PLL397X]	= { "pll_397x", CLK_IGNORE_UNUSED,
> 			.parents = { LPC32XX_CLK_RTC, 0 },
> 
> Not harder to read at all, not really longer, but easier to grep for.
> 

If it is not principal, I would prefer to keep the original notation,
but convert stringified values to plane strings, all in all the table is
fixed and it is not supposed to be updated anymore.

But in general I got your idea, I can implement it in v2, if you ask.

--
With best wishes,
Vladimir

  reply	other threads:[~2015-11-29 13:00 UTC|newest]

Thread overview: 67+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-20  1:05 [PATCH 00/11] clk: lpc32xx: add clock support for NXP LPC32xx Vladimir Zapolskiy
2015-11-20  1:05 ` Vladimir Zapolskiy
2015-11-20  1:05 ` Vladimir Zapolskiy
2015-11-20  1:05 ` [PATCH 02/11] dt-bindings: clock: add description of LPC32xx USB clock controller Vladimir Zapolskiy
2015-11-20  1:05   ` Vladimir Zapolskiy
2015-11-20 16:41   ` Rob Herring
2015-11-20 16:41     ` Rob Herring
2015-11-20 18:14     ` Vladimir Zapolskiy
2015-11-20 18:14       ` Vladimir Zapolskiy
2015-11-20  1:05 ` [PATCH 03/11] dt-bindings: clock: add NXP LPC32xx clock list for consumers Vladimir Zapolskiy
2015-11-20  1:05   ` Vladimir Zapolskiy
2015-11-20 13:56   ` Arnd Bergmann
2015-11-20 13:56     ` Arnd Bergmann
2015-11-20 13:56     ` Arnd Bergmann
2015-11-20 17:58     ` Vladimir Zapolskiy
2015-11-20 17:58       ` Vladimir Zapolskiy
2015-11-20 21:07       ` Arnd Bergmann
2015-11-20 21:07         ` Arnd Bergmann
2015-11-21 18:53         ` Vladimir Zapolskiy
2015-11-21 18:53           ` Vladimir Zapolskiy
2015-11-20  1:05 ` [PATCH 04/11] arm: dts: lpc32xx: add device nodes for external oscillators Vladimir Zapolskiy
2015-11-20  1:05   ` Vladimir Zapolskiy
2015-11-20  1:05 ` [PATCH 05/11] arm: dts: lpc32xx: add clock controller device node Vladimir Zapolskiy
2015-11-20  1:05   ` Vladimir Zapolskiy
     [not found] ` <1447981511-29653-1-git-send-email-vz-ChpfBGZJDbMAvxtiuMwx3w@public.gmane.org>
2015-11-20  1:05   ` [PATCH 01/11] dt-bindings: clock: add description of LPC32xx clock controller Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20 13:58     ` Arnd Bergmann
2015-11-20 13:58       ` Arnd Bergmann
2015-11-20 18:01       ` Vladimir Zapolskiy
2015-11-20 18:01         ` Vladimir Zapolskiy
2015-11-20 18:01         ` Vladimir Zapolskiy
2015-11-20 20:03         ` Arnd Bergmann
2015-11-20 20:03           ` Arnd Bergmann
2015-11-20  1:05   ` [PATCH 06/11] arm: dts: lpc32xx: add clock properties to device nodes Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05   ` [PATCH 07/11] arm: dts: lpc32xx: add USB clock controller Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05   ` [PATCH 08/11] clk: lpc18xx: add NXP specific common clock framework selection Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-22 20:38     ` Joachim Eastwood
2015-11-22 20:38       ` Joachim Eastwood
2015-11-22 20:38       ` Joachim Eastwood
2015-11-20  1:05   ` [PATCH 11/11] arm: dts: lpc32xx: remove clock frequency property from UART device nodes Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05     ` Vladimir Zapolskiy
2015-11-20  1:05 ` [PATCH 09/11] clk: lpc32xx: add common clock framework driver Vladimir Zapolskiy
2015-11-20  1:05   ` Vladimir Zapolskiy
2015-11-20 14:04   ` Arnd Bergmann
2015-11-20 14:04     ` Arnd Bergmann
2015-11-20 18:07     ` Vladimir Zapolskiy
2015-11-20 18:07       ` Vladimir Zapolskiy
2015-11-20 18:07       ` Vladimir Zapolskiy
2015-11-20 20:20       ` Arnd Bergmann
2015-11-20 20:20         ` Arnd Bergmann
2015-11-29 13:00         ` Vladimir Zapolskiy [this message]
2015-11-29 13:00           ` Vladimir Zapolskiy
2015-11-20  1:05 ` [PATCH 10/11] arm: lpc32xx: switch to common clock framework Vladimir Zapolskiy
2015-11-20  1:05   ` Vladimir Zapolskiy
2016-02-09 21:01 ` [PATCH 00/11] clk: lpc32xx: add clock support for NXP LPC32xx Sylvain Lemieux
     [not found]   ` <loom.20160209T215103-78-eS7Uydv5nfjZ+VzJOa5vwg@public.gmane.org>
2016-02-10  0:19     ` Vladimir Zapolskiy
2016-02-10  0:19       ` Vladimir Zapolskiy
     [not found]       ` <56BA81F7.4080006-ChpfBGZJDbMAvxtiuMwx3w@public.gmane.org>
2016-02-10 14:25         ` Sylvain Lemieux
2016-02-10 14:25           ` Sylvain Lemieux

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=565AF6DC.40100@mleia.com \
    --to=vz@mleia.com \
    --cc=arnd@arndb.de \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-clk@vger.kernel.org \
    --cc=linux@arm.linux.org.uk \
    --cc=mturquette@baylibre.com \
    --cc=robh+dt@kernel.org \
    --cc=sboyd@codeaurora.org \
    --cc=stigge@antcom.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.