All of lore.kernel.org
 help / color / mirror / Atom feed
From: Laurent Dufour <ldufour@linux.ibm.com>
To: Oscar Salvador <osalvador@suse.de>, David Hildenbrand <david@redhat.com>
Cc: akpm@linux-foundation.org, mhocko@kernel.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-mm@kvack.org, "Rafael J . Wysocki" <rafael@kernel.org>,
	nathanl@linux.ibm.com, cheloha@linux.ibm.com,
	Tony Luck <tony.luck@intel.com>,
	Fenghua Yu <fenghua.yu@intel.com>,
	linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org,
	stable@vger.kernel.org, Michal Hocko <mhocko@suse.com>
Subject: Re: [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations
Date: Mon, 14 Sep 2020 10:39:49 +0200	[thread overview]
Message-ID: <678b596a-4d40-be88-daf0-c2edb16dd295@linux.ibm.com> (raw)
In-Reply-To: <20200914081921.GA15113@linux>

Le 14/09/2020 à 10:19, Oscar Salvador a écrit :
> On Mon, Sep 14, 2020 at 09:57:46AM +0200, David Hildenbrand wrote:
>>>   /* register memory section under specified node if it spans that node */
>>> +struct rmsun_args {
>>> +	int nid;
>>> +	enum memplug_context context;
>>> +};
> 
> Uhmf, that is a not so descriptive name.

I do agree, but didn't have a better idea.
Anyway this will disappear since the choosen direction is to have 2 callbacks.

> 
>> Instead of handling this in register_mem_sect_under_node(), I
>> think it would be better two have two separate
>> register_mem_sect_under_node() implementations.
>>
>> static int register_mem_sect_under_node_hotplug(struct memory_block *mem_blk,
>> 						void *arg)
>> {
>> 	const int nid = *(int *)arg;
>> 	int ret;
>>
>> 	/* Hotplugged memory has no holes and belongs to a single node. */
>> 	mem_blk->nid = nid;
>> 	ret = sysfs_create_link_nowarn(&node_devices[nid]->dev.kobj,
>> 				       &mem_blk->dev.kobj,
>> 				       kobject_name(&mem_blk->dev.kobj));
>> 	if (ret)
>> 		returnr et;
>> 	return sysfs_create_link_nowarn(&mem_blk->dev.kobj,
>> 					&node_devices[nid]->dev.kobj,
>> 					kobject_name(&node_devices[nid]->dev.kobj));
>>
>> }
>>
>> Cleaner, right? :) No unnecessary checks.
> 
> I tend to agree here, I like more a simplistic version for hotplug.
> 
>> One could argue if link_mem_section_hotplug() would be better than passing around the context.
> 
> I am not sure if I would duplicate the code there.
> We could just pass the pointer of the function we want to call to
> link_mem_sections? either register_mem_sect_under_node_hotplug or
> register_mem_sect_under_node_early?
> Would not that be clean and clear enough?

That would expose the register_mem_sect_under_node*() prototype to the caller.

I'm wondering if that would be cleaner than passing a MEMPLUG_* constant value 
to link_mem_sections() and let it choose the right callback.

WARNING: multiple messages have this Message-ID (diff)
From: Laurent Dufour <ldufour@linux.ibm.com>
To: Oscar Salvador <osalvador@suse.de>, David Hildenbrand <david@redhat.com>
Cc: akpm@linux-foundation.org, mhocko@kernel.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-mm@kvack.org, "Rafael J . Wysocki" <rafael@kernel.org>,
	nathanl@linux.ibm.com, cheloha@linux.ibm.com,
	Tony Luck <tony.luck@intel.com>,
	Fenghua Yu <fenghua.yu@intel.com>,
	linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org,
	stable@vger.kernel.org, Michal Hocko <mhocko@suse.com>
Subject: Re: [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations
Date: Mon, 14 Sep 2020 08:39:49 +0000	[thread overview]
Message-ID: <678b596a-4d40-be88-daf0-c2edb16dd295@linux.ibm.com> (raw)
In-Reply-To: <20200914081921.GA15113@linux>

Le 14/09/2020 à 10:19, Oscar Salvador a écrit :
> On Mon, Sep 14, 2020 at 09:57:46AM +0200, David Hildenbrand wrote:
>>>   /* register memory section under specified node if it spans that node */
>>> +struct rmsun_args {
>>> +	int nid;
>>> +	enum memplug_context context;
>>> +};
> 
> Uhmf, that is a not so descriptive name.

I do agree, but didn't have a better idea.
Anyway this will disappear since the choosen direction is to have 2 callbacks.

> 
>> Instead of handling this in register_mem_sect_under_node(), I
>> think it would be better two have two separate
>> register_mem_sect_under_node() implementations.
>>
>> static int register_mem_sect_under_node_hotplug(struct memory_block *mem_blk,
>> 						void *arg)
>> {
>> 	const int nid = *(int *)arg;
>> 	int ret;
>>
>> 	/* Hotplugged memory has no holes and belongs to a single node. */
>> 	mem_blk->nid = nid;
>> 	ret = sysfs_create_link_nowarn(&node_devices[nid]->dev.kobj,
>> 				       &mem_blk->dev.kobj,
>> 				       kobject_name(&mem_blk->dev.kobj));
>> 	if (ret)
>> 		returnr et;
>> 	return sysfs_create_link_nowarn(&mem_blk->dev.kobj,
>> 					&node_devices[nid]->dev.kobj,
>> 					kobject_name(&node_devices[nid]->dev.kobj));
>>
>> }
>>
>> Cleaner, right? :) No unnecessary checks.
> 
> I tend to agree here, I like more a simplistic version for hotplug.
> 
>> One could argue if link_mem_section_hotplug() would be better than passing around the context.
> 
> I am not sure if I would duplicate the code there.
> We could just pass the pointer of the function we want to call to
> link_mem_sections? either register_mem_sect_under_node_hotplug or
> register_mem_sect_under_node_early?
> Would not that be clean and clear enough?

That would expose the register_mem_sect_under_node*() prototype to the caller.

I'm wondering if that would be cleaner than passing a MEMPLUG_* constant value 
to link_mem_sections() and let it choose the right callback.

  parent reply	other threads:[~2020-09-14  8:40 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-11 13:48 mm: fix memory to node bad links in sysfs Laurent Dufour
2020-09-11 13:48 ` Laurent Dufour
2020-09-11 13:48 ` [PATCH 1/3] mm: replace memmap_context by memplug_context Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-11 14:59   ` David Hildenbrand
2020-09-11 14:59     ` David Hildenbrand
2020-09-11 16:23     ` Laurent Dufour
2020-09-11 16:23       ` Laurent Dufour
2020-09-11 17:34       ` David Hildenbrand
2020-09-11 17:34         ` David Hildenbrand
2020-09-14  8:49   ` Michal Hocko
2020-09-14  8:49     ` Michal Hocko
2020-09-14  8:51     ` Laurent Dufour
2020-09-14  8:51       ` Laurent Dufour
2020-09-14  8:59       ` Michal Hocko
2020-09-14  8:59         ` Michal Hocko
2020-09-11 13:48 ` [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-14  7:57   ` David Hildenbrand
2020-09-14  7:57     ` David Hildenbrand
2020-09-14  8:05     ` Laurent Dufour
2020-09-14  8:05       ` Laurent Dufour
2020-09-14  8:19     ` Oscar Salvador
2020-09-14  8:19       ` Oscar Salvador
2020-09-14  8:31       ` David Hildenbrand
2020-09-14  8:31         ` David Hildenbrand
2020-09-14  9:16         ` Laurent Dufour
2020-09-14  9:16           ` Laurent Dufour
2020-09-14  9:19           ` David Hildenbrand
2020-09-14  9:19             ` David Hildenbrand
2020-09-14  8:39       ` Laurent Dufour [this message]
2020-09-14  8:39         ` Laurent Dufour
2020-09-14  8:55   ` Michal Hocko
2020-09-14  8:55     ` Michal Hocko
2020-09-11 13:48 ` [PATCH 3/3] mm: don't panic when links can't be created in sysfs Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-11 14:01   ` Greg Kroah-Hartman
2020-09-11 14:01     ` Greg Kroah-Hartman
2020-09-11 16:27     ` Laurent Dufour
2020-09-11 16:27       ` Laurent Dufour
2020-09-14  8:59   ` Michal Hocko
2020-09-14  8:59     ` Michal Hocko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=678b596a-4d40-be88-daf0-c2edb16dd295@linux.ibm.com \
    --to=ldufour@linux.ibm.com \
    --cc=akpm@linux-foundation.org \
    --cc=cheloha@linux.ibm.com \
    --cc=david@redhat.com \
    --cc=fenghua.yu@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nathanl@linux.ibm.com \
    --cc=osalvador@suse.de \
    --cc=rafael@kernel.org \
    --cc=stable@vger.kernel.org \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.