All of lore.kernel.org
 help / color / mirror / Atom feed
From: Laurent Dufour <ldufour@linux.ibm.com>
To: Michal Hocko <mhocko@suse.com>
Cc: akpm@linux-foundation.org, David Hildenbrand <david@redhat.com>,
	Oscar Salvador <osalvador@suse.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-mm@kvack.org, "Rafael J . Wysocki" <rafael@kernel.org>,
	nathanl@linux.ibm.com, cheloha@linux.ibm.com,
	Tony Luck <tony.luck@intel.com>,
	Fenghua Yu <fenghua.yu@intel.com>,
	linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/3] mm: replace memmap_context by memplug_context
Date: Mon, 14 Sep 2020 10:51:06 +0200	[thread overview]
Message-ID: <d3843235-2e02-a4ad-494c-20222a7e3b45@linux.ibm.com> (raw)
In-Reply-To: <20200914084904.GA16999@dhcp22.suse.cz>

Le 14/09/2020 à 10:49, Michal Hocko a écrit :
> On Fri 11-09-20 15:48:29, Laurent Dufour wrote:
>> The memmap_context is used to detect whether a memory operation is due to a
>> hot-add operation or happening at boot time.
>>
>> Makes it general to the hotplug operation, renaming it at memplug_context
>> and move its define in the corresponding header.
>>
>> There is no functional change introduced by this patch
> 
> I do not want to nit picking on naming but we want to look at this from
> the initialization POV rather than hotplug. So....
>>
>> Suggested-by: David Hildenbrand <david@redhat.com>
>> Signed-off-by: Laurent Dufour <ldufour@linux.ibm.com>
> [...]
>> diff --git a/include/linux/memory_hotplug.h b/include/linux/memory_hotplug.h
>> index 375515803cd8..cd2bd21d3a4d 100644
>> --- a/include/linux/memory_hotplug.h
>> +++ b/include/linux/memory_hotplug.h
>> @@ -15,6 +15,15 @@ struct memory_block;
>>   struct resource;
>>   struct vmem_altmap;
>>   
>> +/*
>> + * Memory plugin context, use to differentiate memory added at boot time and
>> + * hot-plugged memory.
>> + */
>> +enum memplug_context {
>> +	MEMPLUG_EARLY,
>> +	MEMPLUG_HOTPLUG,
>> +};
> 
> /*
>   * Memory initialization context, use to differentiate memory added by
>   * the platform statically or via memory hotplug interface.
>   */
> enum meminit_context {
> 	MEMINIT_EARLY,
> 	MEMINIT_HOTPLUG
> }
> 

Sounds good too.
What about its definition's place, in include/mm/zone.h as David suggested ?

WARNING: multiple messages have this Message-ID (diff)
From: Laurent Dufour <ldufour@linux.ibm.com>
To: Michal Hocko <mhocko@suse.com>
Cc: akpm@linux-foundation.org, David Hildenbrand <david@redhat.com>,
	Oscar Salvador <osalvador@suse.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-mm@kvack.org, "Rafael J . Wysocki" <rafael@kernel.org>,
	nathanl@linux.ibm.com, cheloha@linux.ibm.com,
	Tony Luck <tony.luck@intel.com>,
	Fenghua Yu <fenghua.yu@intel.com>,
	linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/3] mm: replace memmap_context by memplug_context
Date: Mon, 14 Sep 2020 08:51:06 +0000	[thread overview]
Message-ID: <d3843235-2e02-a4ad-494c-20222a7e3b45@linux.ibm.com> (raw)
In-Reply-To: <20200914084904.GA16999@dhcp22.suse.cz>

Le 14/09/2020 à 10:49, Michal Hocko a écrit :
> On Fri 11-09-20 15:48:29, Laurent Dufour wrote:
>> The memmap_context is used to detect whether a memory operation is due to a
>> hot-add operation or happening at boot time.
>>
>> Makes it general to the hotplug operation, renaming it at memplug_context
>> and move its define in the corresponding header.
>>
>> There is no functional change introduced by this patch
> 
> I do not want to nit picking on naming but we want to look at this from
> the initialization POV rather than hotplug. So....
>>
>> Suggested-by: David Hildenbrand <david@redhat.com>
>> Signed-off-by: Laurent Dufour <ldufour@linux.ibm.com>
> [...]
>> diff --git a/include/linux/memory_hotplug.h b/include/linux/memory_hotplug.h
>> index 375515803cd8..cd2bd21d3a4d 100644
>> --- a/include/linux/memory_hotplug.h
>> +++ b/include/linux/memory_hotplug.h
>> @@ -15,6 +15,15 @@ struct memory_block;
>>   struct resource;
>>   struct vmem_altmap;
>>   
>> +/*
>> + * Memory plugin context, use to differentiate memory added at boot time and
>> + * hot-plugged memory.
>> + */
>> +enum memplug_context {
>> +	MEMPLUG_EARLY,
>> +	MEMPLUG_HOTPLUG,
>> +};
> 
> /*
>   * Memory initialization context, use to differentiate memory added by
>   * the platform statically or via memory hotplug interface.
>   */
> enum meminit_context {
> 	MEMINIT_EARLY,
> 	MEMINIT_HOTPLUG
> }
> 

Sounds good too.
What about its definition's place, in include/mm/zone.h as David suggested ?

  reply	other threads:[~2020-09-14  8:51 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-11 13:48 mm: fix memory to node bad links in sysfs Laurent Dufour
2020-09-11 13:48 ` Laurent Dufour
2020-09-11 13:48 ` [PATCH 1/3] mm: replace memmap_context by memplug_context Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-11 14:59   ` David Hildenbrand
2020-09-11 14:59     ` David Hildenbrand
2020-09-11 16:23     ` Laurent Dufour
2020-09-11 16:23       ` Laurent Dufour
2020-09-11 17:34       ` David Hildenbrand
2020-09-11 17:34         ` David Hildenbrand
2020-09-14  8:49   ` Michal Hocko
2020-09-14  8:49     ` Michal Hocko
2020-09-14  8:51     ` Laurent Dufour [this message]
2020-09-14  8:51       ` Laurent Dufour
2020-09-14  8:59       ` Michal Hocko
2020-09-14  8:59         ` Michal Hocko
2020-09-11 13:48 ` [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-14  7:57   ` David Hildenbrand
2020-09-14  7:57     ` David Hildenbrand
2020-09-14  8:05     ` Laurent Dufour
2020-09-14  8:05       ` Laurent Dufour
2020-09-14  8:19     ` Oscar Salvador
2020-09-14  8:19       ` Oscar Salvador
2020-09-14  8:31       ` David Hildenbrand
2020-09-14  8:31         ` David Hildenbrand
2020-09-14  9:16         ` Laurent Dufour
2020-09-14  9:16           ` Laurent Dufour
2020-09-14  9:19           ` David Hildenbrand
2020-09-14  9:19             ` David Hildenbrand
2020-09-14  8:39       ` Laurent Dufour
2020-09-14  8:39         ` Laurent Dufour
2020-09-14  8:55   ` Michal Hocko
2020-09-14  8:55     ` Michal Hocko
2020-09-11 13:48 ` [PATCH 3/3] mm: don't panic when links can't be created in sysfs Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-11 14:01   ` Greg Kroah-Hartman
2020-09-11 14:01     ` Greg Kroah-Hartman
2020-09-11 16:27     ` Laurent Dufour
2020-09-11 16:27       ` Laurent Dufour
2020-09-14  8:59   ` Michal Hocko
2020-09-14  8:59     ` Michal Hocko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d3843235-2e02-a4ad-494c-20222a7e3b45@linux.ibm.com \
    --to=ldufour@linux.ibm.com \
    --cc=akpm@linux-foundation.org \
    --cc=cheloha@linux.ibm.com \
    --cc=david@redhat.com \
    --cc=fenghua.yu@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@suse.com \
    --cc=nathanl@linux.ibm.com \
    --cc=osalvador@suse.de \
    --cc=rafael@kernel.org \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.