All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Hildenbrand <david@redhat.com>
To: Oscar Salvador <osalvador@suse.de>
Cc: Laurent Dufour <ldufour@linux.ibm.com>,
	akpm@linux-foundation.org, mhocko@kernel.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-mm@kvack.org, "Rafael J . Wysocki" <rafael@kernel.org>,
	nathanl@linux.ibm.com, cheloha@linux.ibm.com,
	Tony Luck <tony.luck@intel.com>,
	Fenghua Yu <fenghua.yu@intel.com>,
	linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org,
	stable@vger.kernel.org, Michal Hocko <mhocko@suse.com>
Subject: Re: [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations
Date: Mon, 14 Sep 2020 10:31:47 +0200	[thread overview]
Message-ID: <96736256-a0a6-3126-3810-3380532b9621@redhat.com> (raw)
In-Reply-To: <20200914081921.GA15113@linux>

>> static int register_mem_sect_under_node_hotplug(struct memory_block *mem_blk,
>> 						void *arg)
>> {
>> 	const int nid = *(int *)arg;
>> 	int ret;
>>
>> 	/* Hotplugged memory has no holes and belongs to a single node. */
>> 	mem_blk->nid = nid;
>> 	ret = sysfs_create_link_nowarn(&node_devices[nid]->dev.kobj,
>> 				       &mem_blk->dev.kobj,
>> 				       kobject_name(&mem_blk->dev.kobj));
>> 	if (ret)
>> 		returnr et;
>> 	return sysfs_create_link_nowarn(&mem_blk->dev.kobj,
>> 					&node_devices[nid]->dev.kobj,
>> 					kobject_name(&node_devices[nid]->dev.kobj));
>>
>> }
>>
>> Cleaner, right? :) No unnecessary checks.
> 
> I tend to agree here, I like more a simplistic version for hotplug.
> 

... and while we're at it, we should rename register_mem_sect_under_node
to something like "register_memory_block_under_node" - "section" is a
legacy leftover here.

We could factor out both sysfs_create_link_nowarn() calls into something
like "do_register_memory_block_under_node" or similar, to minimize code
duplication.

>> One could argue if link_mem_section_hotplug() would be better than passing around the context.
> 
> I am not sure if I would duplicate the code there.
> We could just pass the pointer of the function we want to call to
> link_mem_sections? either register_mem_sect_under_node_hotplug or
> register_mem_sect_under_node_early?
> Would not that be clean and clear enough?

I don't particularly like passing around function pointers where it can
be avoided (e.g., here exporting 3 functions now instead 1). Makes the
interface harder to get IMHO. But I don't really care about that
interface, easy to change later on.

-- 
Thanks,

David / dhildenb


WARNING: multiple messages have this Message-ID (diff)
From: David Hildenbrand <david@redhat.com>
To: Oscar Salvador <osalvador@suse.de>
Cc: Laurent Dufour <ldufour@linux.ibm.com>,
	akpm@linux-foundation.org, mhocko@kernel.org,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-mm@kvack.org, "Rafael J . Wysocki" <rafael@kernel.org>,
	nathanl@linux.ibm.com, cheloha@linux.ibm.com,
	Tony Luck <tony.luck@intel.com>,
	Fenghua Yu <fenghua.yu@intel.com>,
	linux-ia64@vger.kernel.org, linux-kernel@vger.kernel.org,
	stable@vger.kernel.org, Michal Hocko <mhocko@suse.com>
Subject: Re: [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations
Date: Mon, 14 Sep 2020 08:31:47 +0000	[thread overview]
Message-ID: <96736256-a0a6-3126-3810-3380532b9621@redhat.com> (raw)
In-Reply-To: <20200914081921.GA15113@linux>

>> static int register_mem_sect_under_node_hotplug(struct memory_block *mem_blk,
>> 						void *arg)
>> {
>> 	const int nid = *(int *)arg;
>> 	int ret;
>>
>> 	/* Hotplugged memory has no holes and belongs to a single node. */
>> 	mem_blk->nid = nid;
>> 	ret = sysfs_create_link_nowarn(&node_devices[nid]->dev.kobj,
>> 				       &mem_blk->dev.kobj,
>> 				       kobject_name(&mem_blk->dev.kobj));
>> 	if (ret)
>> 		returnr et;
>> 	return sysfs_create_link_nowarn(&mem_blk->dev.kobj,
>> 					&node_devices[nid]->dev.kobj,
>> 					kobject_name(&node_devices[nid]->dev.kobj));
>>
>> }
>>
>> Cleaner, right? :) No unnecessary checks.
> 
> I tend to agree here, I like more a simplistic version for hotplug.
> 

... and while we're at it, we should rename register_mem_sect_under_node
to something like "register_memory_block_under_node" - "section" is a
legacy leftover here.

We could factor out both sysfs_create_link_nowarn() calls into something
like "do_register_memory_block_under_node" or similar, to minimize code
duplication.

>> One could argue if link_mem_section_hotplug() would be better than passing around the context.
> 
> I am not sure if I would duplicate the code there.
> We could just pass the pointer of the function we want to call to
> link_mem_sections? either register_mem_sect_under_node_hotplug or
> register_mem_sect_under_node_early?
> Would not that be clean and clear enough?

I don't particularly like passing around function pointers where it can
be avoided (e.g., here exporting 3 functions now instead 1). Makes the
interface harder to get IMHO. But I don't really care about that
interface, easy to change later on.

-- 
Thanks,

David / dhildenb

  reply	other threads:[~2020-09-14  8:32 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-11 13:48 mm: fix memory to node bad links in sysfs Laurent Dufour
2020-09-11 13:48 ` Laurent Dufour
2020-09-11 13:48 ` [PATCH 1/3] mm: replace memmap_context by memplug_context Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-11 14:59   ` David Hildenbrand
2020-09-11 14:59     ` David Hildenbrand
2020-09-11 16:23     ` Laurent Dufour
2020-09-11 16:23       ` Laurent Dufour
2020-09-11 17:34       ` David Hildenbrand
2020-09-11 17:34         ` David Hildenbrand
2020-09-14  8:49   ` Michal Hocko
2020-09-14  8:49     ` Michal Hocko
2020-09-14  8:51     ` Laurent Dufour
2020-09-14  8:51       ` Laurent Dufour
2020-09-14  8:59       ` Michal Hocko
2020-09-14  8:59         ` Michal Hocko
2020-09-11 13:48 ` [PATCH 2/3] mm: don't rely on system state to detect hot-plug operations Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-14  7:57   ` David Hildenbrand
2020-09-14  7:57     ` David Hildenbrand
2020-09-14  8:05     ` Laurent Dufour
2020-09-14  8:05       ` Laurent Dufour
2020-09-14  8:19     ` Oscar Salvador
2020-09-14  8:19       ` Oscar Salvador
2020-09-14  8:31       ` David Hildenbrand [this message]
2020-09-14  8:31         ` David Hildenbrand
2020-09-14  9:16         ` Laurent Dufour
2020-09-14  9:16           ` Laurent Dufour
2020-09-14  9:19           ` David Hildenbrand
2020-09-14  9:19             ` David Hildenbrand
2020-09-14  8:39       ` Laurent Dufour
2020-09-14  8:39         ` Laurent Dufour
2020-09-14  8:55   ` Michal Hocko
2020-09-14  8:55     ` Michal Hocko
2020-09-11 13:48 ` [PATCH 3/3] mm: don't panic when links can't be created in sysfs Laurent Dufour
2020-09-11 13:48   ` Laurent Dufour
2020-09-11 14:01   ` Greg Kroah-Hartman
2020-09-11 14:01     ` Greg Kroah-Hartman
2020-09-11 16:27     ` Laurent Dufour
2020-09-11 16:27       ` Laurent Dufour
2020-09-14  8:59   ` Michal Hocko
2020-09-14  8:59     ` Michal Hocko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=96736256-a0a6-3126-3810-3380532b9621@redhat.com \
    --to=david@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=cheloha@linux.ibm.com \
    --cc=fenghua.yu@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=ldufour@linux.ibm.com \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mhocko@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nathanl@linux.ibm.com \
    --cc=osalvador@suse.de \
    --cc=rafael@kernel.org \
    --cc=stable@vger.kernel.org \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.