linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: bhelgaas@google.com (Bjorn Helgaas)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v6 12/30] PCI: Introduce pci_host_bridge_ops to support host specific operations
Date: Wed, 11 Mar 2015 22:23:41 -0500	[thread overview]
Message-ID: <20150312032341.GE10949@google.com> (raw)
In-Reply-To: <1425868467-9667-13-git-send-email-wangyijing@huawei.com>

On Mon, Mar 09, 2015 at 10:34:09AM +0800, Yijing Wang wrote:
> Now we have weak functions like pcibios_root_bridge_prepare()
> to setup pci host bridge, We could introduce pci_host_bridge_ops
> which contain host bridge specific ops to setup pci_host_bridge.
> Then host bridge driver could add pci_host_bridge_ops hooks
> intead of weak function to setup pci_host_bridge.
> This patch add following pci_host_bridge_ops hooks:
> 
> pci_host_bridge_ops {
> 	/* set root bus speed, some platform need this like powerpc */
> 	void (*set_root_bus_speed)(struct pci_host_bridge *host);
> 	/* setup pci_host_bridge before pci_host_bridge be added to driver core */
> 	int (*prepare)(struct pci_host_bridge *host);
> 	/* platform specific of scan hook to scan pci device */
> 	void (*scan_bus)(struct pci_host_bridge *);
> }
> We could easily extend it to support different host bridge
> specific operations.
> 
> Signed-off-by: Yijing Wang <wangyijing@huawei.com>
> Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
> ---
>  drivers/pci/host-bridge.c |   12 ++++++++++--
>  drivers/pci/pci.h         |    4 ++--
>  drivers/pci/probe.c       |   17 +++++++++++------
>  include/linux/pci.h       |    8 ++++++++
>  4 files changed, 31 insertions(+), 10 deletions(-)
> 
> diff --git a/drivers/pci/host-bridge.c b/drivers/pci/host-bridge.c
> index 3c34c49..bc1de59 100644
> --- a/drivers/pci/host-bridge.c
> +++ b/drivers/pci/host-bridge.c
> @@ -23,8 +23,8 @@ static void pci_release_host_bridge_dev(struct device *dev)
>  }
>  
>  struct pci_host_bridge *pci_create_host_bridge(
> -		struct device *parent, u32 db,
> -		struct list_head *resources, void *sysdata)
> +		struct device *parent, u32 db, struct list_head *resources,
> +		void *sysdata, struct pci_host_bridge_ops *ops)
>  {
>  	int error;
>  	int bus = PCI_BUSNUM(db);
> @@ -56,6 +56,7 @@ struct pci_host_bridge *pci_create_host_bridge(
>  		}
>  	mutex_unlock(&phb_mutex);
>  
> +	host->ops = ops;
>  	host->dev.parent = parent;
>  	INIT_LIST_HEAD(&host->windows);
>  	host->dev.release = pci_release_host_bridge_dev;
> @@ -63,6 +64,13 @@ struct pci_host_bridge *pci_create_host_bridge(
>  	dev_set_name(&host->dev, "pci%04x:%02x", host->domain,
>  			host->busnum);
>  
> +	if (host->ops && host->ops->prepare) {
> +		error = host->ops->prepare(host);
> +		if (error) {
> +			kfree(host);
> +			return NULL;
> +		}
> +	}
>  	error = device_register(&host->dev);
>  	if (error) {
>  		put_device(&host->dev);
> diff --git a/drivers/pci/pci.h b/drivers/pci/pci.h
> index 79a8894..a1dc9f2 100644
> --- a/drivers/pci/pci.h
> +++ b/drivers/pci/pci.h
> @@ -324,8 +324,8 @@ static inline int pci_dev_specific_reset(struct pci_dev *dev, int probe)
>  #endif
>  
>  struct pci_host_bridge *pci_create_host_bridge(
> -		struct device *parent, u32 dombus,
> -		struct list_head *resources, void *sysdata);
> +		struct device *parent, u32 dombus, struct list_head *resources,
> +		void *sysdata, struct pci_host_bridge_ops *ops);
>  
>  void pci_free_host_bridge(struct pci_host_bridge *host);
>  #endif /* DRIVERS_PCI_H */
> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
> index c8e074d..59d9be3 100644
> --- a/drivers/pci/probe.c
> +++ b/drivers/pci/probe.c
> @@ -1889,6 +1889,8 @@ static struct pci_bus *__pci_create_root_bus(
>  
>  	bridge->bus = b;
>  	b->bridge = get_device(&bridge->dev);
> +	if (bridge->ops && bridge->ops->set_root_bus_speed)
> +		bridge->ops->set_root_bus_speed(bridge);

Before this patch, can you do this:

  - Rename the powerpc pcibios_root_bridge_prepare() to
    pcibios_set_root_bus_speed() and add a call to it here

  - Move the pcibios_root_bridge_prepare() call to pci_create_host_bridge()

Then this patch will make a lot more sense because it will look like this,
with the host bridge ops call right next to the matching pcibios call:

  +	if (host->ops && host->ops->prepare) {
  +		error = host->ops->prepare(host);
  +		...
  +	}
	pcibios_root_bridge_prepare(...);

  +	if (bridge->ops && bridge->ops->set_root_bus_speed)
  +		bridge->ops->set_root_bus_speed(bridge);
	pcibios_set_root_bus_speed(...);

>  	error = pcibios_root_bridge_prepare(bridge);
>  	if (error)
>  		goto err_out;
> @@ -1954,7 +1956,7 @@ struct pci_bus *pci_create_root_bus(struct device *parent, u32 db,
>  {
>  	struct pci_host_bridge *host;
>  
> -	host = pci_create_host_bridge(parent, db, resources, sysdata);
> +	host = pci_create_host_bridge(parent, db, resources, sysdata, NULL);
>  	if (!host)
>  		return NULL;
>  
> @@ -2051,10 +2053,13 @@ static struct pci_bus *__pci_scan_root_bus(
>  		pci_bus_insert_busn_res(b, b->number, 255);
>  	}
>  
> -	max = pci_scan_child_bus(b);
> -
> -	if (!found)
> -		pci_bus_update_busn_res_end(b, max);
> +	if (host->ops && host->ops->scan_bus) {
> +		host->ops->scan_bus(host);
> +	} else {
> +		max = pci_scan_child_bus(b);
> +		if (!found)
> +			pci_bus_update_busn_res_end(b, max);
> +	}

I think host->ops->scan_bus() should have the same prototype as
pci_scan_child_bus(), and it should return max, and you should do the same
busn update as when you call pci_scan_child_bus().  So the code would look
like this:

    if (host->ops && host->ops->scan_bus)
	max = host->ops->scan_bus(b);
    else
	max = pci_scan_child_bus(b);

    if (!found)
	pci_bus_update_busn_res_end(b, max);

>  
>  	return b;
>  }
> @@ -2064,7 +2069,7 @@ struct pci_bus *pci_scan_root_bus(struct device *parent, u32 db,
>  {
>  	struct pci_host_bridge *host;
>  
> -	host = pci_create_host_bridge(parent, db, resources, sysdata);
> +	host = pci_create_host_bridge(parent, db, resources, sysdata, NULL);
>  	if (!host)
>  		return NULL;
>  
> diff --git a/include/linux/pci.h b/include/linux/pci.h
> index b621f5b..e9922b1 100644
> --- a/include/linux/pci.h
> +++ b/include/linux/pci.h
> @@ -400,6 +400,13 @@ static inline int pci_channel_offline(struct pci_dev *pdev)
>  	return (pdev->error_state != pci_channel_io_normal);
>  }
>  
> +struct pci_host_bridge;
> +struct pci_host_bridge_ops {
> +	void (*set_root_bus_speed)(struct pci_host_bridge *host);
> +	int (*prepare)(struct pci_host_bridge *host);
> +	void (*scan_bus)(struct pci_host_bridge *);

Needs an argument name to match the style of the other ops.

> +};
> +
>  struct pci_host_bridge {
>  	u16	domain;
>  	u16 busnum;
> @@ -407,6 +414,7 @@ struct pci_host_bridge {
>  	struct pci_bus *bus;		/* root bus */
>  	struct list_head windows;	/* resource_entry */
>  	struct list_head list;
> +	struct pci_host_bridge_ops *ops;
>  	void (*release_fn)(struct pci_host_bridge *);
>  	void *release_data;
>  };
> -- 
> 1.7.1
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo at vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/

  reply	other threads:[~2015-03-12  3:23 UTC|newest]

Thread overview: 87+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-09  2:33 [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-03-09  2:33 ` [PATCH v6 01/30] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-03-09  2:33 ` [PATCH v6 02/30] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 03/30] PCI: Export busn_resource to drivers/pci Yijing Wang
2015-03-11 22:28   ` Bjorn Helgaas
2015-03-12 11:42     ` Yijing Wang
2015-03-12 19:32       ` Bjorn Helgaas
2015-03-13  1:57         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 04/30] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-03-11 22:32   ` Bjorn Helgaas
2015-03-12 11:46     ` Yijing Wang
2015-03-12 19:35       ` Bjorn Helgaas
2015-03-13  2:36         ` Yijing Wang
2015-03-13 13:24           ` Bjorn Helgaas
2015-03-13 14:01             ` Konrad Rzeszutek Wilk
2015-03-13 14:26               ` Bjorn Helgaas
2015-03-25 19:23                 ` Konrad Rzeszutek Wilk
2015-03-26  1:18                   ` Yijing Wang
2015-03-26  7:30                   ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 05/30] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 06/30] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-03-12  1:29   ` Bjorn Helgaas
2015-03-12 12:14     ` Yijing Wang
2015-03-12 19:49       ` Bjorn Helgaas
2015-03-13  3:19         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 07/30] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-03-12  1:34   ` Bjorn Helgaas
2015-03-12 12:20     ` Yijing Wang
2015-03-17  5:15   ` [Xen-devel] " Manish Jaggi
2015-03-17 14:05     ` Ian Campbell
2015-03-09  2:34 ` [PATCH v6 08/30] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-03-12  1:39   ` Bjorn Helgaas
2015-03-12 12:23     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 09/30] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-03-12  3:52   ` Bjorn Helgaas
2015-03-12 13:44     ` Yijing Wang
2015-03-21 23:21   ` Suravee Suthikulpanit
2015-03-23  1:08     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 10/30] PCI: Introduce pci_host_bridge_list to manage host bridges Yijing Wang
2015-03-12  2:55   ` Bjorn Helgaas
2015-03-12 13:03     ` Yijing Wang
2015-03-12 19:56       ` Bjorn Helgaas
2015-03-13  3:28         ` Yijing Wang
2015-03-13 14:33           ` Bjorn Helgaas
2015-03-16  1:28             ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 11/30] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-03-09  2:34 ` [PATCH v6 12/30] PCI: Introduce pci_host_bridge_ops to support host specific operations Yijing Wang
2015-03-12  3:23   ` Bjorn Helgaas [this message]
2015-03-12 13:14     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 13/30] PCI: Introduce new scan function pci_scan_host_bridge() Yijing Wang
2015-03-12  3:25   ` Bjorn Helgaas
2015-03-12 13:15     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 14/30] x86/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-03-09  2:34 ` [PATCH v6 15/30] ia64/PCI: " Yijing Wang
2015-03-09  2:34 ` [PATCH v6 16/30] powerpc/pci: Rename pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 17/30] powerpc/pci: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 18/30] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 19/30] sparc/PCI: Claim bus resources before pci_bus_add_devices() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 20/30] sparc/PCI: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-12  3:30   ` Bjorn Helgaas
2015-03-12 13:17     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 21/30] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-03-12  3:33   ` Bjorn Helgaas
2015-03-12 13:24     ` Yijing Wang
2015-03-12  3:36   ` Bjorn Helgaas
2015-03-12 13:28     ` Yijing Wang
2015-03-12 20:00       ` Bjorn Helgaas
2015-03-09  2:34 ` [PATCH v6 22/30] parisc/PCI: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 23/30] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-03-09  2:34 ` [PATCH v6 24/30] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 25/30] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 26/30] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 27/30] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 28/30] PCI: Export find_pci_host_bridge() and rename to pci_find_host_bridge() Yijing Wang
2015-03-12  3:43   ` Bjorn Helgaas
2015-03-12 13:29     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 29/30] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 30/30] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-03-12  3:48   ` Bjorn Helgaas
2015-03-12 13:32     ` Yijing Wang
2015-03-12 21:23 ` [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Bjorn Helgaas
2015-03-13  3:29   ` Yijing Wang
2015-03-13 11:31   ` Liviu Dudau
2015-03-13 14:48     ` Bjorn Helgaas
2015-03-16  1:31       ` Yijing Wang
2015-03-16  1:48     ` Yijing Wang
2015-03-17 10:55       ` Liviu Dudau

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150312032341.GE10949@google.com \
    --to=bhelgaas@google.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).