linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: wangyijing@huawei.com (Yijing Wang)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v6 06/30] PCI: Combine PCI domain and bus number in u32 arg
Date: Thu, 12 Mar 2015 20:14:40 +0800	[thread overview]
Message-ID: <55018330.5050002@huawei.com> (raw)
In-Reply-To: <20150312012946.GA10949@google.com>

On 2015/3/12 9:29, Bjorn Helgaas wrote:
> On Mon, Mar 09, 2015 at 10:34:03AM +0800, Yijing Wang wrote:
>> Currently, we use int type for bus number in
>> pci_create_root_bus(), pci_scan_root_bus() and
>> pci_scan_bus_legacy. Because PCI bus number
>> always <= 255, so we could change the bus number
>> argument type to u32, and combine PCI domain and
>> bus number in one. 
> 
> This makes no sense.  Or rather, it only states the obvious: an 8-bit value
> and a 16-bit value will both fit in a 32-bit value.  But it doesn't say
> *why* you think it's a good idea to pass a single value that contains both
> domain and bus numbers.  The obvious thing is to pass two separate values,
> and you don't say why passing a single combined value is better.

Sorry for my poor description for this patch, I combined the domain and bus, because
I think now we have too many args at pci_scan_root_bus() or other scan functions,

struct pci_bus *pci_scan_root_bus(struct device *parent, int bus,
		struct pci_ops *ops, void *sysdata, struct list_head *resources)

Now we have five args yet, plus the new introduced domain and pci_host_bridge_ops,
it will become 7.

I thought introduced a new structure which contain the necessary info to scan root bus/ host bridge,

E.g

struct pci_scan_info {
	int bus;
	struct device *parent;
	struct pci_ops *ops;
	void *sysdata;
	struct list_head *resource;
	int domain;
	struct pci_host_bridge_ops;
}

Do you like this one or keep it like now ?

pci_scan_root_bus(struct device *parent, int domain, int bus,
		struct pci_ops *ops, void *sysdata, struct list_head *resources, struct pci_host_bridge_ops *ops)


> 
> Also see whitespace mistakes below.  I get a little testy when people don't
> follow the whitespace convention of neighboring lines because if people are
> sloppy about whitespace I assume they're sloppy about the code.
> 

Sorry, I would be more careful.


>>  	int error;
>> @@ -1901,6 +1901,7 @@ struct pci_bus *pci_create_root_bus(struct device *parent, int bus,
>>  	resource_size_t offset;
>>  	char bus_addr[64];
>>  	char *fmt;
>> +	u8	bus = PCI_BUSNUM(db);
> 
> Whitespace botch.
> 
>>  
>>  	b = pci_alloc_bus(NULL);
>>  	if (!b)
>> @@ -1921,6 +1922,7 @@ struct pci_bus *pci_create_root_bus(struct device *parent, int bus,
>>  	if (!bridge)
>>  		goto err_out;
>>  
>> +	bridge->domain = PCI_DOMAIN(db);
>>  	bridge->dev.parent = parent;
>>  	bridge->dev.release = pci_release_host_bridge_dev;
>>  	dev_set_name(&bridge->dev, "pci%04x:%02x", pci_domain_nr(b), bus);
>> @@ -2058,7 +2060,7 @@ void pci_bus_release_busn_res(struct pci_bus *b)
>>  			res, ret ? "can not be" : "is");
>>  }
>>  
>> -struct pci_bus *pci_scan_root_bus(struct device *parent, int bus,
>> +struct pci_bus *pci_scan_root_bus(struct device *parent, u32 db,
>>  		struct pci_ops *ops, void *sysdata, struct list_head *resources)
>>  {
>>  	struct resource_entry *window;
>> @@ -2072,15 +2074,15 @@ struct pci_bus *pci_scan_root_bus(struct device *parent, int bus,
>>  			break;
>>  		}
>>  
>> -	b = pci_create_root_bus(parent, bus, ops, sysdata, resources);
>> +	b = pci_create_root_bus(parent, db, ops, sysdata, resources);
>>  	if (!b)
>>  		return NULL;
>>  
>>  	if (!found) {
>>  		dev_info(&b->dev,
>>  		 "No busn resource found for root bus, will use [bus %02x-ff]\n",
>> -			bus);
>> -		pci_bus_insert_busn_res(b, bus, 255);
>> +			PCI_BUSNUM(db));
>> +		pci_bus_insert_busn_res(b, PCI_BUSNUM(db), 255);
>>  	}
>>  
>>  	max = pci_scan_child_bus(b);
>> @@ -2092,7 +2094,7 @@ struct pci_bus *pci_scan_root_bus(struct device *parent, int bus,
>>  }
>>  EXPORT_SYMBOL(pci_scan_root_bus);
>>  
>> -struct pci_bus *pci_scan_bus(int bus, struct pci_ops *ops,
>> +struct pci_bus *pci_scan_bus(u32 db, struct pci_ops *ops,
>>  					void *sysdata)
>>  {
>>  	LIST_HEAD(resources);
>> @@ -2101,7 +2103,7 @@ struct pci_bus *pci_scan_bus(int bus, struct pci_ops *ops,
>>  	pci_add_resource(&resources, &ioport_resource);
>>  	pci_add_resource(&resources, &iomem_resource);
>>  	pci_add_resource(&resources, &busn_resource);
>> -	b = pci_create_root_bus(NULL, bus, ops, sysdata, &resources);
>> +	b = pci_create_root_bus(NULL, db, ops, sysdata, &resources);
>>  	if (b) {
>>  		pci_scan_child_bus(b);
>>  	} else {
>> diff --git a/include/linux/pci.h b/include/linux/pci.h
>> index 36effb8..8b3d245 100644
>> --- a/include/linux/pci.h
>> +++ b/include/linux/pci.h
>> @@ -401,6 +401,7 @@ static inline int pci_channel_offline(struct pci_dev *pdev)
>>  }
>>  
>>  struct pci_host_bridge {
>> +	u16	domain;
> 
> Please follow the existing whitespace convention, i.e., use a space, not a
> tab, between "u16 domain".
> 
>>  	struct device dev;
>>  	struct pci_bus *bus;		/* root bus */
>>  	struct list_head windows;	/* resource_entry */
>> @@ -769,14 +770,14 @@ void pcibios_bus_to_resource(struct pci_bus *bus, struct resource *res,
>>  void pcibios_scan_specific_bus(int busn);
>>  struct pci_bus *pci_find_bus(int domain, int busnr);
>>  void pci_bus_add_devices(const struct pci_bus *bus);
>> -struct pci_bus *pci_scan_bus(int bus, struct pci_ops *ops, void *sysdata);
>> -struct pci_bus *pci_create_root_bus(struct device *parent, int bus,
>> +struct pci_bus *pci_scan_bus(u32 dombus, struct pci_ops *ops, void *sysdata);
>> +struct pci_bus *pci_create_root_bus(struct device *parent, u32 dombus,
>>  				    struct pci_ops *ops, void *sysdata,
>>  				    struct list_head *resources);
>>  int pci_bus_insert_busn_res(struct pci_bus *b, int bus, int busmax);
>>  int pci_bus_update_busn_res_end(struct pci_bus *b, int busmax);
>>  void pci_bus_release_busn_res(struct pci_bus *b);
>> -struct pci_bus *pci_scan_root_bus(struct device *parent, int bus,
>> +struct pci_bus *pci_scan_root_bus(struct device *parent, u32 dombus,
>>  					     struct pci_ops *ops, void *sysdata,
>>  					     struct list_head *resources);
>>  struct pci_bus *pci_add_new_bus(struct pci_bus *parent, struct pci_dev *dev,
>> diff --git a/include/uapi/linux/pci.h b/include/uapi/linux/pci.h
>> index 3c292bc..89c6f15 100644
>> --- a/include/uapi/linux/pci.h
>> +++ b/include/uapi/linux/pci.h
>> @@ -30,6 +30,9 @@
>>  #define PCI_DEVFN(slot, func)	((((slot) & 0x1f) << 3) | ((func) & 0x07))
>>  #define PCI_SLOT(devfn)		(((devfn) >> 3) & 0x1f)
>>  #define PCI_FUNC(devfn)		((devfn) & 0x07)
>> +#define PCI_DOMAIN(db)		((db) >> 16)
>> +#define PCI_BUSNUM(db)		((db) & 0xffff)
>> +#define PCI_DOMBUS(domain, bus)		(((domain) << 16) | (bus))
>>  
>>  /* Ioctls for /proc/bus/pci/X/Y nodes. */
>>  #define PCIIOC_BASE		('P' << 24 | 'C' << 16 | 'I' << 8)
>> -- 
>> 1.7.1
>>
>> --
>> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
>> the body of a message to majordomo at vger.kernel.org
>> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 
> .
> 


-- 
Thanks!
Yijing

  reply	other threads:[~2015-03-12 12:14 UTC|newest]

Thread overview: 87+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-09  2:33 [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-03-09  2:33 ` [PATCH v6 01/30] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-03-09  2:33 ` [PATCH v6 02/30] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 03/30] PCI: Export busn_resource to drivers/pci Yijing Wang
2015-03-11 22:28   ` Bjorn Helgaas
2015-03-12 11:42     ` Yijing Wang
2015-03-12 19:32       ` Bjorn Helgaas
2015-03-13  1:57         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 04/30] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-03-11 22:32   ` Bjorn Helgaas
2015-03-12 11:46     ` Yijing Wang
2015-03-12 19:35       ` Bjorn Helgaas
2015-03-13  2:36         ` Yijing Wang
2015-03-13 13:24           ` Bjorn Helgaas
2015-03-13 14:01             ` Konrad Rzeszutek Wilk
2015-03-13 14:26               ` Bjorn Helgaas
2015-03-25 19:23                 ` Konrad Rzeszutek Wilk
2015-03-26  1:18                   ` Yijing Wang
2015-03-26  7:30                   ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 05/30] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 06/30] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-03-12  1:29   ` Bjorn Helgaas
2015-03-12 12:14     ` Yijing Wang [this message]
2015-03-12 19:49       ` Bjorn Helgaas
2015-03-13  3:19         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 07/30] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-03-12  1:34   ` Bjorn Helgaas
2015-03-12 12:20     ` Yijing Wang
2015-03-17  5:15   ` [Xen-devel] " Manish Jaggi
2015-03-17 14:05     ` Ian Campbell
2015-03-09  2:34 ` [PATCH v6 08/30] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-03-12  1:39   ` Bjorn Helgaas
2015-03-12 12:23     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 09/30] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-03-12  3:52   ` Bjorn Helgaas
2015-03-12 13:44     ` Yijing Wang
2015-03-21 23:21   ` Suravee Suthikulpanit
2015-03-23  1:08     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 10/30] PCI: Introduce pci_host_bridge_list to manage host bridges Yijing Wang
2015-03-12  2:55   ` Bjorn Helgaas
2015-03-12 13:03     ` Yijing Wang
2015-03-12 19:56       ` Bjorn Helgaas
2015-03-13  3:28         ` Yijing Wang
2015-03-13 14:33           ` Bjorn Helgaas
2015-03-16  1:28             ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 11/30] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-03-09  2:34 ` [PATCH v6 12/30] PCI: Introduce pci_host_bridge_ops to support host specific operations Yijing Wang
2015-03-12  3:23   ` Bjorn Helgaas
2015-03-12 13:14     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 13/30] PCI: Introduce new scan function pci_scan_host_bridge() Yijing Wang
2015-03-12  3:25   ` Bjorn Helgaas
2015-03-12 13:15     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 14/30] x86/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-03-09  2:34 ` [PATCH v6 15/30] ia64/PCI: " Yijing Wang
2015-03-09  2:34 ` [PATCH v6 16/30] powerpc/pci: Rename pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 17/30] powerpc/pci: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 18/30] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 19/30] sparc/PCI: Claim bus resources before pci_bus_add_devices() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 20/30] sparc/PCI: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-12  3:30   ` Bjorn Helgaas
2015-03-12 13:17     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 21/30] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-03-12  3:33   ` Bjorn Helgaas
2015-03-12 13:24     ` Yijing Wang
2015-03-12  3:36   ` Bjorn Helgaas
2015-03-12 13:28     ` Yijing Wang
2015-03-12 20:00       ` Bjorn Helgaas
2015-03-09  2:34 ` [PATCH v6 22/30] parisc/PCI: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 23/30] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-03-09  2:34 ` [PATCH v6 24/30] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 25/30] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 26/30] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 27/30] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 28/30] PCI: Export find_pci_host_bridge() and rename to pci_find_host_bridge() Yijing Wang
2015-03-12  3:43   ` Bjorn Helgaas
2015-03-12 13:29     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 29/30] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 30/30] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-03-12  3:48   ` Bjorn Helgaas
2015-03-12 13:32     ` Yijing Wang
2015-03-12 21:23 ` [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Bjorn Helgaas
2015-03-13  3:29   ` Yijing Wang
2015-03-13 11:31   ` Liviu Dudau
2015-03-13 14:48     ` Bjorn Helgaas
2015-03-16  1:31       ` Yijing Wang
2015-03-16  1:48     ` Yijing Wang
2015-03-17 10:55       ` Liviu Dudau

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=55018330.5050002@huawei.com \
    --to=wangyijing@huawei.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).