linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: wangyijing@huawei.com (Yijing Wang)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v6 21/30] PCI: Introduce pci_bus_child_max_busnr()
Date: Thu, 12 Mar 2015 21:24:51 +0800	[thread overview]
Message-ID: <550193A3.1020102@huawei.com> (raw)
In-Reply-To: <20150312033305.GH10949@google.com>

On 2015/3/12 11:33, Bjorn Helgaas wrote:
> On Mon, Mar 09, 2015 at 10:34:18AM +0800, Yijing Wang wrote:
>> Sometimes, we need to know the highest reserved
>> busnr for children bus. Because parent's
>> bus->busn_res could have padding in it.
>> This function return the max child busnr as
>> pci_scan_child_bus().
> 
> I'm not convinced about this one.  The fact that it's only used by parisc
> lba_pci.c and acpiphp makes me suspicious that either they're doing
> something funny, or other drivers *should* be using it, too.

Yes, what lba_pci.c do looks some strange, I did this patch just try to
keep the original logic, but it seems to make code more complex, I would
consider this again and try to find a better solution, thanks.

> 
>> Signed-off-by: Yijing Wang <wangyijing@huawei.com>
>> Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
>> Signed-off-by: Fengguang Wu <fengguang.wu@intel.com>
>> ---
>>  drivers/pci/hotplug/acpiphp_glue.c |   29 +----------------------------
>>  drivers/pci/pci.c                  |   27 +++++++++++++++++++++++++--
>>  include/linux/pci.h                |    2 +-
>>  3 files changed, 27 insertions(+), 31 deletions(-)
>>
>> diff --git a/drivers/pci/hotplug/acpiphp_glue.c b/drivers/pci/hotplug/acpiphp_glue.c
>> index bcb90e4..84f2584 100644
>> --- a/drivers/pci/hotplug/acpiphp_glue.c
>> +++ b/drivers/pci/hotplug/acpiphp_glue.c
>> @@ -397,33 +397,6 @@ static void cleanup_bridge(struct acpiphp_bridge *bridge)
>>  	acpi_unlock_hp_context();
>>  }
>>  
>> -/**
>> - * acpiphp_max_busnr - return the highest reserved bus number under the given bus.
>> - * @bus: bus to start search with
>> - */
>> -static unsigned char acpiphp_max_busnr(struct pci_bus *bus)
>> -{
>> -	struct pci_bus *tmp;
>> -	unsigned char max, n;
>> -
>> -	/*
>> -	 * pci_bus_max_busnr will return the highest
>> -	 * reserved busnr for all these children.
>> -	 * that is equivalent to the bus->subordinate
>> -	 * value.  We don't want to use the parent's
>> -	 * bus->subordinate value because it could have
>> -	 * padding in it.
>> -	 */
>> -	max = bus->busn_res.start;
>> -
>> -	list_for_each_entry(tmp, &bus->children, node) {
>> -		n = pci_bus_max_busnr(tmp);
>> -		if (n > max)
>> -			max = n;
>> -	}
>> -	return max;
>> -}
>> -
>>  static void acpiphp_set_acpi_region(struct acpiphp_slot *slot)
>>  {
>>  	struct acpiphp_func *func;
>> @@ -489,7 +462,7 @@ static void enable_slot(struct acpiphp_slot *slot)
>>  	LIST_HEAD(add_list);
>>  
>>  	acpiphp_rescan_slot(slot);
>> -	max = acpiphp_max_busnr(bus);
>> +	max = pci_bus_child_max_busnr(bus);
>>  	for (pass = 0; pass < 2; pass++) {
>>  		list_for_each_entry(dev, &bus->devices, bus_list) {
>>  			if (PCI_SLOT(dev->devfn) != slot->device)
>> diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c
>> index c49eec1..0001896 100644
>> --- a/drivers/pci/pci.c
>> +++ b/drivers/pci/pci.c
>> @@ -108,7 +108,7 @@ static bool pcie_ari_disabled;
>>   * Given a PCI bus, returns the highest PCI bus number present in the set
>>   * including the given PCI bus and its list of child PCI buses.
>>   */
>> -unsigned char pci_bus_max_busnr(struct pci_bus *bus)
>> +static unsigned char pci_bus_max_busnr(struct pci_bus *bus)
>>  {
>>  	struct pci_bus *tmp;
>>  	unsigned char max, n;
>> @@ -121,7 +121,30 @@ unsigned char pci_bus_max_busnr(struct pci_bus *bus)
>>  	}
>>  	return max;
>>  }
>> -EXPORT_SYMBOL_GPL(pci_bus_max_busnr);
>> +
>> +unsigned char pci_bus_child_max_busnr(struct pci_bus *bus)
>> +{
>> +	struct pci_bus *tmp;
>> +	unsigned char max, n;
>> +
>> +	/*
>> +	 * pci_bus_max_busnr will return the highest
>> +	 * reserved busnr for all these children.
>> +	 * that is equivalent to the bus->subordinate
>> +	 * value.  We don't want to use the parent's
>> +	 * bus->subordinate value because it could have
>> +	 * padding in it.
>> +	 */
>> +	max = bus->busn_res.start;
>> +
>> +	list_for_each_entry(tmp, &bus->children, node) {
>> +		n = pci_bus_max_busnr(tmp);
>> +		if (n > max)
>> +			max = n;
>> +	}
>> +	return max;
>> +}
>> +EXPORT_SYMBOL_GPL(pci_bus_child_max_busnr);
>>  
>>  #ifdef CONFIG_HAS_IOMEM
>>  void __iomem *pci_ioremap_bar(struct pci_dev *pdev, int bar)
>> diff --git a/include/linux/pci.h b/include/linux/pci.h
>> index cfaf217..261b8de 100644
>> --- a/include/linux/pci.h
>> +++ b/include/linux/pci.h
>> @@ -1181,7 +1181,7 @@ int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max,
>>  void pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *),
>>  		  void *userdata);
>>  int pci_cfg_space_size(struct pci_dev *dev);
>> -unsigned char pci_bus_max_busnr(struct pci_bus *bus);
>> +unsigned char pci_bus_child_max_busnr(struct pci_bus *bus);
>>  void pci_setup_bridge(struct pci_bus *bus);
>>  resource_size_t pcibios_window_alignment(struct pci_bus *bus,
>>  					 unsigned long type);
>> -- 
>> 1.7.1
>>
> 
> .
> 


-- 
Thanks!
Yijing

  reply	other threads:[~2015-03-12 13:24 UTC|newest]

Thread overview: 87+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-09  2:33 [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-03-09  2:33 ` [PATCH v6 01/30] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-03-09  2:33 ` [PATCH v6 02/30] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 03/30] PCI: Export busn_resource to drivers/pci Yijing Wang
2015-03-11 22:28   ` Bjorn Helgaas
2015-03-12 11:42     ` Yijing Wang
2015-03-12 19:32       ` Bjorn Helgaas
2015-03-13  1:57         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 04/30] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-03-11 22:32   ` Bjorn Helgaas
2015-03-12 11:46     ` Yijing Wang
2015-03-12 19:35       ` Bjorn Helgaas
2015-03-13  2:36         ` Yijing Wang
2015-03-13 13:24           ` Bjorn Helgaas
2015-03-13 14:01             ` Konrad Rzeszutek Wilk
2015-03-13 14:26               ` Bjorn Helgaas
2015-03-25 19:23                 ` Konrad Rzeszutek Wilk
2015-03-26  1:18                   ` Yijing Wang
2015-03-26  7:30                   ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 05/30] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 06/30] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-03-12  1:29   ` Bjorn Helgaas
2015-03-12 12:14     ` Yijing Wang
2015-03-12 19:49       ` Bjorn Helgaas
2015-03-13  3:19         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 07/30] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-03-12  1:34   ` Bjorn Helgaas
2015-03-12 12:20     ` Yijing Wang
2015-03-17  5:15   ` [Xen-devel] " Manish Jaggi
2015-03-17 14:05     ` Ian Campbell
2015-03-09  2:34 ` [PATCH v6 08/30] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-03-12  1:39   ` Bjorn Helgaas
2015-03-12 12:23     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 09/30] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-03-12  3:52   ` Bjorn Helgaas
2015-03-12 13:44     ` Yijing Wang
2015-03-21 23:21   ` Suravee Suthikulpanit
2015-03-23  1:08     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 10/30] PCI: Introduce pci_host_bridge_list to manage host bridges Yijing Wang
2015-03-12  2:55   ` Bjorn Helgaas
2015-03-12 13:03     ` Yijing Wang
2015-03-12 19:56       ` Bjorn Helgaas
2015-03-13  3:28         ` Yijing Wang
2015-03-13 14:33           ` Bjorn Helgaas
2015-03-16  1:28             ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 11/30] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-03-09  2:34 ` [PATCH v6 12/30] PCI: Introduce pci_host_bridge_ops to support host specific operations Yijing Wang
2015-03-12  3:23   ` Bjorn Helgaas
2015-03-12 13:14     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 13/30] PCI: Introduce new scan function pci_scan_host_bridge() Yijing Wang
2015-03-12  3:25   ` Bjorn Helgaas
2015-03-12 13:15     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 14/30] x86/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-03-09  2:34 ` [PATCH v6 15/30] ia64/PCI: " Yijing Wang
2015-03-09  2:34 ` [PATCH v6 16/30] powerpc/pci: Rename pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 17/30] powerpc/pci: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 18/30] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 19/30] sparc/PCI: Claim bus resources before pci_bus_add_devices() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 20/30] sparc/PCI: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-12  3:30   ` Bjorn Helgaas
2015-03-12 13:17     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 21/30] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-03-12  3:33   ` Bjorn Helgaas
2015-03-12 13:24     ` Yijing Wang [this message]
2015-03-12  3:36   ` Bjorn Helgaas
2015-03-12 13:28     ` Yijing Wang
2015-03-12 20:00       ` Bjorn Helgaas
2015-03-09  2:34 ` [PATCH v6 22/30] parisc/PCI: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 23/30] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-03-09  2:34 ` [PATCH v6 24/30] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 25/30] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 26/30] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 27/30] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 28/30] PCI: Export find_pci_host_bridge() and rename to pci_find_host_bridge() Yijing Wang
2015-03-12  3:43   ` Bjorn Helgaas
2015-03-12 13:29     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 29/30] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 30/30] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-03-12  3:48   ` Bjorn Helgaas
2015-03-12 13:32     ` Yijing Wang
2015-03-12 21:23 ` [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Bjorn Helgaas
2015-03-13  3:29   ` Yijing Wang
2015-03-13 11:31   ` Liviu Dudau
2015-03-13 14:48     ` Bjorn Helgaas
2015-03-16  1:31       ` Yijing Wang
2015-03-16  1:48     ` Yijing Wang
2015-03-17 10:55       ` Liviu Dudau

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=550193A3.1020102@huawei.com \
    --to=wangyijing@huawei.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).