linux-arm-kernel.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: wangyijing@huawei.com (Yijing Wang)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v6 10/30] PCI: Introduce pci_host_bridge_list to manage host bridges
Date: Thu, 12 Mar 2015 21:03:12 +0800	[thread overview]
Message-ID: <55018E90.9030301@huawei.com> (raw)
In-Reply-To: <20150312025537.GD10949@google.com>

On 2015/3/12 10:55, Bjorn Helgaas wrote:
> On Mon, Mar 09, 2015 at 10:34:07AM +0800, Yijing Wang wrote:
>> Introduce pci_host_bridge_list to manage pci host
>> bridges in system, so we could detect whether
>> the host in domain:bus is alreay registered.
>> Then we could remove bus alreay exist test in
>> __pci_create_root_bus().
> 
> It's a nice idea to move this test into the core.  While you're at it, why
> don't you check for any overlap with the bus ranges of existing host
> bridges?  For example, if we're trying to create a new host bridge to
> [bus 40-7f], it should conflict with existing bridges to [bus 00-7f]
> as well as to [bus 40-ff].  I think your current patch will detect the
> latter conflict but not the former.

Now pci host bridge may only know its start bus number, like acpi _BBN provided,
but does not limit the end bus number, Eg. two pci roots report _BBN 0x0 and 0x80,
so we have two bus number resource (0, 0xff) and (0x80, 0xff), if we check it strictly,
some pci scan would fail which currently scan success.

> 
>> Signed-off-by: Yijing Wang <wangyijing@huawei.com>
>> Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
>> ---
>>  drivers/pci/host-bridge.c |   24 +++++++++++++++++++++++-
>>  drivers/pci/probe.c       |    8 +-------
>>  include/linux/pci.h       |    1 +
>>  3 files changed, 25 insertions(+), 8 deletions(-)
>>
>> diff --git a/drivers/pci/host-bridge.c b/drivers/pci/host-bridge.c
>> index 3bd45e7..0bb08ef 100644
>> --- a/drivers/pci/host-bridge.c
>> +++ b/drivers/pci/host-bridge.c
>> @@ -8,6 +8,9 @@
>>  
>>  #include "pci.h"
>>  
>> +static LIST_HEAD(pci_host_bridge_list);
>> +static DEFINE_MUTEX(phb_mutex);
> 
> We don't use the "phb" abbreviation in the PCI core.

OK

> 
>> +
>>  static void pci_release_host_bridge_dev(struct device *dev)
>>  {
>>  	struct pci_host_bridge *bridge = to_pci_host_bridge(dev);
>> @@ -25,7 +28,7 @@ struct pci_host_bridge *pci_create_host_bridge(
>>  	int error;
>>  	int bus = PCI_BUSNUM(db);
>>  	int domain = PCI_DOMAIN(db);
>> -	struct pci_host_bridge *host;
>> +	struct pci_host_bridge *host, *temp;
>>  	struct resource_entry *window, *n;
>>  
>>  	host = kzalloc(sizeof(*host), GFP_KERNEL);
>> @@ -40,6 +43,18 @@ struct pci_host_bridge *pci_create_host_bridge(
>>  	 */
>>  	pci_host_assign_domain_nr(host);
>>  
>> +	mutex_lock(&phb_mutex);
>> +	list_for_each_entry(temp, &pci_host_bridge_list, list)
>> +		if (temp->domain == host->domain
>> +				&& temp->busnum == host->busnum) {
>> +			dev_dbg(&host->dev, "pci host bridge pci%04x:%02x exist\n",
>> +					host->domain, host->busnum);
> 
> &host->dev hasn't been initialized yet!  And the text of the original
> message was better.

Oh, my mistake, good catch.

> 
>> +			mutex_unlock(&phb_mutex);
>> +			kfree(host);
>> +			return NULL;
>> +		}
>> +	mutex_unlock(&phb_mutex);
> 
> This is racy.  Two CPUs adding a bridge to [bus 00-7f] at about the same
> time can both succeed.
> 

Hmm, I need to unlock after I add the new host bridge to the gloal host bridge list, thanks.

> And it needs curly braces around the list_for_each_entry() body.

OK

> 
>> +
>>  	host->dev.parent = parent;
>>  	INIT_LIST_HEAD(&host->windows);
>>  	host->dev.release = pci_release_host_bridge_dev;
>> @@ -55,11 +70,18 @@ struct pci_host_bridge *pci_create_host_bridge(
>>  	resource_list_for_each_entry_safe(window, n, resources)
>>  		list_move_tail(&window->node, &host->windows);
>>  
>> +	mutex_lock(&phb_mutex);
>> +	list_add_tail(&host->list, &pci_host_bridge_list);
>> +	mutex_unlock(&phb_mutex);
>>  	return host;
>>  }
>>  
>>  void pci_free_host_bridge(struct pci_host_bridge *host)
>>  {
>> +	mutex_lock(&phb_mutex);
>> +	list_del(&host->list);
>> +	mutex_unlock(&phb_mutex);
>> +
>>  	device_unregister(&host->dev);
>>  }
>>  
>> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
>> index 27ec612..7238fa3 100644
>> --- a/drivers/pci/probe.c
>> +++ b/drivers/pci/probe.c
>> @@ -1870,7 +1870,7 @@ static struct pci_bus *__pci_create_root_bus(
>>  		void *sysdata)
>>  {
>>  	int error;
>> -	struct pci_bus *b, *b2;
>> +	struct pci_bus *b;
>>  	struct resource_entry *window;
>>  	struct device *parent;
>>  	struct resource *res;
>> @@ -1887,12 +1887,6 @@ static struct pci_bus *__pci_create_root_bus(
>>  	b->ops = ops;
>>  	b->number = b->busn_res.start = bridge->busnum;
>>  	pci_bus_assign_domain_nr(b, parent);
>> -	b2 = pci_find_bus(pci_domain_nr(b), b->number);
>> -	if (b2) {
>> -		/* If we already got to this bus through a different bridge, ignore it */
>> -		dev_dbg(&b2->dev, "bus already known\n");
>> -		goto err_out;
>> -	}
>>  
>>  	bridge->bus = b;
>>  	b->bridge = get_device(&bridge->dev);
>> diff --git a/include/linux/pci.h b/include/linux/pci.h
>> index 463eaa3..b621f5b 100644
>> --- a/include/linux/pci.h
>> +++ b/include/linux/pci.h
>> @@ -406,6 +406,7 @@ struct pci_host_bridge {
>>  	struct device dev;
>>  	struct pci_bus *bus;		/* root bus */
>>  	struct list_head windows;	/* resource_entry */
>> +	struct list_head list;
>>  	void (*release_fn)(struct pci_host_bridge *);
>>  	void *release_data;
>>  };
>> -- 
>> 1.7.1
>>
> 
> .
> 


-- 
Thanks!
Yijing

  reply	other threads:[~2015-03-12 13:03 UTC|newest]

Thread overview: 87+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-09  2:33 [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Yijing Wang
2015-03-09  2:33 ` [PATCH v6 01/30] PCI: Rip out pci_bus_add_devices() from pci_scan_bus() Yijing Wang
2015-03-09  2:33 ` [PATCH v6 02/30] PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 03/30] PCI: Export busn_resource to drivers/pci Yijing Wang
2015-03-11 22:28   ` Bjorn Helgaas
2015-03-12 11:42     ` Yijing Wang
2015-03-12 19:32       ` Bjorn Helgaas
2015-03-13  1:57         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 04/30] xen/PCI: Don't use deprecated function pci_scan_bus_parented() Yijing Wang
2015-03-11 22:32   ` Bjorn Helgaas
2015-03-12 11:46     ` Yijing Wang
2015-03-12 19:35       ` Bjorn Helgaas
2015-03-13  2:36         ` Yijing Wang
2015-03-13 13:24           ` Bjorn Helgaas
2015-03-13 14:01             ` Konrad Rzeszutek Wilk
2015-03-13 14:26               ` Bjorn Helgaas
2015-03-25 19:23                 ` Konrad Rzeszutek Wilk
2015-03-26  1:18                   ` Yijing Wang
2015-03-26  7:30                   ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 05/30] PCI: Remove deprecated pci_scan_bus_parented() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 06/30] PCI: Combine PCI domain and bus number in u32 arg Yijing Wang
2015-03-12  1:29   ` Bjorn Helgaas
2015-03-12 12:14     ` Yijing Wang
2015-03-12 19:49       ` Bjorn Helgaas
2015-03-13  3:19         ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 07/30] PCI: Pass PCI domain number combined with root bus number Yijing Wang
2015-03-12  1:34   ` Bjorn Helgaas
2015-03-12 12:20     ` Yijing Wang
2015-03-17  5:15   ` [Xen-devel] " Manish Jaggi
2015-03-17 14:05     ` Ian Campbell
2015-03-09  2:34 ` [PATCH v6 08/30] PCI: Introduce pci_host_assign_domain_nr() to assign domain Yijing Wang
2015-03-12  1:39   ` Bjorn Helgaas
2015-03-12 12:23     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 09/30] PCI: Separate pci_host_bridge creation out of pci_create_root_bus() Yijing Wang
2015-03-12  3:52   ` Bjorn Helgaas
2015-03-12 13:44     ` Yijing Wang
2015-03-21 23:21   ` Suravee Suthikulpanit
2015-03-23  1:08     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 10/30] PCI: Introduce pci_host_bridge_list to manage host bridges Yijing Wang
2015-03-12  2:55   ` Bjorn Helgaas
2015-03-12 13:03     ` Yijing Wang [this message]
2015-03-12 19:56       ` Bjorn Helgaas
2015-03-13  3:28         ` Yijing Wang
2015-03-13 14:33           ` Bjorn Helgaas
2015-03-16  1:28             ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 11/30] PCI: Save sysdata in pci_host_bridge drvdata Yijing Wang
2015-03-09  2:34 ` [PATCH v6 12/30] PCI: Introduce pci_host_bridge_ops to support host specific operations Yijing Wang
2015-03-12  3:23   ` Bjorn Helgaas
2015-03-12 13:14     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 13/30] PCI: Introduce new scan function pci_scan_host_bridge() Yijing Wang
2015-03-12  3:25   ` Bjorn Helgaas
2015-03-12 13:15     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 14/30] x86/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge Yijing Wang
2015-03-09  2:34 ` [PATCH v6 15/30] ia64/PCI: " Yijing Wang
2015-03-09  2:34 ` [PATCH v6 16/30] powerpc/pci: Rename pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 17/30] powerpc/pci: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 18/30] PCI: Remove weak pcibios_root_bridge_prepare() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 19/30] sparc/PCI: Claim bus resources before pci_bus_add_devices() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 20/30] sparc/PCI: Use pci_scan_host_bridge() for simplicity Yijing Wang
2015-03-12  3:30   ` Bjorn Helgaas
2015-03-12 13:17     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 21/30] PCI: Introduce pci_bus_child_max_busnr() Yijing Wang
2015-03-12  3:33   ` Bjorn Helgaas
2015-03-12 13:24     ` Yijing Wang
2015-03-12  3:36   ` Bjorn Helgaas
2015-03-12 13:28     ` Yijing Wang
2015-03-12 20:00       ` Bjorn Helgaas
2015-03-09  2:34 ` [PATCH v6 22/30] parisc/PCI: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 23/30] PCI/mvebu: Use pci_common_init_dev() to simplify code Yijing Wang
2015-03-09  2:34 ` [PATCH v6 24/30] PCI/tegra: Remove redundant tegra_pcie_scan_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 25/30] PCI/designware: Use pci_scan_root_bus() for simplicity Yijing Wang
2015-03-09  2:34 ` [PATCH v6 26/30] PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 27/30] PCI: Rename __pci_create_root_bus() to pci_create_root_bus() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 28/30] PCI: Export find_pci_host_bridge() and rename to pci_find_host_bridge() Yijing Wang
2015-03-12  3:43   ` Bjorn Helgaas
2015-03-12 13:29     ` Yijing Wang
2015-03-09  2:34 ` [PATCH v6 29/30] PCI: Remove platform specific pci_domain_nr() Yijing Wang
2015-03-09  2:34 ` [PATCH v6 30/30] PCI: Remove pci_bus_assign_domain_nr() Yijing Wang
2015-03-12  3:48   ` Bjorn Helgaas
2015-03-12 13:32     ` Yijing Wang
2015-03-12 21:23 ` [PATCH v6 00/30] Refine PCI scan interfaces and make generic pci host bridge Bjorn Helgaas
2015-03-13  3:29   ` Yijing Wang
2015-03-13 11:31   ` Liviu Dudau
2015-03-13 14:48     ` Bjorn Helgaas
2015-03-16  1:31       ` Yijing Wang
2015-03-16  1:48     ` Yijing Wang
2015-03-17 10:55       ` Liviu Dudau

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=55018E90.9030301@huawei.com \
    --to=wangyijing@huawei.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).