QEMU-Devel Archive on lore.kernel.org
 help / color / Atom feed
* [Qemu-devel] [Bug 1404278] [NEW] tap connections not working on windows host
@ 2014-12-19 15:36 timsoft
  2014-12-19 21:09 ` [Qemu-devel] [Bug 1404278] " timsoft
                   ` (19 more replies)
  0 siblings, 20 replies; 26+ messages in thread
From: timsoft @ 2014-12-19 15:36 UTC (permalink / raw)
  To: qemu-devel

Public bug reported:

using latest qemu 2.2.0 64bit for windows host (installed from
qemu-w64-setup-20141210.exe obtained from http://qemu.weilnetz.de/w64/
),OpenVPN 2.6.3-I601 64bit tap adapter named tap01 and calling qemu
using the following.

qemu-system-x86_64.exe -m 512 -net nic -net tap,ifname=tap01 -hda
"c:\\data\\images\\test.img"

where the image contains a slackware 14.0 64bit install.
The tap is bridged with the real network adapter and the bridge is given an ip of 10.1.1.41 (which works as the ip for the windows host). The tap adapter (in network connections) shows connected when the qemu vm is running. inside the vm, the network is given an ip of 10.1.1.143 (the netmask and default gateway are the same for the virtual and real pc).
fault.
The vm cannot see the rest of the local network or visa-versa. This used to work in early (0.9 32bit) versions of qemu.

** Affects: qemu
     Importance: Undecided
         Status: New


** Tags: 64bit tap windows

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1404278

Title:
  tap connections not working on windows host

Status in QEMU:
  New

Bug description:
  using latest qemu 2.2.0 64bit for windows host (installed from
  qemu-w64-setup-20141210.exe obtained from http://qemu.weilnetz.de/w64/
  ),OpenVPN 2.6.3-I601 64bit tap adapter named tap01 and calling qemu
  using the following.

  qemu-system-x86_64.exe -m 512 -net nic -net tap,ifname=tap01 -hda
  "c:\\data\\images\\test.img"

  where the image contains a slackware 14.0 64bit install.
  The tap is bridged with the real network adapter and the bridge is given an ip of 10.1.1.41 (which works as the ip for the windows host). The tap adapter (in network connections) shows connected when the qemu vm is running. inside the vm, the network is given an ip of 10.1.1.143 (the netmask and default gateway are the same for the virtual and real pc).
  fault.
  The vm cannot see the rest of the local network or visa-versa. This used to work in early (0.9 32bit) versions of qemu.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1404278/+subscriptions

^ permalink raw reply	[flat|nested] 26+ messages in thread

end of thread, back to index

Thread overview: 26+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-12-19 15:36 [Qemu-devel] [Bug 1404278] [NEW] tap connections not working on windows host timsoft
2014-12-19 21:09 ` [Qemu-devel] [Bug 1404278] " timsoft
2015-01-02 13:38 ` [Qemu-devel] [Bug 1404278] [NEW] " Stefan Hajnoczi
2015-01-05 17:11 ` [Qemu-devel] [Bug 1404278] " timsoft
2015-01-06 11:47   ` Stefan Hajnoczi
2015-01-06 21:12 ` timsoft
2015-01-07  9:06   ` Stefan Hajnoczi
2015-01-06 21:30 ` timsoft
2015-01-07 12:51   ` Stefan Hajnoczi
2015-01-07 16:09 ` timsoft
2015-03-24 11:10   ` Stefan Hajnoczi
2015-01-12  3:02 ` Tommy
2015-01-21 21:16 ` neil prideaux
2015-02-07 23:48 ` James J Myers
2018-05-22 13:33 ` Thomas Huth
2018-05-29 14:38   ` timsoft
2018-05-31  7:44 ` timsoft
2018-05-31  7:49 ` timsoft
2018-05-31 11:41 ` Thomas Huth
2018-05-31 11:42 ` Thomas Huth
2018-09-10 15:59 ` Jan Marti
2018-09-10 16:07 ` Jan Marti
2018-09-10 16:54 ` Jan Marti
2018-09-10 17:57 ` Jan Marti
2018-09-11  8:48 ` timsoft
2020-08-02 15:59 ` hakan

QEMU-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/qemu-devel/0 qemu-devel/git/0.git
	git clone --mirror https://lore.kernel.org/qemu-devel/1 qemu-devel/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 qemu-devel qemu-devel/ https://lore.kernel.org/qemu-devel \
		qemu-devel@nongnu.org
	public-inbox-index qemu-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.nongnu.qemu-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git