All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v3 0/7] xen: Hardware domain support
@ 2014-03-27 11:52 Daniel De Graaf
  2014-03-27 11:52 ` [PATCH 1/7] xen: use domid check in is_hardware_domain Daniel De Graaf
                   ` (7 more replies)
  0 siblings, 8 replies; 25+ messages in thread
From: Daniel De Graaf @ 2014-03-27 11:52 UTC (permalink / raw)
  To: xen-devel; +Cc: dgdegra

This adds support to the hypervisor for the creation of a hardware
domain distinct from domain 0, allowing further disaggregation of the
duties of domain 0.  The commit message for patch 1 contains a more
complete description of the distinction between the hardware domain and
control domain(s).  Making the hardware domain distinct from domain 0
allows it to be further de-privileged using an XSM policy: the hardware
domain does not need to be permitted access to create or modify other
domains in order to act as a device backend for them.

Changes since v2:
 - Rename and move CONFIG_LATE_HWDOM declaration to asm-x86/config.h
 - Move alloc_dom0_vcpu0 prototype change from patch 5 to 4
 - Also rename nmi_{dom0 => hwdom}_report
 - Add help/documentation for xl destroy -f

Changes since v1:
 - More complete conversion to is_hardware_domain (convert "== dom0")
 - Rename "dom0" global variable and associated functions
 - Avoid locating the hardware_domid variable in x86-only code
 - Require using "xl destroy -f 0" to destroy domain 0 to retain the
   existing guard against accidental attempts to destroy domain 0 that
   will still cause disruption of the platform.
 - Add an XSM permission check so that the security label of the
   hardware domain can be limited by the policy.
 - Rebase against updated xen/staging

[PATCH 1/7] xen: use domid check in is_hardware_domain
[PATCH 2/7] xen/iommu: Move dom0 setup to __hwdom_init
[PATCH 3/7] xen: prevent 0 from being used as a dynamic domid
[PATCH 4/7] xen: rename dom0 to hardware_domain
[PATCH 5/7] xen: rename various functions referencing dom0
[PATCH 6/7] xen: Allow hardare domain != dom0
[PATCH 7/7] tools/libxl: Allow dom0 to be destroyed

^ permalink raw reply	[flat|nested] 25+ messages in thread
* [PATCH v2 0/7] xen: Hardware domain support
@ 2014-03-18 21:34 Daniel De Graaf
  2014-03-18 21:34 ` [PATCH 3/7] xen: prevent 0 from being used as a dynamic domid Daniel De Graaf
  0 siblings, 1 reply; 25+ messages in thread
From: Daniel De Graaf @ 2014-03-18 21:34 UTC (permalink / raw)
  To: xen-devel

This adds support to the hypervisor for the creation of a hardware
domain distinct from domain 0, allowing further disaggregation of the
duties of domain 0.  The commit message for patch 1 contains a more
complete description of the distinction between the hardware domain and
control domain(s).  Making the hardware domain distinct from domain 0
allows it to be further de-privileged using an XSM policy: the hardware
domain does not need to be permitted access to create or modify other
domains in order to act as a device backend for them.

Changes since v1:
 - More complete conversion to is_hardware_domain (convert "== dom0")
 - Rename "dom0" global variable and associated functions
 - Avoid locating the hardware_domid variable in x86-only code
 - Require using "xl destroy -f 0" to destroy domain 0 to retain the
   existing guard against accidental attempts to destroy domain 0 that
   will still cause disruption of the platform.
 - Add an XSM permission check so that the security label of the
   hardware domain can be limited by the policy.
 - Rebase against updated xen/staging

[PATCH 1/7] xen: use domid check in is_hardware_domain
[PATCH 2/7] xen/iommu: Move dom0 setup to __hwdom_init
[PATCH 3/7] xen: prevent 0 from being used as a dynamic domid
[PATCH 4/7] xen: rename dom0 to hardware_domain
[PATCH 5/7] xen: rename various functions referencing dom0
[PATCH 6/7] xen: Allow hardare domain != dom0
[PATCH 7/7] tools/libxl: Allow dom0 to be destroyed

^ permalink raw reply	[flat|nested] 25+ messages in thread

end of thread, other threads:[~2014-04-14 20:12 UTC | newest]

Thread overview: 25+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-03-27 11:52 [PATCH v3 0/7] xen: Hardware domain support Daniel De Graaf
2014-03-27 11:52 ` [PATCH 1/7] xen: use domid check in is_hardware_domain Daniel De Graaf
2014-03-27 15:31   ` Ian Campbell
2014-03-27 11:52 ` [PATCH 2/7] xen/iommu: Move dom0 setup code to __hwdom_init Daniel De Graaf
2014-03-27 11:52 ` [PATCH 3/7] xen: prevent 0 from being used as a dynamic domid Daniel De Graaf
2014-03-27 11:52 ` [PATCH 4/7] xen: rename dom0 to hardware_domain Daniel De Graaf
2014-03-27 12:20   ` Egger, Christoph
2014-03-27 12:48     ` Daniel De Graaf
2014-03-27 15:46       ` Egger, Christoph
2014-03-27 15:33   ` Ian Campbell
2014-03-27 11:52 ` [PATCH 5/7] xen: rename various functions referencing dom0 Daniel De Graaf
2014-03-27 15:34   ` Ian Campbell
2014-03-27 15:47     ` Daniel De Graaf
2014-03-27 11:52 ` [PATCH 6/7] xen: Allow hardare domain != dom0 Daniel De Graaf
2014-04-11  9:13   ` Jan Beulich
2014-04-11 15:07     ` Daniel De Graaf
2014-04-11 15:20       ` Jan Beulich
2014-04-11 18:22         ` Daniel De Graaf
2014-04-14  7:56           ` Jan Beulich
2014-04-14 20:12             ` Daniel De Graaf
2014-03-27 11:52 ` [PATCH 7/7] tools/libxl: Allow dom0 to be destroyed Daniel De Graaf
2014-03-27 15:35   ` Ian Campbell
2014-04-02 15:08     ` Ian Jackson
2014-04-10 15:58 ` [PATCH v3 0/7] xen: Hardware domain support Keir Fraser
  -- strict thread matches above, loose matches on Subject: below --
2014-03-18 21:34 [PATCH v2 " Daniel De Graaf
2014-03-18 21:34 ` [PATCH 3/7] xen: prevent 0 from being used as a dynamic domid Daniel De Graaf

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.