All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Rutland <mark.rutland-5wv7dgnIgG8@public.gmane.org>
To: fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org
Cc: rjw-LthD3rsA81gm4RdzfppkhA@public.gmane.org,
	lenb-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org,
	daniel.lezcano-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	tglx-hfZtesqFncYOwBW4kG4KsQ@public.gmane.org,
	marc.zyngier-5wv7dgnIgG8@public.gmane.org,
	lorenzo.pieralisi-5wv7dgnIgG8@public.gmane.org,
	sudeep.holla-5wv7dgnIgG8@public.gmane.org,
	hanjun.guo-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org,
	linaro-acpi-cunTk1MwBs8s++Sfvej+rw@public.gmane.org,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	linux-acpi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	rruigrok-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org,
	harba-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org,
	cov-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org,
	timur-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org,
	graeme.gregory-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	al.stone-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	jcm-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org,
	wei-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org,
	arnd-r2nGTMty4D4@public.gmane.org,
	catalin.marinas-5wv7dgnIgG8@public.gmane.org,
	will.deacon-5wv7dgnIgG8@public.gmane.org,
	Suravee.Suthikulpanit-5C7GfCeVMHo@public.gmane.org,
	leo.duran-5C7GfCeVMHo@public.gmane.org,
	wim-IQzOog9fTRqzQB+pC5nmwQ@public.gmane.org,
	linux-0h96xk9xTtrk1uMJSBkQmQ@public.gmane.org,
	linux-watchdog-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	tn-nYOzD4b6Jr9Wk0Htik3J/w@public.gmane.org,
	christoffer.dall-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org,
	julien.grall-5wv7dgnIgG8@public.gmane.org
Subject: Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file
Date: Thu, 20 Oct 2016 15:45:39 +0100	[thread overview]
Message-ID: <20161020144510.GJ10234@leverpostej> (raw)
In-Reply-To: <1475086637-1914-2-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>

Hi,

On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org wrote:
> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
> index caedb74..6f06481 100644
> --- a/include/clocksource/arm_arch_timer.h
> +++ b/include/clocksource/arm_arch_timer.h
> @@ -19,6 +19,9 @@

Please add:

#include <linux/bitops.h>

... immediately before the includes below; it's needed to ensure that
BIT() is defined in all cases. Previously we were relying on implicit
header includes, which is not good practice.

>  #include <linux/timecounter.h>
>  #include <linux/types.h>
>  
> +#define ARCH_CP15_TIMER			BIT(0)
> +#define ARCH_MEM_TIMER			BIT(1)

If we're going to expose these in a header, it would be better to rename
them to something that makes their usage/meaning clear. These should
probably be ARCH_TIMER_TYPE_{CP15,MEM}.

I guess this can wait for subsequent cleanup.

> +enum ppi_nr {
> +	PHYS_SECURE_PPI,
> +	PHYS_NONSECURE_PPI,
> +	VIRT_PPI,
> +	HYP_PPI,
> +	MAX_TIMER_PPI
> +};

Please rename this to arch_timer_ppi_nr (updating the single user in 
drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for
name clashes in files this happens to get included in (potentially
transitively via other headers).

With those changes (regardless of the ARCH_TIMER_TYPE_* bits):

Acked-by: Mark Rutland <mark.rutland-5wv7dgnIgG8@public.gmane.org>

Thanks,
Mark.

> +
>  #define ARCH_TIMER_PHYS_ACCESS		0
>  #define ARCH_TIMER_VIRT_ACCESS		1
>  #define ARCH_TIMER_MEM_PHYS_ACCESS	2
> -- 
> 2.7.4
> 
--
To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

WARNING: multiple messages have this Message-ID (diff)
From: Mark Rutland <mark.rutland@arm.com>
To: fu.wei@linaro.org
Cc: rjw@rjwysocki.net, lenb@kernel.org, daniel.lezcano@linaro.org,
	tglx@linutronix.de, marc.zyngier@arm.com,
	lorenzo.pieralisi@arm.com, sudeep.holla@arm.com,
	hanjun.guo@linaro.org, linux-arm-kernel@lists.infradead.org,
	linaro-acpi@lists.linaro.org, linux-kernel@vger.kernel.org,
	linux-acpi@vger.kernel.org, rruigrok@codeaurora.org,
	harba@codeaurora.org, cov@codeaurora.org, timur@codeaurora.org,
	graeme.gregory@linaro.org, al.stone@linaro.org, jcm@redhat.com,
	wei@redhat.com, arnd@arndb.de, catalin.marinas@arm.com,
	will.deacon@arm.com, Suravee.Suthikulpanit@amd.com,
	leo.duran@amd.com, wim@iguana.be, linux@roeck-us.net,
	linux-watchdog@vger.kernel.org, tn@semihalf.com,
	christoffer.dall@linaro.org, julien.grall@arm.com
Subject: Re: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file
Date: Thu, 20 Oct 2016 15:45:39 +0100	[thread overview]
Message-ID: <20161020144510.GJ10234@leverpostej> (raw)
In-Reply-To: <1475086637-1914-2-git-send-email-fu.wei@linaro.org>

Hi,

On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei@linaro.org wrote:
> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
> index caedb74..6f06481 100644
> --- a/include/clocksource/arm_arch_timer.h
> +++ b/include/clocksource/arm_arch_timer.h
> @@ -19,6 +19,9 @@

Please add:

#include <linux/bitops.h>

... immediately before the includes below; it's needed to ensure that
BIT() is defined in all cases. Previously we were relying on implicit
header includes, which is not good practice.

>  #include <linux/timecounter.h>
>  #include <linux/types.h>
>  
> +#define ARCH_CP15_TIMER			BIT(0)
> +#define ARCH_MEM_TIMER			BIT(1)

If we're going to expose these in a header, it would be better to rename
them to something that makes their usage/meaning clear. These should
probably be ARCH_TIMER_TYPE_{CP15,MEM}.

I guess this can wait for subsequent cleanup.

> +enum ppi_nr {
> +	PHYS_SECURE_PPI,
> +	PHYS_NONSECURE_PPI,
> +	VIRT_PPI,
> +	HYP_PPI,
> +	MAX_TIMER_PPI
> +};

Please rename this to arch_timer_ppi_nr (updating the single user in 
drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for
name clashes in files this happens to get included in (potentially
transitively via other headers).

With those changes (regardless of the ARCH_TIMER_TYPE_* bits):

Acked-by: Mark Rutland <mark.rutland@arm.com>

Thanks,
Mark.

> +
>  #define ARCH_TIMER_PHYS_ACCESS		0
>  #define ARCH_TIMER_VIRT_ACCESS		1
>  #define ARCH_TIMER_MEM_PHYS_ACCESS	2
> -- 
> 2.7.4
> 

WARNING: multiple messages have this Message-ID (diff)
From: mark.rutland@arm.com (Mark Rutland)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file
Date: Thu, 20 Oct 2016 15:45:39 +0100	[thread overview]
Message-ID: <20161020144510.GJ10234@leverpostej> (raw)
In-Reply-To: <1475086637-1914-2-git-send-email-fu.wei@linaro.org>

Hi,

On Thu, Sep 29, 2016 at 02:17:09AM +0800, fu.wei at linaro.org wrote:
> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
> index caedb74..6f06481 100644
> --- a/include/clocksource/arm_arch_timer.h
> +++ b/include/clocksource/arm_arch_timer.h
> @@ -19,6 +19,9 @@

Please add:

#include <linux/bitops.h>

... immediately before the includes below; it's needed to ensure that
BIT() is defined in all cases. Previously we were relying on implicit
header includes, which is not good practice.

>  #include <linux/timecounter.h>
>  #include <linux/types.h>
>  
> +#define ARCH_CP15_TIMER			BIT(0)
> +#define ARCH_MEM_TIMER			BIT(1)

If we're going to expose these in a header, it would be better to rename
them to something that makes their usage/meaning clear. These should
probably be ARCH_TIMER_TYPE_{CP15,MEM}.

I guess this can wait for subsequent cleanup.

> +enum ppi_nr {
> +	PHYS_SECURE_PPI,
> +	PHYS_NONSECURE_PPI,
> +	VIRT_PPI,
> +	HYP_PPI,
> +	MAX_TIMER_PPI
> +};

Please rename this to arch_timer_ppi_nr (updating the single user in 
drivers/clocksource/arm_arch_timer.c). That'll avoid the potential for
name clashes in files this happens to get included in (potentially
transitively via other headers).

With those changes (regardless of the ARCH_TIMER_TYPE_* bits):

Acked-by: Mark Rutland <mark.rutland@arm.com>

Thanks,
Mark.

> +
>  #define ARCH_TIMER_PHYS_ACCESS		0
>  #define ARCH_TIMER_VIRT_ACCESS		1
>  #define ARCH_TIMER_MEM_PHYS_ACCESS	2
> -- 
> 2.7.4
> 

  parent reply	other threads:[~2016-10-20 14:45 UTC|newest]

Thread overview: 115+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-09-28 18:17 [PATCH v14 0/9] acpi, clocksource: add GTDT driver and GTDT support in arm_arch_timer fu.wei
2016-09-28 18:17 ` fu.wei at linaro.org
2016-09-28 18:17 ` [PATCH v14 1/9] clocksource/drivers/arm_arch_timer: Move enums and defines to header file fu.wei
2016-09-28 18:17   ` fu.wei at linaro.org
2016-09-28 18:17   ` fu.wei
     [not found]   ` <1475086637-1914-2-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2016-10-20 14:45     ` Mark Rutland [this message]
2016-10-20 14:45       ` Mark Rutland
2016-10-20 14:45       ` Mark Rutland
2016-10-26  8:31       ` Fu Wei
2016-10-26  8:31         ` Fu Wei
2016-10-26  8:31         ` Fu Wei
2016-10-26 10:51         ` Mark Rutland
2016-10-26 10:51           ` Mark Rutland
2016-10-26 10:51           ` Mark Rutland
2016-10-26 10:54           ` Fu Wei
2016-10-26 10:54             ` Fu Wei
2016-10-26 10:54             ` Fu Wei
2016-09-28 18:17 ` [PATCH v14 3/9] clocksource/drivers/arm_arch_timer: Improve printk relevant code fu.wei
2016-09-28 18:17   ` fu.wei at linaro.org
2016-10-20 15:32   ` Mark Rutland
2016-10-20 15:32     ` Mark Rutland
2016-10-26  8:28     ` Fu Wei
2016-10-26  8:28       ` Fu Wei
2016-10-26  8:28       ` Fu Wei
     [not found] ` <1475086637-1914-1-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2016-09-28 18:17   ` [PATCH v14 2/9] clocksource/drivers/arm_arch_timer: Add a new enum for spi type fu.wei-QSEj5FYQhm4dnm+yROfE0A
2016-09-28 18:17     ` fu.wei at linaro.org
2016-09-28 18:17     ` fu.wei
     [not found]     ` <1475086637-1914-3-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2016-10-20 15:09       ` Mark Rutland
2016-10-20 15:09         ` Mark Rutland
2016-10-20 15:09         ` Mark Rutland
2016-10-26  8:26         ` Fu Wei
2016-10-26  8:26           ` Fu Wei
2016-10-26  8:26           ` Fu Wei
2016-09-28 18:17   ` [PATCH v14 4/9] acpi/arm64: Add GTDT table parse driver fu.wei-QSEj5FYQhm4dnm+yROfE0A
2016-09-28 18:17     ` fu.wei at linaro.org
2016-09-28 18:17     ` fu.wei
     [not found]     ` <1475086637-1914-5-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2016-10-20 16:37       ` Mark Rutland
2016-10-20 16:37         ` Mark Rutland
2016-10-20 16:37         ` Mark Rutland
2016-10-26 11:10         ` Fu Wei
2016-10-26 11:10           ` Fu Wei
2016-10-26 11:10           ` Fu Wei
2016-10-26 12:11           ` Marc Zyngier
2016-10-26 12:11             ` Marc Zyngier
2016-10-26 12:11             ` Marc Zyngier
2016-10-26 13:41             ` Fu Wei
2016-10-26 13:41               ` Fu Wei
2016-10-26 13:41               ` Fu Wei
2016-11-11 13:43           ` Hanjun Guo
2016-11-11 13:43             ` Hanjun Guo
2016-11-11 13:43             ` Hanjun Guo
2016-11-11 13:46         ` Hanjun Guo
2016-11-11 13:46           ` Hanjun Guo
2016-11-11 13:58           ` Hanjun Guo
2016-11-11 13:58             ` Hanjun Guo
2016-11-11 15:32           ` Mark Rutland
2016-11-11 15:32             ` Mark Rutland
2016-09-28 18:17   ` [PATCH v14 6/9] acpi/arm64: Add memory-mapped timer support in GTDT driver fu.wei-QSEj5FYQhm4dnm+yROfE0A
2016-09-28 18:17     ` fu.wei at linaro.org
2016-09-28 18:17     ` fu.wei
2016-10-21 11:19     ` Mark Rutland
2016-10-21 11:19       ` Mark Rutland
2016-09-28 18:17   ` [PATCH v14 9/9] acpi/arm64: Add SBSA Generic Watchdog " fu.wei-QSEj5FYQhm4dnm+yROfE0A
2016-09-28 18:17     ` fu.wei at linaro.org
2016-09-28 18:17     ` fu.wei
2016-10-20 14:31   ` [PATCH v14 0/9] acpi, clocksource: add GTDT driver and GTDT support in arm_arch_timer Mark Rutland
2016-10-20 14:31     ` Mark Rutland
2016-10-20 14:31     ` Mark Rutland
2016-10-20 14:57     ` Lorenzo Pieralisi
2016-10-20 14:57       ` Lorenzo Pieralisi
2016-10-20 15:17       ` Mark Rutland
2016-10-20 15:17         ` Mark Rutland
2016-10-20 15:17         ` Mark Rutland
2016-10-26  8:24         ` Fu Wei
2016-10-26  8:24           ` Fu Wei
2016-10-26  8:24           ` Fu Wei
2016-09-28 18:17 ` [PATCH v14 5/9] clocksource/drivers/arm_arch_timer: Simplify ACPI support code fu.wei
2016-09-28 18:17   ` fu.wei at linaro.org
     [not found]   ` <1475086637-1914-6-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2016-10-20 16:58     ` Mark Rutland
2016-10-20 16:58       ` Mark Rutland
2016-10-20 16:58       ` Mark Rutland
2016-10-21 11:14       ` Mark Rutland
2016-10-21 11:14         ` Mark Rutland
2016-10-21 11:14         ` Mark Rutland
2016-10-21 11:21         ` Mark Rutland
2016-10-21 11:21           ` Mark Rutland
2016-10-26  8:54           ` Fu Wei
2016-10-26  8:54             ` Fu Wei
2016-10-26  8:54             ` Fu Wei
2016-11-11 13:55           ` Hanjun Guo
2016-11-11 13:55             ` Hanjun Guo
2016-11-11 13:55             ` Hanjun Guo
2016-09-28 18:17 ` [PATCH v14 7/9] clocksource/drivers/arm_arch_timer: Refactor the timer init code to prepare for GTDT fu.wei
2016-09-28 18:17   ` fu.wei at linaro.org
     [not found]   ` <1475086637-1914-8-git-send-email-fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
2016-10-21 11:32     ` Mark Rutland
2016-10-21 11:32       ` Mark Rutland
2016-10-21 11:32       ` Mark Rutland
2016-10-26 15:24       ` Fu Wei
2016-10-26 15:24         ` Fu Wei
2016-10-26 15:24         ` Fu Wei
2016-10-26 15:46         ` Mark Rutland
2016-10-26 15:46           ` Mark Rutland
2016-10-26 15:46           ` Mark Rutland
2016-10-26 16:07           ` Fu Wei
2016-10-26 16:07             ` Fu Wei
2016-10-26 16:07             ` Fu Wei
2016-09-28 18:17 ` [PATCH v14 8/9] clocksource/drivers/arm_arch_timer: Add GTDT support for memory-mapped timer fu.wei
2016-09-28 18:17   ` fu.wei at linaro.org
2016-09-28 18:17   ` fu.wei
2016-09-30  0:40 ` [PATCH v14 0/9] acpi, clocksource: add GTDT driver and GTDT support in arm_arch_timer Xiongfeng Wang
2016-09-30  0:40   ` Xiongfeng Wang
2016-09-30  0:40   ` Xiongfeng Wang
2016-10-05 17:26   ` Fu Wei
2016-10-05 17:26     ` Fu Wei
2016-10-05 17:26     ` Fu Wei

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20161020144510.GJ10234@leverpostej \
    --to=mark.rutland-5wv7dgnigg8@public.gmane.org \
    --cc=Suravee.Suthikulpanit-5C7GfCeVMHo@public.gmane.org \
    --cc=al.stone-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org \
    --cc=arnd-r2nGTMty4D4@public.gmane.org \
    --cc=catalin.marinas-5wv7dgnIgG8@public.gmane.org \
    --cc=christoffer.dall-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org \
    --cc=cov-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org \
    --cc=daniel.lezcano-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org \
    --cc=fu.wei-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org \
    --cc=graeme.gregory-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org \
    --cc=hanjun.guo-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org \
    --cc=harba-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org \
    --cc=jcm-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org \
    --cc=julien.grall-5wv7dgnIgG8@public.gmane.org \
    --cc=lenb-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org \
    --cc=leo.duran-5C7GfCeVMHo@public.gmane.org \
    --cc=linaro-acpi-cunTk1MwBs8s++Sfvej+rw@public.gmane.org \
    --cc=linux-0h96xk9xTtrk1uMJSBkQmQ@public.gmane.org \
    --cc=linux-acpi-u79uwXL29TY76Z2rM5mHXA@public.gmane.org \
    --cc=linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org \
    --cc=linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org \
    --cc=linux-watchdog-u79uwXL29TY76Z2rM5mHXA@public.gmane.org \
    --cc=lorenzo.pieralisi-5wv7dgnIgG8@public.gmane.org \
    --cc=marc.zyngier-5wv7dgnIgG8@public.gmane.org \
    --cc=rjw-LthD3rsA81gm4RdzfppkhA@public.gmane.org \
    --cc=rruigrok-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org \
    --cc=sudeep.holla-5wv7dgnIgG8@public.gmane.org \
    --cc=tglx-hfZtesqFncYOwBW4kG4KsQ@public.gmane.org \
    --cc=timur-sgV2jX0FEOL9JmXXK+q4OQ@public.gmane.org \
    --cc=tn-nYOzD4b6Jr9Wk0Htik3J/w@public.gmane.org \
    --cc=wei-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org \
    --cc=will.deacon-5wv7dgnIgG8@public.gmane.org \
    --cc=wim-IQzOog9fTRqzQB+pC5nmwQ@public.gmane.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.