All of lore.kernel.org
 help / color / mirror / Atom feed
* [GIT PULL] New ab/i18n series and builtin fixes
@ 2010-09-03 18:22 Ævar Arnfjörð Bjarmason
  2010-09-03 23:24 ` [PATCH 0/3] ab/i18n: README and GETTEXT_POISON support Ævar Arnfjörð Bjarmason
                   ` (6 more replies)
  0 siblings, 7 replies; 30+ messages in thread
From: Ævar Arnfjörð Bjarmason @ 2010-09-03 18:22 UTC (permalink / raw)
  To: Git Mailing List, Junio C Hamano

This is a pull request for an updated ab/i18n and the builtin.h
changes. I can also send this to list on request, but it's 25 patches
for what are trivial merge changes and a doc patch.

I've rebased the ab/i18n series on top of master. Now it looks like
this:

    master
    \
     use-builtin-h-for-builtin-commands-v2
     \
      ab/i18n

The changes are:

use-builtin-h-for-builtin-commands-v2: (needed by the new ab/i18n
series, and a good idea in general)

 833c9cf builtin: use builtin.h for all builtin commands
 http://github.com/avar/git/commit/833c9cf

 git://github.com/avar/git.git use-builtin-h-for-builtin-commands-v2

  * I changed the "builtin: use builtin.h for all builtin commands"
    patch so that it adds builtin.h but only removes cache.h, not
    commit.h and notes.h.

ab/i18n: (new ab/i18n to replace the one in git.git)

 git://github.com/avar/git.git ab/i18n

 1c7584b gettext: Add po/README file documenting Git's gettext

This is new, a README file describing how to deal with the po/
directory. See http://github.com/avar/git/raw/ab/i18n/po/README

 aba2acf gettext tests: remove old sanity test under NO_GETTEXT
 340b167 gettext tests: test message re-encoding under C
 f072e35 po/pl.po: add Polish translation
 ea9736b po/is.po: add Icelandic translation
 a0dfa7e po/is.po: msgmerge and add Language: header
 6693d50 gettext tests: mark a test message as not needing translation
 9428b0a gettext tests: test re-encoding with a UTF-8 msgid under Shell
 b1d6c80 gettext tests: test message re-encoding under Shell
 e630ddd gettext tests: add detection for is_IS.ISO-8859-1 locale
 da615f4 gettext tests: update test/is.po to match t/t0200/test.c
 09c03ba gettext tests: test if $VERSION exists before using it
 56bed97 gettext.c: work around us not using setlocale(LC_CTYPE, "")
 c1c0d12 gettext: localize the main git-init message
 a0b47a5 gettext: make the simple parts of git-init localizable
 4a606ac builtin.h: Include gettext.h
 deb01cf Makefile: use variables and shorter lines for xgettext
 4ecebf5 Makefile: tell xgettext(1) that our source is in UTF-8
 3d9f454 Makefile: provide a --msgid-bugs-address to xgettext(1)
 29446ce Makefile: A variable for options used by xgettext(1) calls
 e25db7d tests: locate i18n lib&data correctly under --valgrind
 d3415a9 gettext: setlocale(LC_CTYPE, "") breaks Git's C function assumptions
 3e25bb6 tests: rename test to work around GNU gettext bug

This is all the same.

 760724f Add infrastructure for translating Git with gettext

Changed perl/Makefile so it doesn't conflict with the version now in
master (conflict because of "perl/Makefile: Unset INSTALL_BASE when
making perl.mak").

END PULL REQUEST.

What I'm working on, which should not be pulled at this time:

ab/i18n-gettextize:
http://github.com/avar/git/compare/ab/i18n...ab/i18n-gettextize

  Updated version of the gettextize series rebased on master. No
  longer needs its own builtin.h patches (since ab/i18n itself now
  depends on it). I'm also fixing some minor issues raised on-list.

  I'm also going to add the aforementioned GETTEXT_POISON
  functionality to ab/i18n to make sure this series is OK.

ab/i18n-add-translations:
http://github.com/avar/git/compare/ab/i18n-gettextize...ab/i18n-add-translations

  Adds German and British English translations. More additions welcome.

^ permalink raw reply	[flat|nested] 30+ messages in thread
* Re: [PATCH 1/2] po/de.po: add German translation
@ 2010-09-15  7:33 Christian Stimming
  2010-09-15  9:47 ` Thomas Rast
                   ` (3 more replies)
  0 siblings, 4 replies; 30+ messages in thread
From: Christian Stimming @ 2010-09-15  7:33 UTC (permalink / raw)
  To: trast, jk, avarab; +Cc: git

Dear Thomas, Jan, et al.,

thanks for the discussion of an initial git translation to German. I  
appreciate the efforts to translate not only the gui tools of git, but  
also the command line commands as well. I completely agree with  
Thomas' proposal to discuss and agree on a glossary of terms *first*,  
and *secondly* preparing the actual translation - otherwise it will be  
impossible to create a consistent translation.

As you might guess, as the (initial) translator of git-gui I've been  
through this discussion before [1] and as you have noticed, I have  
decided to take a translation approach different from what you have  
recently discussed here. I deliberately tried to translate as much of  
the terms into German as possible. I do not agree about the importance  
of statements on this mailing list like "This translation translates  
too much terms - I cannot find the commands I'm used to". The point of  
a translation is to enable the usage of a program to people who do  
*not* know the original language. This is the target audience. By  
definition, this excludes anyone who participates on *this* mailing  
list from the target audience: Obviously you not only speak English  
very well, but you are daily familiar with the English git wording for  
the concepts inside this VCS. Then let me repeat: A translation is not  
for you. You know, the bait and the fisherman and the fish and such.  
Instead, a translation is for people who do neither know nor  
understand the English wording for the git concepts. For this target  
audience, the goal is to find a set of terms for the different git  
concepts which makes the concepts most easily accessible for their  
language. This may or may not include terms which are left at English  
words.

Having said that, I would also take the following inspiration with a  
grain of salt:

> You said on IRC that you left all English terms that
> are also used on
> http://de.wikipedia.org/wiki/Versionskontrolle

Wikipedia is a bad reference for measuring the importance of certain  
things. I (or you) could have easily adapted that article to my point  
of view before continuing the discussion. However, in this particular  
case that article doesn't even mention many of the terms which need to  
be discussed in a git glossary.

Having said that as well, I admit the translation of the command line  
tools is somewhat more difficult than a GUI tool, because many of the  
git concepts appear as English words in the command itself. Hence, I  
admit it is much more difficult to decide on a non-English  
translation, but having to mention the English term all the time  
because that's the command which needs to be used. And for sure we  
won't want to translate the (main porcelain) command names. Hence, the  
decision on terms which are left in English can surely be decided  
differently here than in the GUI tools.

After this introduction, I would like to comment on a few of the  
proposed German glossary translations; the IMHO easier ones first:

>  branch                Branch (m.)

I'd go for "Zweig". It's even on the wikipedia page and it perfectly  
represents the concept.

>  index                 Index

I'd strongly vote for not using "Index". The "Index" is where the  
"Bundesprüfstelle für jugendgefährdende Schriften" puts the  
Ballerspiele on. Don't let the identical word fool you into thinking  
this is a worthwhile translation. Also, the English term is a bad  
naming anyway IMHO. I'd use git-gui's replacement (staging area) and  
use "Bereitstellung" here as well. Feel free to propose something  
different, but please not "Index". Git isn't FSK18.

>  commit (noun, verb)                Commit/committen

That's a hard one. It sounds terrible to use "committen" in German. I  
would strongly vote for not using this word directly, but I admit I  
also don't have a completely convincing alternative.

>  revision              Revision

Die "Revision" kommt ins Haus, um die Bücher zu prüfen. Honestly,  
please don't use that word in German. Why not "Version"?

>  tag                   Tag

Der heutige Tag oder der morgige Tag? What's the problem with  
"Markierung"? This is exactky the git concept which is meant.

>  tree                  Tree

I would not understand what the "Tree" in German should be. Any German  
word instead?

Many other of the proposals are just fine and very good. Keep up the  
good work!

Regards,

Christian Stimming


[1] http://article.gmane.org/gmane.comp.version-control.git/58315

^ permalink raw reply	[flat|nested] 30+ messages in thread

end of thread, other threads:[~2010-09-17  7:23 UTC | newest]

Thread overview: 30+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-09-03 18:22 [GIT PULL] New ab/i18n series and builtin fixes Ævar Arnfjörð Bjarmason
2010-09-03 23:24 ` [PATCH 0/3] ab/i18n: README and GETTEXT_POISON support Ævar Arnfjörð Bjarmason
2010-09-03 23:24 ` [PATCH 1/3] gettext: Add po/README file documenting Git's gettext Ævar Arnfjörð Bjarmason
2010-09-03 23:24 ` [PATCH 2/3] gettext: Add GETTEXT_POISON=YesPlease Makefile parameter Ævar Arnfjörð Bjarmason
2010-09-03 23:24 ` [PATCH 3/3] gettext: add NO_GETTEXT_POISON prerequisite to tests Ævar Arnfjörð Bjarmason
2010-09-03 23:41   ` Ævar Arnfjörð Bjarmason
2010-09-04  0:49 ` [PATCH 0/2] [PULL] ab/i18n-gettextize & translations avarab
2010-09-04  0:49 ` [PATCH 1/2] po/de.po: add German translation avarab
2010-09-06 15:41   ` Thomas Rast
2010-09-06 16:09     ` Jan Krüger
2010-09-06 17:06       ` Ævar Arnfjörð Bjarmason
2010-09-06 16:24     ` Jens Lehmann
2010-09-06 19:58       ` Tilo Schwarz
2010-09-06 17:15     ` Ævar Arnfjörð Bjarmason
2010-09-04  0:49 ` [PATCH 2/2] po/en_GB.po: add British English Translation avarab
2010-09-15  7:33 [PATCH 1/2] po/de.po: add German translation Christian Stimming
2010-09-15  9:47 ` Thomas Rast
2010-09-15 11:51   ` Michael J Gruber
2010-09-15 11:10 ` Michael J Gruber
2010-09-15 16:54   ` Andreas Schwab
2010-09-15 11:44 ` Thomas Hochstein
2010-09-16 10:57 ` Jan Krüger
2010-09-16 11:09   ` Ævar Arnfjörð Bjarmason
2010-09-16 11:29     ` Jens Lehmann
2010-09-16 11:51       ` Ævar Arnfjörð Bjarmason
2010-09-16 14:52       ` Junio C Hamano
2010-09-16 15:05         ` Jens Lehmann
2010-09-16 11:51   ` Michael J Gruber
2010-09-16 16:48     ` Jan Krüger
2010-09-17  7:23       ` Michael J Gruber

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.