dri-devel.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v1 00/35] drm: Analog TV Improvements
@ 2022-07-29 16:34 Maxime Ripard
  2022-07-29 16:34 ` [PATCH v1 01/35] drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity Maxime Ripard
                   ` (36 more replies)
  0 siblings, 37 replies; 151+ messages in thread
From: Maxime Ripard @ 2022-07-29 16:34 UTC (permalink / raw)
  To: Jernej Skrabec, Martin Blumenstingl, Chen-Yu Tsai, Philipp Zabel,
	Jerome Brunet, Samuel Holland, Thomas Zimmermann, Daniel Vetter,
	Emma Anholt, David Airlie, Maarten Lankhorst,
	Noralf Trønnes, Kevin Hilman, Neil Armstrong, Maxime Ripard
  Cc: Dom Cobley, Dave Stevenson, linux-kernel, dri-devel,
	Mateusz Kwiatkowski, Geert Uytterhoeven, Maxime Ripard,
	linux-amlogic, linux-sunxi, Phil Elwell, linux-arm-kernel

Hi,

Here's a series aiming at improving the command line named modes support,
and more importantly how we deal with all the analog TV variants.

The named modes support were initially introduced to allow to specify the
analog TV mode to be used.

However, this was causing multiple issues:

  * The mode name parsed on the command line was passed directly to the
    driver, which had to figure out which mode it was suppose to match;

  * Figuring that out wasn't really easy, since the video= argument or what
    the userspace might not even have a name in the first place, but
    instead could have passed a mode with the same timings;

  * The fallback to matching on the timings was mostly working as long as
    we were supporting one 525 lines (most likely NSTC) and one 625 lines
    (PAL), but couldn't differentiate between two modes with the same
    timings (NTSC vs PAL-M vs NSTC-J for example); 

  * There was also some overlap with the tv mode property registered by 
    drm_mode_create_tv_properties(), but named modes weren't interacting
    with that property at all.

  * Even though that property was generic, its possible values were
    specific to each drivers, which made some generic support difficult.

Thus, I chose to tackle in multiple steps:

  * A new TV norm property was introduced, with generic values, each driver
    reporting through a bitmask what standard it supports to the userspace;

  * This option was added to the command line parsing code to be able to
    specify it on the kernel command line, and new atomic_check and reset
    helpers were created to integrate properly into atomic KMS;

  * The named mode parsing code is now creating a proper display mode for
    the given named mode, and the TV standard will thus be part of the
    connector state;

  * Two drivers were converted and tested for now (vc4 and sun4i), with
    some backward compatibility code to translate the old TV mode to the
    new TV mode;

Unit tests were created along the way. Nouveau, ch7006 and gud are
currently broken for now since I expect that work to be reworked fairly
significantly. I'm also not entirely sure about how to migrate GUD to the
new property.

Let me know what you think,
Maxime

Cc: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: "Noralf Trønnes" <noralf@tronnes.org>
Cc: Dave Stevenson <dave.stevenson@raspberrypi.com>
Cc: Dom Cobley <dom@raspberrypi.com>
Cc: Phil Elwell <phil@raspberrypi.com>
Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Cc: Thomas Zimmermann <tzimmermann@suse.de>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: David Airlie <airlied@linux.ie>
Cc: <dri-devel@lists.freedesktop.org>
Signed-off-by: Maxime Ripard <maxime@cerno.tech>

---
Mateusz Kwiatkowski (5):
      drm/vc4: vec: Refactor VEC TV mode setting
      drm/vc4: vec: Remove redundant atomic_mode_set
      drm/vc4: vec: Fix timings for VEC modes
      drm/vc4: vec: Fix definition of PAL-M mode
      drm/vc4: vec: Add support for more analog TV standards

Maxime Ripard (30):
      drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity
      drm/connector: Rename subconnector state variable
      drm/atomic: Add TV subconnector property to get/set_property
      drm/modes: Introduce 480i and 576i modes
      drm/connector: Add TV standard property
      drm/connector: Only register TV mode property if present
      drm/modes: Only consider bpp and refresh before options
      drm/client: Add some tests for drm_connector_pick_cmdline_mode()
      drm/modes: Move named modes parsing to a separate function
      drm/modes: Switch to named mode descriptors
      drm/modes: Fill drm_cmdline mode from named modes
      drmi/modes: Properly generate a drm_display_mode from a named mode
      drm/atomic-helper: Add a TV properties reset helper
      drm/atomic-helper: Add an analog TV atomic_check implementation
      drm/vc4: vec: Remove empty mode_fixup
      drm/vc4: vec: Convert to atomic helpers
      drm/vc4: vec: Switch for common modes
      drm/vc4: vec: Use TV Reset implementation
      drm/vc4: vec: Convert to the new TV mode property
      drm/sun4i: tv: Remove unused mode_valid
      drm/sun4i: tv: Convert to atomic hooks
      drm/sun4i: tv: Merge mode_set into atomic_enable
      drm/sun4i: tv: Remove useless function
      drm/sun4i: tv: Remove useless destroy function
      drm/sun4i: tv: Rename error label
      drm/sun4i: tv: Add missing reset assertion
      drm/sun4i: tv: Convert to the new TV mode property
      drm/connector: Remove TV modes property
      drm/modes: Introduce the tv_mode property as a command-line option
      drm/modes: Introduce more named modes

 drivers/gpu/drm/drm_atomic_state_helper.c       | 166 +++++++++-
 drivers/gpu/drm/drm_atomic_uapi.c               |  12 +-
 drivers/gpu/drm/drm_client_modeset.c            |   4 +
 drivers/gpu/drm/drm_connector.c                 |  46 ++-
 drivers/gpu/drm/drm_modes.c                     | 198 +++++++++--
 drivers/gpu/drm/gud/gud_connector.c             |   2 +-
 drivers/gpu/drm/meson/meson_encoder_cvbs.c      |  18 +-
 drivers/gpu/drm/meson/meson_encoder_cvbs.h      |   2 +-
 drivers/gpu/drm/sun4i/sun4i_tv.c                | 173 +++-------
 drivers/gpu/drm/tests/drm_cmdline_parser_test.c | 295 +++++++++++++++++
 drivers/gpu/drm/tests/drm_mode_test.c           | 255 +++++++++++++++
 drivers/gpu/drm/vc4/vc4_hdmi.c                  |   2 +-
 drivers/gpu/drm/vc4/vc4_vec.c                   | 418 ++++++++++++++++--------
 include/drm/drm_atomic_state_helper.h           |   4 +
 include/drm/drm_connector.h                     |  40 ++-
 include/drm/drm_mode_config.h                   |   6 +
 include/drm/drm_modes.h                         |   3 +
 17 files changed, 1314 insertions(+), 330 deletions(-)
---
base-commit: 37b355fdaf31ee18bda9a93c2a438dc1cbf57ec9
change-id: 20220728-rpi-analog-tv-properties-0914dfcee460

Best regards,
-- 
Maxime Ripard <maxime@cerno.tech>

^ permalink raw reply	[flat|nested] 151+ messages in thread

end of thread, other threads:[~2022-08-30 21:31 UTC | newest]

Thread overview: 151+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-07-29 16:34 [PATCH v1 00/35] drm: Analog TV Improvements Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 01/35] drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity Maxime Ripard
2022-08-08 12:25   ` Noralf Trønnes
2022-07-29 16:34 ` [PATCH v1 02/35] drm/connector: Rename subconnector state variable Maxime Ripard
2022-08-08 12:26   ` Noralf Trønnes
2022-07-29 16:34 ` [PATCH v1 03/35] drm/atomic: Add TV subconnector property to get/set_property Maxime Ripard
2022-08-08 12:30   ` Noralf Trønnes
2022-08-15  7:35     ` Maxime Ripard
2022-08-15 10:48       ` Noralf Trønnes
2022-07-29 16:34 ` [PATCH v1 04/35] drm/modes: Introduce 480i and 576i modes Maxime Ripard
2022-08-02 13:58   ` Jani Nikula
2022-08-02 14:16     ` Thomas Zimmermann
2022-08-16 11:58       ` Maxime Ripard
2022-08-12 13:18   ` Geert Uytterhoeven
2022-08-16 13:26     ` Maxime Ripard
2022-08-16 15:00       ` Geert Uytterhoeven
2022-08-17  7:53         ` Maxime Ripard
2022-08-17  8:51           ` Geert Uytterhoeven
2022-08-17 13:14             ` Maxime Ripard
2022-08-17 14:01               ` Geert Uytterhoeven
2022-08-18 12:39                 ` Maxime Ripard
2022-08-18 12:57                   ` Geert Uytterhoeven
2022-08-18 13:42                     ` Maxime Ripard
2022-08-18 15:34                       ` Geert Uytterhoeven
2022-08-18 15:46                         ` Maxime Ripard
2022-08-18 15:56                           ` Geert Uytterhoeven
2022-08-24 16:42                             ` Mateusz Kwiatkowski
2022-08-29 13:29                               ` Maxime Ripard
2022-08-29 14:14                                 ` Geert Uytterhoeven
2022-08-29 14:33                                   ` Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 05/35] drm/connector: Add TV standard property Maxime Ripard
2022-08-08 12:44   ` Noralf Trønnes
2022-08-16  8:26     ` Maxime Ripard
2022-08-16  9:42       ` Noralf Trønnes
2022-08-16  9:49         ` Maxime Ripard
2022-08-16 19:35           ` Noralf Trønnes
2022-08-17 11:46             ` Maxime Ripard
2022-08-17 13:11               ` Noralf Trønnes
2022-08-17 23:23                 ` Noralf Trønnes
2022-08-18 15:01                   ` Noralf Trønnes
2022-08-18 15:31                     ` Maxime Ripard
2022-08-21 11:43                       ` Noralf Trønnes
2022-08-26  8:21                         ` Maxime Ripard
2022-08-18 15:27                 ` Maxime Ripard
2022-08-12 13:25   ` Geert Uytterhoeven
2022-08-16 13:20     ` Maxime Ripard
2022-08-16 13:29       ` Geert Uytterhoeven
2022-08-16 14:11         ` Maxime Ripard
2022-08-16 14:43           ` Geert Uytterhoeven
2022-08-16 15:49             ` Maxime Ripard
2022-08-17  7:31               ` Geert Uytterhoeven
2022-08-17  7:32                 ` Geert Uytterhoeven
2022-08-17  7:47                 ` Maxime Ripard
2022-08-17  8:35                   ` Geert Uytterhoeven
2022-08-17 11:14                     ` Maxime Ripard
2022-08-17 13:05                       ` Geert Uytterhoeven
2022-08-17 13:18                         ` Maxime Ripard
2022-08-17 14:04                           ` Geert Uytterhoeven
2022-08-18 14:54                             ` Maxime Ripard
2022-08-18 15:20                               ` Geert Uytterhoeven
2022-08-18 15:34                                 ` Maxime Ripard
2022-08-19  9:35                                   ` Geert Uytterhoeven
2022-08-25 13:39                                     ` Maxime Ripard
2022-08-20 20:12   ` Noralf Trønnes
2022-08-25 13:44     ` Maxime Ripard
2022-08-25 15:13       ` Noralf Trønnes
2022-08-29  8:28         ` Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 06/35] drm/connector: Only register TV mode property if present Maxime Ripard
2022-08-08 12:49   ` Noralf Trønnes
2022-08-15 10:40     ` Maxime Ripard
2022-08-15 10:49       ` Noralf Trønnes
2022-07-29 16:34 ` [PATCH v1 07/35] drm/modes: Only consider bpp and refresh before options Maxime Ripard
2022-08-12 13:25   ` Geert Uytterhoeven
2022-08-16 12:20     ` Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 08/35] drm/client: Add some tests for drm_connector_pick_cmdline_mode() Maxime Ripard
2022-08-02 10:14   ` Thomas Zimmermann
2022-08-15  8:42     ` Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 09/35] drm/modes: Move named modes parsing to a separate function Maxime Ripard
2022-08-12 13:27   ` Geert Uytterhoeven
2022-08-16 13:46     ` Maxime Ripard
2022-08-16 14:44       ` Geert Uytterhoeven
2022-07-29 16:34 ` [PATCH v1 10/35] drm/modes: Switch to named mode descriptors Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 11/35] drm/modes: Fill drm_cmdline mode from named modes Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 12/35] drmi/modes: Properly generate a drm_display_mode from a named mode Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 13/35] drm/atomic-helper: Add a TV properties reset helper Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 14/35] drm/atomic-helper: Add an analog TV atomic_check implementation Maxime Ripard
2022-07-29 17:16   ` Mateusz Kwiatkowski
2022-08-15  8:30     ` Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 15/35] drm/vc4: vec: Remove empty mode_fixup Maxime Ripard
2022-07-29 16:34 ` [PATCH v1 16/35] drm/vc4: vec: Convert to atomic helpers Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 17/35] drm/vc4: vec: Refactor VEC TV mode setting Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 18/35] drm/vc4: vec: Remove redundant atomic_mode_set Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 19/35] drm/vc4: vec: Fix timings for VEC modes Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 20/35] drm/vc4: vec: Switch for common modes Maxime Ripard
2022-07-29 18:12   ` Mateusz Kwiatkowski
2022-08-16 11:57     ` Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 21/35] drm/vc4: vec: Fix definition of PAL-M mode Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 22/35] drm/vc4: vec: Use TV Reset implementation Maxime Ripard
2022-07-30  3:03   ` kernel test robot
2022-07-29 16:35 ` [PATCH v1 23/35] drm/vc4: vec: Convert to the new TV mode property Maxime Ripard
2022-08-20 17:22   ` Noralf Trønnes
2022-08-24 15:26     ` Maxime Ripard
2022-08-25 13:14       ` Noralf Trønnes
2022-08-29 12:13         ` Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 24/35] drm/vc4: vec: Add support for more analog TV standards Maxime Ripard
2022-07-29 17:55   ` Mateusz Kwiatkowski
2022-08-15  8:37     ` Maxime Ripard
2022-08-24 16:59       ` Mateusz Kwiatkowski
2022-07-29 16:35 ` [PATCH v1 25/35] drm/sun4i: tv: Remove unused mode_valid Maxime Ripard
2022-07-30  9:13   ` Jernej Škrabec
2022-07-29 16:35 ` [PATCH v1 26/35] drm/sun4i: tv: Convert to atomic hooks Maxime Ripard
2022-07-30  9:12   ` Jernej Škrabec
2022-07-29 16:35 ` [PATCH v1 27/35] drm/sun4i: tv: Merge mode_set into atomic_enable Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 28/35] drm/sun4i: tv: Remove useless function Maxime Ripard
2022-07-29 16:35 ` [PATCH v1 29/35] drm/sun4i: tv: Remove useless destroy function Maxime Ripard
2022-07-30  9:14   ` Jernej Škrabec
2022-07-29 16:35 ` [PATCH v1 30/35] drm/sun4i: tv: Rename error label Maxime Ripard
2022-07-30  9:15   ` Jernej Škrabec
2022-07-29 16:35 ` [PATCH v1 31/35] drm/sun4i: tv: Add missing reset assertion Maxime Ripard
2022-07-30  9:16   ` Jernej Škrabec
2022-07-29 16:35 ` [PATCH v1 32/35] drm/sun4i: tv: Convert to the new TV mode property Maxime Ripard
2022-08-28 17:12   ` Noralf Trønnes
2022-07-29 16:35 ` [PATCH v1 33/35] drm/connector: Remove TV modes property Maxime Ripard
2022-07-29 20:06   ` kernel test robot
2022-07-29 20:16   ` kernel test robot
2022-07-29 16:35 ` [PATCH v1 34/35] drm/modes: Introduce the tv_mode property as a command-line option Maxime Ripard
2022-08-12 13:31   ` Geert Uytterhoeven
2022-08-16 13:51     ` Maxime Ripard
2022-08-20 20:18   ` Noralf Trønnes
2022-08-24 15:45     ` Maxime Ripard
2022-08-24 17:08       ` Mateusz Kwiatkowski
2022-08-25 12:41       ` Noralf Trønnes
2022-08-26  6:46         ` Maxime Ripard
2022-08-28 17:06           ` Noralf Trønnes
2022-07-29 16:35 ` [PATCH v1 35/35] drm/modes: Introduce more named modes Maxime Ripard
2022-08-21 16:16   ` Noralf Trønnes
2022-08-25 14:22     ` Maxime Ripard
2022-08-08 13:03 ` [PATCH v1 00/35] drm: Analog TV Improvements Noralf Trønnes
2022-08-21 16:33 ` Noralf Trønnes
2022-08-22  7:48   ` Maxime Ripard
2022-08-22  8:57     ` Mateusz Kwiatkowski
2022-08-25 15:55       ` Maxime Ripard
2022-08-25 16:17         ` Mateusz Kwiatkowski
2022-08-26  4:07           ` Mateusz Kwiatkowski
2022-08-26  8:39             ` Maxime Ripard
2022-08-26 14:56             ` Dom Cobley
2022-08-27 16:11               ` Noralf Trønnes
2022-08-30 21:31               ` kFYatek
2022-08-22 13:21     ` Noralf Trønnes
2022-08-25 16:21       ` Maxime Ripard
2022-08-25 19:36         ` Noralf Trønnes

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).