netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [patch net-next 00/15] introduce programable flow dissector and cls_flower
@ 2015-05-09 13:10 Jiri Pirko
  2015-05-09 13:10 ` [patch net-next 01/15] net: change name of flow_dissector header to match the .c file name Jiri Pirko
                   ` (15 more replies)
  0 siblings, 16 replies; 26+ messages in thread
From: Jiri Pirko @ 2015-05-09 13:10 UTC (permalink / raw)
  To: netdev
  Cc: davem, jhs, tgraf, jesse, kaber, therbert, edumazet,
	alexander.h.duyck, hannes, ast, daniel, herbert, cwang,
	john.fastabend

Per Davem's request, I prepared this patchset which introduces programmable
flow dissector. For current users of flow_keys, there is a wrapper
skb_flow_dissect_flow_keys which maintains the previous behaviour.
For purposes of cls_flower, couple of new dissection keys were introduced.

Note that this dissector can be also eventually used by openvswitch code.

Also, as a next step, I plan to get rid of *skb_flow_get_ports(export)
and *__skb_get_poff as their functionality can be now implemented by
skb_flow_dissect as well.

rfc->v1:
- only rebase

Jiri Pirko (15):
  net: change name of flow_dissector header to match the .c file name
  flow_dissector: remove unused function flow_get_hlen declaration
  net: move *skb_get_poff declarations into correct header
  flow_dissector: fix doc for __skb_get_hash and remove couple of empty
    lines
  net: move __skb_get_hash function declaration to flow_dissector.h
  net: move __skb_tx_hash to skbuff.c
  net: move netdev_pick_tx and dependencies to net/core/dev.c
  flow_dissector: fix doc for skb_get_poff
  flow_dissector: introduce programable flow_dissector
  flow_dissect: use programable dissector in skb_flow_dissect and
    friends
  flow_dissector: add missing header includes
  flow_dissector: introduce support for ipv6 addressses
  flow_dissector: introduce support for Ethernet addresses
  flow_dissector: change port array into src,dst tuple
  tc: introduce Flower classifier

 drivers/net/bonding/bond_main.c                |  20 +-
 drivers/net/ethernet/cisco/enic/enic_clsf.c    |  29 +-
 drivers/net/ethernet/cisco/enic/enic_ethtool.c |  10 +-
 drivers/net/hyperv/netvsc_drv.c                |   8 +-
 include/linux/skbuff.h                         |  11 +-
 include/net/flow_dissector.h                   | 167 ++++++
 include/net/flow_keys.h                        |  61 ---
 include/net/ip.h                               |  10 +-
 include/net/ipv6.h                             |  10 +-
 include/uapi/linux/pkt_cls.h                   |  31 ++
 net/core/dev.c                                 |  78 +++
 net/core/filter.c                              |   1 +
 net/core/flow_dissector.c                      | 380 ++++++++------
 net/core/skbuff.c                              |  28 +
 net/ethernet/eth.c                             |   7 +-
 net/sched/Kconfig                              |  10 +
 net/sched/Makefile                             |   1 +
 net/sched/cls_flow.c                           |  22 +-
 net/sched/cls_flower.c                         | 688 +++++++++++++++++++++++++
 net/sched/sch_choke.c                          |   6 +-
 20 files changed, 1283 insertions(+), 295 deletions(-)
 create mode 100644 include/net/flow_dissector.h
 delete mode 100644 include/net/flow_keys.h
 create mode 100644 net/sched/cls_flower.c

-- 
1.9.3

^ permalink raw reply	[flat|nested] 26+ messages in thread

end of thread, other threads:[~2015-05-12 11:38 UTC | newest]

Thread overview: 26+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-05-09 13:10 [patch net-next 00/15] introduce programable flow dissector and cls_flower Jiri Pirko
2015-05-09 13:10 ` [patch net-next 01/15] net: change name of flow_dissector header to match the .c file name Jiri Pirko
2015-05-09 13:10 ` [patch net-next 02/15] flow_dissector: remove unused function flow_get_hlen declaration Jiri Pirko
2015-05-09 13:10 ` [patch net-next 03/15] net: move *skb_get_poff declarations into correct header Jiri Pirko
2015-05-09 13:10 ` [patch net-next 04/15] flow_dissector: fix doc for __skb_get_hash and remove couple of empty lines Jiri Pirko
2015-05-09 13:10 ` [patch net-next 05/15] net: move __skb_get_hash function declaration to flow_dissector.h Jiri Pirko
2015-05-09 13:10 ` [patch net-next 06/15] net: move __skb_tx_hash to skbuff.c Jiri Pirko
2015-05-11 15:55   ` Alexander Duyck
2015-05-11 16:01     ` Jiri Pirko
2015-05-11 23:21   ` Cong Wang
2015-05-12  5:22     ` Jiri Pirko
2015-05-09 13:10 ` [patch net-next 07/15] net: move netdev_pick_tx and dependencies to net/core/dev.c Jiri Pirko
2015-05-09 13:10 ` [patch net-next 08/15] flow_dissector: fix doc for skb_get_poff Jiri Pirko
2015-05-09 13:10 ` [patch net-next 09/15] flow_dissector: introduce programable flow_dissector Jiri Pirko
2015-05-09 13:10 ` [patch net-next 10/15] flow_dissect: use programable dissector in skb_flow_dissect and friends Jiri Pirko
2015-05-09 13:10 ` [patch net-next 11/15] flow_dissector: add missing header includes Jiri Pirko
2015-05-09 13:10 ` [patch net-next 12/15] flow_dissector: introduce support for ipv6 addressses Jiri Pirko
2015-05-09 13:10 ` [patch net-next 13/15] flow_dissector: introduce support for Ethernet addresses Jiri Pirko
2015-05-09 13:10 ` [patch net-next 14/15] flow_dissector: change port array into src,dst tuple Jiri Pirko
2015-05-09 13:10 ` [patch net-next 15/15] tc: introduce Flower classifier Jiri Pirko
2015-05-11 12:08   ` Jamal Hadi Salim
2015-05-11 12:39     ` Jiri Pirko
2015-05-11 15:30     ` Jiri Pirko
2015-05-12 11:31       ` Jamal Hadi Salim
2015-05-12 11:37         ` Jiri Pirko
2015-05-09 21:29 ` [patch net-next 00/15] introduce programable flow dissector and cls_flower Tom Herbert

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).